VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 ... 3 4 [5] 6 7 ... 10
 41 
 on: December 29, 2017, 05:54:32 am 
Started by vector - Last post by M0E-lnx
Thanks for testing @nightflier.

@amo_en.ch try this:

Head over to http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.2/
and look in the x86 or x86_64 subdirs, whichever matches your installed architecture (see uname -m)

Download the kernel4.4, kernel4.4-modules and kernel4.4-stripped-src versions 4.4.108

Open a terminal and cd to the directory holding the .txz packages. ..  Then in that terminal, su to root and install them with the --no-upgrade option, then update the bootloader.

Code: [Select]
installpkg --no-upgrade *.t?z
grub-mkconfig -o /boot/grub/grub.cfg

After that reboot, and select the 4.4.108 kernel from your boot menu.
The alx module is built-in, so if it'll work, it should work out of the box.

Let me know if this does it for you.

 42 
 on: December 29, 2017, 04:41:43 am 
Started by vector - Last post by nightflier
@amo_en.ch: M0E-lnx is working on a new kernel that should support your hardware. Watch this thread for further instructions.

@M0E-lnx: In a vm, I did a kernel upgrade to the kernel4.4-4.4.108-x86_64 in untested. First look seems fine.

 43 
 on: December 29, 2017, 02:54:02 am 
Started by vector - Last post by amo_en.ch
Thanks for all your help but I'm out of my depth with your link. Will try immediately if you tell me what I should do.

 44 
 on: December 28, 2017, 01:52:59 pm 
Started by vector - Last post by M0E-lnx
Tried as suggested but got the same errors.

Quote
/home/allan/compat-drivers-2013-03-04-u/config.mk:21: *** "ERROR: compat-drivers by default supports kernels >= 2.6.24, try enabling only one driver though".  Stop.


Looks as though you're right about old drivers.

Googled a lot and lots of distros seem to have this problem for kernels 3 and 4. There is normally a solution provided but obviously only for their distro.

Looks like the solution may be easier than this.

https://cateee.net/lkddb/web-lkddb/ALX.html

Looks like the alx module has been present in the kernel tree since the 3.10 days.  I'm doing a minor version update to our 4.4 build and will build with CONFIG_ALX enabled.  Per the link above, your device should be supported by this.  Watch out for 4.4.108 in the untested repos at http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.2.  I will post again when the build is complete so you can try

 45 
 on: December 28, 2017, 10:24:34 am 
Started by vector - Last post by amo_en.ch
Tried as suggested but got the same errors.

Quote
/home/allan/compat-drivers-2013-03-04-u/config.mk:21: *** "ERROR: compat-drivers by default supports kernels >= 2.6.24, try enabling only one driver though".  Stop.


Looks as though you're right about old drivers.

Googled a lot and lots of distros seem to have this problem for kernels 3 and 4. There is normally a solution provided but obviously only for their distro.


 46 
 on: December 28, 2017, 07:43:20 am 
Started by vector - Last post by M0E-lnx
Guys,
I think the drivers you're trying to compile are intended for use with the 3.x kernel series.  Not sure what kind of luck you'll have with the 4.x series.

I got a little further past the error by following https://github.com/erikarn/alx
I had to rebuild the kernel to disable CFG80211 and CFG80211_EXT which aparently conflict with this.  I'm short on time, but if I do get time, I'm gonna try this with the 3.x LTS kernel and see if that can be fixed.

Has anyone read any solutions to this using the 4.x kernel?

 47 
 on: December 28, 2017, 07:06:12 am 
Started by vector - Last post by nightflier
There is a discrepancy between your kernel version and the src pkg (4.4.76 vs. 4.4.107).
Try pkg: http://vectorlinux.osuosl.org/veclinux-7.2/extra/Fonts/kernel4.4-src-4.4.76-x86-1vl72.txz

Side note: with an i7 system, I would choose the 64 bit version.  ;)

 48 
 on: December 28, 2017, 03:33:08 am 
Started by vector - Last post by amo_en.ch
No problem

Quote
vector:/~
allan:$ cat /etc/vector-version
7.2 LIGHT Final built on Aug-21-2017
vector:/~
allan:$ uname -a
Linux vector.linux.vnet 4.4.76 #1 SMP Wed Jul 5 10:26:28 CDT 2017 i686 Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz GenuineIntel GNU/Linux
vector:/~


 49 
 on: December 27, 2017, 12:55:09 pm 
Started by vector - Last post by M0E-lnx
Ok, I think i'm confused.

Can you post the output of 'cat /etc/vector-version' and 'uname -a' please?

 50 
 on: December 27, 2017, 08:11:26 am 
Started by vector - Last post by amo_en.ch
I tried on VL 7.1 because I couldn't find newer source files. My experience of kernels and modules is virtually inexistant but here's what I tried today.

Downloaded kernel4.4-stripped-src-4.4.107-x86-1vl72.txz. Installed VL 7.2 light.

Quote
root:# lspci
03:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)
vector://home/allan

Because I haven't Gslapt

Quote
installpkg kernel4.4-stripped-src-4.4.107-x86-1vl72.txz

Got a few errors concerning symlinks in arch presumably because the sources aren't complete. Remade symlinks between /lib/modules and /usr/source

Ran driver-select alx, and make

Quote
vector://home/allan/compat-drivers-2013-03-04-u
root:# ./scripts/driver-select alx
Processing new driver-select request...
Backing up makefile: Makefile.bk
Backup exists: Makefile.bk
Backing up makefile: drivers/net/ethernet/broadcom/Makefile.bk
Backing up makefile: drivers/net/ethernet/atheros/Makefile.bk
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backup exists: drivers/net/ethernet/broadcom/Makefile.bk
vector://home/allan/compat-drivers-2013-03-04-u
root:# make
./scripts/gen-compat-autoconf.sh /home/allan/compat-drivers-2013-03-04-u/.config /home/allan/compat-drivers-2013-03-04-u/config.mk > include/linux/compat_autoconf.h
sed: character class syntax is [[:space:]], not [:space:]
make -C /lib/modules/4.4.76/build M=/home/allan/compat-drivers-2013-03-04-u modules
make[1]: Entering directory '/usr/src/linux-4.4.107'
/home/allan/compat-drivers-2013-03-04-u/config.mk:21: *** "ERROR: compat-drivers by default supports kernels >= 2.6.24, try enabling only one driver though".  Stop.
Makefile:1405: recipe for target '_module_/home/allan/compat-drivers-2013-03-04-u' failed
make[1]: *** [_module_/home/allan/compat-drivers-2013-03-04-u] Error 2
make[1]: Leaving directory '/usr/src/linux-4.4.107'
Makefile:89: recipe for target 'modules' failed
make: *** [modules] Error 2

I think that I have done things correctly but I have no idea where this error message leaves me

Pages: 1 ... 3 4 [5] 6 7 ... 10