VectorLinux
November 23, 2014, 07:53:09 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: DVDrip  (Read 4158 times)
InTheWoods
Vectorite
***
Posts: 302


« on: July 02, 2009, 01:40:29 pm »

I get the following error when trying to run DVDrip

Code:
dvdrip
Can't locate Gtk2.pm in @INC (@INC contains: lib /usr/lib/perl5/5.10.0/i586-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at /usr/bin/dvdrip-splash line 10.
BEGIN failed--compilation aborted at /usr/bin/dvdrip-splash line 10.
Can't locate Gtk2.pm in @INC (@INC contains: lib /usr/lib/perl5/5.10.0/i586-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/site_perl/5.8.8/Video/DVDRip/GUI/Main.pm line 18.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Video/DVDRip/GUI/Main.pm line 18.
Compilation failed in require at /usr/bin/dvdrip line 97.

The package is dvdrip 0.98.8-i586-9gsb from the extras portion of the repository.
I am running it on vl6.0 standard. Can this be fixed or does a new package need to be compiled?
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2290


« Reply #1 on: July 02, 2009, 02:23:56 pm »

Hi InTheWoods, try installing this package: gtk2-perl-1.164-i586-4gsb
Let me know if this solves it, and I will fix the missing dep.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
InTheWoods
Vectorite
***
Posts: 302


« Reply #2 on: July 26, 2009, 02:31:56 am »

gtk2-perl-1.164-i586-4gsb is installed already.
Logged
markus
Member
*
Posts: 9


« Reply #3 on: July 26, 2009, 07:25:33 pm »

Coincidentally I am also trying to get this package running and have the same error.  I tried reinstalling Gtk2-perl but with no luck.
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2290


« Reply #4 on: July 26, 2009, 08:49:25 pm »

Oops, I have dvdrip working here, but was a long time ago when I installed it and I forgot how I did it.
You may want to try installing Gtk2-perl from cpan.
Try as root:

Code:
cpan Gtk2

If it is your first time using cpan, it will ask some questions about mirrors and other burocratic stuff, default answers usually work fine.

HTH
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
InTheWoods
Vectorite
***
Posts: 302


« Reply #5 on: July 27, 2009, 12:38:35 pm »

I tried to install Gtk2-perl from cpan. I used the default configuration options but was unable to install do to the following depenancies missing.

Code:
    ExtUtils::Depends 0.300
    Glib not installed
    Pango not installed

I checked with gslapt and it appears that those dependancies are actually installed.

Hmmm....
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #6 on: August 11, 2009, 09:00:57 pm »

I was curious if solution was found..I am useing dvdshrink with wine on VL6.0 but a linux solution would be interesting
Logged

Everything Is Relative
OU812
Vectorite
***
Posts: 156



« Reply #7 on: August 12, 2009, 08:54:19 pm »

Does it have something do with glade-xml?

john
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #8 on: August 12, 2009, 09:24:17 pm »

those look like perl dependancies
you should be able to install them all with CPAN
Logged
InTheWoods
Vectorite
***
Posts: 302


« Reply #9 on: August 13, 2009, 03:15:29 am »

I tried to install the above dependancies with CPAN but I get the following error after config errors.

Code:
Please install them manually.
Warning (usually harmless): 'YAML' not installed, will not store persistent state
Logged
InTheWoods
Vectorite
***
Posts: 302


« Reply #10 on: August 13, 2009, 04:07:57 am »

Got it working

As root Install YAML
Code:
cpan YAML
install Glib
Code:
cpan Glib
install Pango
Code:
cpan Pango
install Gtk2
Code:
cpan Gtk2
now you can finally install the GSLAPT "DVDrip" package
and it appears to work ( I have'nt got a dvd to test with right now but I do have a GUI)

I think its safe to say the package in the repository needs some work.
thanks for the help.
And by the way I found this article some of the more intrepid Vector users may be interested in.http://www.stonehenge.com/merlyn/LinuxMag/col42.html
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!