VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Solved:Gslapt on drugs?  (Read 1210 times)

OldNoob

  • Member
  • *
  • Posts: 20
Solved:Gslapt on drugs?
« on: July 01, 2009, 12:54:22 pm »

Hi, i like VL6 very much it's a great leap forward, everything except autoupdate works fine, there's a strange issue of up-downgrading of some packages.
Latest example Firefox was to be upgraded from version 3.10 to 3.5, worked nice! Next day time for another upgrade? Now gslapt want to go to firefox 3.10??? Yeah ok. Next day it want to upgrade to 3.11, wow improvement here!!!
Now i manually upgraded firefox and i feel that the fun part comes after next reboot, be back after. Roffe :)
Hi i'm back again and yep gslapt really can't wait to "upgrade" to 3.11 WTF??? I also tried with deleting cached packet files, but same shit. Roffe ???
« Last Edit: July 01, 2009, 04:08:59 pm by OldNoob »
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3275
Re: Gslapt on drugs?
« Reply #1 on: July 01, 2009, 01:38:36 pm »

I think this is just one more case of the troublesome priorities in your software source lines.
Look in your /etc/slapt-get/slapt-getrc file for keywords like "PREFERRED" and "OFFICIAL"
remove any similar keyword at the end of each repo line and you should be fine.

OldNoob

  • Member
  • *
  • Posts: 20
Re: Gslapt on drugs?
« Reply #2 on: July 01, 2009, 04:07:46 pm »

Thanks mucho for the fast help.
That did it, seemed like a constipated dog finally got relieved when a lot of upgrades came up totally 27Mb nice!
Well almost, something happened with the icons in menubar i think xfcerelated part of upgrades.
Opera downgraded and bookmarks lost but that's life, i will fix that later.
Who said computers are boring? ;D Roffe
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2321
Re: Solved:Gslapt on drugs?
« Reply #3 on: July 01, 2009, 05:18:13 pm »

OldNoob: be careful while upgrading with testing enabled.
Try this command as root for the Xfce icons:

Code: [Select]
/usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!