VectorLinux
September 02, 2014, 12:59:33 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Upgrade FAILED  (Read 1039 times)
edgeofthewoods
Member
*
Posts: 62


« on: July 14, 2009, 07:45:09 pm »

K I have resisted it for months, but the urge finally got the best of me. I hit the upgrade button that was in the task bar, let it do it's thing and restarted the machine. BOOM itsa dead machine! Sad  It boots fine but goes to an alien login screen. Looks kind of like and old KDE login. OK I type in my user name and password and it acts like it is going to start and BOOM back to the login. OK I restart and go to the TUI login to try to use SLAPT and remove the upgrade it boots back to the KDE Login screen. Right now I am the Debian side of my system, (My wife likes Linux Mint 7) So any ideas on how to fix my Vector System. Debian is so S>>>>>>>>>>L>>>>>>>>>>>>>>>O>>>>>>>>>>>W!

Chuck
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: July 14, 2009, 08:52:02 pm »

Quote
K I have resisted it for months, but the urge finally got the best of me. I hit the upgrade button that was in the task bar, let it do it's thing and restarted the machine. BOOM itsa dead machine! Sad

If I had to guess I would say that you did a system upgrade with the testing repository enabled.  ( I wish there was a warning that popped up for that kind of thing)

Sound like kdm has highjacked top spot as your Display Manager.  I'm assuming you were using VL-6.0 standard and GDM was your display manager and XFCE was your desktop environment before this all happened.
The first step would be to get you back to the gdm login screen.   Start your machine in TUI mode and set yourself up as a root user. In the terminal type...
 nano /etc/rc.d/rc.X
Eleven lines down there is a line that reads...DISPLAY_MANAGER=KDM
Change it to read.... DISPLAY_MANAGER=GDM
Then ctrl +X and 'Y' (for yes) to save your changes.

Type 'init 6' in the terminal while still root, this will restart your machine.  Hopefully, you will now see the familiar GDM Display manager.

Side note.
You should still be able to launch into XFCE from the kdm Display Manager.  You just need to reselect it as your session from the KDM menu.

This is only a fix for KDM hijacking the display manager top spot. If your troubles run deeper, let us know.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
edgeofthewoods
Member
*
Posts: 62


« Reply #2 on: July 14, 2009, 08:55:17 pm »

Thanks but I tried that and the TUI login sends me straight to the GUI login screen. I am thinking I may try to do something with the live CD. I am using VL6.0 Deluxe. Thanks again

Chuck
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #3 on: July 15, 2009, 05:30:13 am »

I'm gonna take another wild guess and say your /etc/slapt-getrc had priority keywords before your upgrade.
I have done upgrade even w/ the testing repos enabled, and never had a problem. The story is a lot different when these priority keywords are present in the config file.

grep the borked VL's /etc/slapt-getrc for words like "OFFICIAL","PREFERED", etc

If you did, I'm afraid you have no other solution but to re-install.
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!