VectorLinux
July 29, 2014, 02:46:18 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: amsn with sound  (Read 3075 times)
VectorWal
Member
*
Posts: 8


« on: July 09, 2009, 03:59:05 am »

Hi there, being totally new to vectorlinux I want to use amsn with sound. In the preferences-other stuff it says I have to install snack. Followig the install instructions it says at the point ./configure etc that tclconfigure.sh and tkconfigure.sh aren't present. They appear to be one directory up so I installed in /usr/lib instead of /usr/lib/tcl8.4.
Is this correct for it still doesn't work. Anyone who can help me out ?
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: July 09, 2009, 09:21:15 am »

Try this...
Open the terminal in the snack2.2.10/unix directory

Paste the following code into the terminal and press enter.
Code:
./configure  --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--disable-debug \
--enable-alsa \
--with-tcl=/usr/lib \
--with-tk=/usr/lib \
--with-ogg-include=/usr \
--with-ogg-lib=/usr \
--program-prefix= \
--program-suffix=

then just type
make


That should do it. Let me know how it goes.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
VectorWal
Member
*
Posts: 8


« Reply #2 on: July 10, 2009, 03:01:07 am »

Thanks for your reply,
The installation went wel (I think) I went to snack2.2.10/unix, pasted your code into the terminal, did enter and then make.
After that I went to amsn and tried the preferences/sound and it still says that snack
isn't loaded.  greetz Wal
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: July 10, 2009, 10:44:32 am »

Hi; I messed with this for better than an hour after reading your post.  I've tryied moving the snack libraries around every where I can thing of and recompiled with a couple different options.  I'm starting to think the trouble is in the tcl and tk programs.

From the snack readme file...
Code:
You must have Tcl/Tk installed on your system. Both Tcl and Tk must have
been configured with the "--enable-shared" flag at build time (this is
default for the 8.4 versions). Build them before Snack.

I can not find the source for tcl and tk in the VL FTP Repository, so I can not determine if they have been compiled with the --enable-shared option or not.  If they have not that could be our problem.

Is there anyone out there who may be able to determine this.  Otherwise, I may have time next week to build a new tcl and tk.  We could try again then.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
VectorWal
Member
*
Posts: 8


« Reply #4 on: July 12, 2009, 07:43:02 am »

OK, I think I'll have to wait for you then
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #5 on: July 13, 2009, 10:43:34 am »

OK, give me until Friday.  I'll see if rebuilding tcl/tk with the option mentioned does anything.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
rbistolfi
Packager
Vectorian
****
Posts: 2277


« Reply #6 on: July 13, 2009, 12:26:30 pm »

I will have to make the time to check it out, but I would guess the tcl shared libraries are built. Check if there is an option for declaring the tcl location in the configure script. It is in /usr/lib/tcl8.4
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #7 on: July 13, 2009, 01:58:53 pm »

Hi rbistolfi;
It would be great if you could take a look. My snack build is still in my vectorcontrib folder if you want to save some time and work with something already started.  You are right that there is an option to declare the tcl location, but when I use /usr/lib/tcl8.4 the configure script complains that tclconfigure.sh and tkconfigure.sh aren't present.   The configure script runs flawlessly when /usr/lib is declared as the location for tkconfigure.sh and tclconfigure.sh.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
VectorWal
Member
*
Posts: 8


« Reply #8 on: July 14, 2009, 03:47:39 am »

Hi guys, An idea of a newbie. Could that be the problem, that the tcl/tk-configure.sh files
aren't in the same directorie (tcl/tk-8.4) ? They are 1 dir up. ?
greetz Wal
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #9 on: July 20, 2009, 11:05:10 am »

 I don't use amsn myself...just Skype but I just wanted to bring this thread up again as I think aMSN with sound would be important to a number of users.

@VectorWal, have you been able to get this going at all? If yes, how?

@rbistolfi, perhaps after your work on soho 6.0 you could share some of your wisdom.

Also open to anyone else who would like to take a stab at it.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
rbistolfi
Packager
Vectorian
****
Posts: 2277


« Reply #10 on: July 20, 2009, 12:50:27 pm »

@rbistolfi, perhaps after your work on soho 6.0 you could share some of your wisdom.

I promise to share it if I can find some Grin
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
VectorWal
Member
*
Posts: 8


« Reply #11 on: July 21, 2009, 08:51:55 am »

strechtethin, I got aMSN working with the webcam but no sound. If I could use Skype it would be the same for me. could yoy tell me how I have to install Skype ?
(as soon as I've got amsn working with sound, I'll let you know)
greetz Wal
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #12 on: July 21, 2009, 11:43:27 am »

Hi VectorWal;

I have a link here to some screencasts that should help.
http://www.opensourcebistro.com/Tutorial/VL60/11.Network-apps/page

The last 4 links on the page are about installing Skype. Use the one about installing from a .tlz in the 5.9 library first.

I'll keep a watch on this thread if you have any questions.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
VectorWal
Member
*
Posts: 8


« Reply #13 on: July 29, 2009, 01:48:09 am »

hi stretchedthin, yes I have a question. I installed skype and its working. The video is
even better ! But when I try the testcall I can hear the lady speaking, but I cannot get
my mic to work. Do you have any suggestions ? greetz Wal
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #14 on: July 29, 2009, 09:57:02 am »

Hi VectorWal;
There are a couple things to check...
First click on the xfce4-mixer-applet...Speaker icon in the corner.  Make sure that the slider for capture is turned up.
Second in a terminal type alsamixer.  Tab to the capture part of that and make sure nothing is muted.

Here is a screencast that has examples of the above.
http://www.opensourcebistro.com/Tutorial/VL60/02.Beginners-guide/sound/sound.htm

Finally you can make adjustment in skype itself.  I have one laptop where my mic port just does not work.  With this method I can use the usb mic that is included with my webcam.
Here it is...Sorry no screencast.  Cry
When you are using skype there is a little skype S at the bottom left. Click it and a menu will drop down.  Choose 'Options'.

From the resulting menu choose 'Sound Devices'
There you can choose what your sound in device will be.  Assuming you have a usb type webcam with microphone built in you would choose that.
You can also choose your sound out device so that the incoming voice only goes to your headphones.

Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!