VectorLinux
November 28, 2014, 05:04:04 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: [SOLVED] Getting an audio CD to auto-play in V Linux Light  (Read 3334 times)
Silent Music
Member
*
Posts: 20


« on: July 17, 2009, 07:01:38 am »

Hi,
I am new to Vector Linux, and I like what I see so far. I have the light edition with the LXDE desktop.
Most things are working well, but, unfortunately, I cannot play an audio CD in the CD ROM drive. The drive is working because I can mount it when it holds a data CD, but when I put an audio CD in nothing happens. The activity light flickers for a few moments and then goes out. The sound is working OK, and I can play a WAV file or an MP3 file on my computer, but not from the optical drive.
Can someone please help me? I feel it is just a matter of configuring something or turning something on, but I cannot see what it is.
Silent Music
« Last Edit: July 19, 2009, 03:35:05 pm by Silent Music » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4031



« Reply #1 on: July 17, 2009, 07:37:43 am »

For CDROM auto-play, you need HAL instead of Light's default (vl-hot).
As root, run vasm > hardware > mounter.

I'm not very familiar with LXDE, maybe someone else can shed some light on that. Do some experimenting after changing the mounter.
Logged
Silent Music
Member
*
Posts: 20


« Reply #2 on: July 17, 2009, 11:44:58 am »

Thanks. Now I know what I am looking for.
Unfortunately VASM seems a bit buggy, at least on LXDE. It kept jumping to another menu when I clicked Mounter, then it told me that I needed to drop down to TUI mode, so I did that, but that did not help. I still could not access the  Mounter menu. When I selected it and hit OK, it kept jumping away to another menu in the list.
Is there some command line coding that I can do instead to change vlhot to HAL?
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #3 on: July 17, 2009, 01:12:59 pm »

Code:
chmod +x /etc/rc.d/rc.hald
        /etc/rc.d/rc.hald start
        mv /etc/udev/rules.d/10-vl-hot.rules /etc/udev/rules.d/10-vl-hot.rules.disabled
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #4 on: July 17, 2009, 03:47:31 pm »

... or for a graphical way to do it, run vhalswitch as root in a terminal. vhalswitch is the script which should run when you click Mounter in VASM.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
Silent Music
Member
*
Posts: 20


« Reply #5 on: July 18, 2009, 12:52:33 pm »

Thanks for trying to help.
Coding: chmod +x /etc/rc.d/rc.hald
returns: chmod: cannot access '/etc/rc.d/rc.hald' : No such file or directory.

Coding: vhalswitch
returns: vhalswitch: command not found

Does this mean that HAL is not installed in Vector LL? There must be another way of doing it then?
I know the CD drive is working properly, because it works under the Linux distro installed on hda. VectorLL is installed on hdb.

Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #6 on: July 18, 2009, 02:56:22 pm »

Did you su to root before you ran those commands? You have to be root to use them.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Silent Music
Member
*
Posts: 20


« Reply #7 on: July 18, 2009, 03:54:16 pm »

Yes, I always call up the root terminal, which doesn't do anything until you  log in with the pw.
In the /etc/rc.d folder there is an rc.cdrom file and an rc.cdrom.old file, so I switched them over. That didn't help, so I switched them back.
I then uncommented this line in the restored rc.cdrom file:
#BUS=="ide", KERNEL=="*[!0-9]", ENV{PHYSDEVDRIVER}=="ide-cdrom", NAME="%k", GROUP="cdrom", MODE="0660", RUN+="/lib/udev/cdrom-symlinks.sh %k"
and made the rc.cdrom file executable:
 chmod +x  /etc/rc.cdrom
I am now going to reboot and see if that makes any difference.
....................No, it made no difference.  I am not sure what I should try next. Have any other Vector Light users with the LXDE desktop had this problem?
« Last Edit: July 18, 2009, 04:50:46 pm by Silent Music » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4031



« Reply #8 on: July 18, 2009, 06:10:28 pm »

Does it work when inserting an audio CD, then clicking the CDROM icon on the desktop, then selecting the Audio CD option?
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #9 on: July 18, 2009, 06:39:37 pm »

Oops, I think the command that I meant was /sbin/vhalswitch  (run it as root in a terminal)
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
Silent Music
Member
*
Posts: 20


« Reply #10 on: July 19, 2009, 02:35:04 am »

Thanks to all you guys for trying to be helpful.
Nightflier: There is a 'Mount CDROM' icon permanently on the desktop. Double left clicking tries to execute a mount, which is only successful with a data CD, not with an audio CD. Right clicking the icon gives a few options, but 'Audio CD' is not one of them. No temporary icon appears on the desktop when I put an audio CD in the drive
Daniel: /sbin/vhalswitch returns: No such file or directory. When looking in the /sbin directory, you go from vgrubconf to vhwconf - no vhalswitch.

I guess you guys are using the SOHO edition. I am beginning to think, perhaps I ought to be too. I have installed the Light edition. It seems to do things differently.

There look to be some useful messages about the CDROM drive on the boot-up screen, but they flash by so fast that I cannot read them. Is there some way of writing all those messages to a /var/log file? In Ubuntu there is a way of doing this, but if there is a way of doing this in Vector Linux Light, it is not done in the same way. I would be grateful if anyone would let me know how it is done.

Logged
nightflier
Administrator
Vectorian
*****
Posts: 4031



« Reply #11 on: July 19, 2009, 04:32:11 am »

Sounds like you are using VL Light 5.9, not the newer 6.0?

You will need to launch a multimedia player for audio discs. Xine has a "CD" button on the default interface. In XMMS, use "Play directory" > /mnt/cdrom

In 5.9, on the JWM menu, there is a menu entry labeled "Play audio CD".

To look for startup messages, look through the file /var/log/messages (as root).
« Last Edit: July 19, 2009, 04:34:20 am by nightflier » Logged
Silent Music
Member
*
Posts: 20


« Reply #12 on: July 19, 2009, 03:33:59 pm »

Yes I was using v 5.9.
I am afraid I could not get audio CDs to play, despite your instructions. I have upgraded to v 6.0, and now CDs and DVDs are playing in the DVD Rom drive. Things are working well.

I prefer the new designs and art work, and I think it looks great. Thank you for all your hard work. Was there any reason why you dumped LXDE? Did you consider like me that it is still a bit too buggy for comfort?
I'll go away and read the forums now. I haven't had a chance to do that yet.
Thanks again.
Silent Music
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #13 on: July 19, 2009, 07:25:00 pm »

LXDE is now the alternative desktop for VL6 Standard; XFce is the default desktop.

The default desktop for VL6 Light is IceWM. The alternative is JWM. IceWM is very light on the system, but JWM is even lighter.

I'm glad you got your CDs playing. By the way, you don't mount audio CDs. They don't have a mountable file system. You just tell the CD playing software where to find it.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Silent Music
Member
*
Posts: 20


« Reply #14 on: July 20, 2009, 02:32:39 am »

Thanks GrannyGeek and thank you all for being so helpful. This is a helpful forum.
I like the implementation of IceWM, but I appreciate the greater functionality of LXDE, even though it does appear a bit buggy. Xfce seems more robust. I suppose I can install LXDE for VectorLinux Light. It won't mess up anything, will it?
In particular with IceWM, I should like to customise the panel, and put short-cut icons for frequently use apps there, but at first sight it doesn't look as though this can be done. I know this is slightly off topic now, but any advice on that would be appreciated.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!