Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Installing 10g Express on VL6 - or maybe not  (Read 2155 times)


  • Member
  • *
  • Posts: 57
Installing 10g Express on VL6 - or maybe not
« on: August 01, 2009, 11:57:07 am »


I notice Vorlin was an Oracle admin, and now uses VL. I'm hoping either he, or someone, can shed some light on this. I've tried to install Oracle XE server a couple of times on my VL 6 machine. I got a few errors, two of which I seem to have eliminated. However, the "configure" part of the installation hangs, and I can't get it to actually run.

I uninstalled, got the latest download, reinstalled. Installation went fine again - or seemed to, no error messages. One issue was the dba group members, I fixed that. I made sure that the kernel parameters were set according to Oracle's 10g XE table (using sysctl), and turned off the firewall jic that's causing the hiccup. I run the config, and it still hangs in the "starting the listener" mode. I let it sit there for 15 or 20 minutes.

What does the configure do when it is starting the netlistener? What could be going wrong? Could there be an issue if the firewall was keeping ports closed (although I set it to be open for input and output on 8080 and 1521)? I've tried running ps to determine what processes are running with the firewall on and off - there is no difference. I've tried using nmap from another machine, again with the firewall on and off, no difference, everything is closed or filtered. Firestarter seems to be integrated with the kernel, and that's too deep for my Linux knowledge to manage.

Aug 3, morning. I'm changing the status of this post, and reposting in another area. This issue is Vector specific. I just installed the same package on Ubuntu -- and -- it just worked. No issues. It could be alien misses something in translating the install package out of deb into tgz, could be something else. I suspect something else, but I've been around long enough to know --> I don't know.

« Last Edit: August 03, 2009, 07:21:08 am by Hiero2 »