VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: [1] 2

Author Topic: Strange Update  (Read 3917 times)

Pita

  • Vectorian
  • ****
  • Posts: 1326
Strange Update
« on: July 28, 2009, 09:23:26 pm »

HP Mini-Note 2133, VL-6.0-STD-Gold

Owner of machine made an automated update. After rebooting all the icons on the
panel were missing and the xfce-menu applet was gone. I do not know what was
updated. Whatever it was that was not nice to happen. Added the icons now again
manually.
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Strange Update
« Reply #1 on: July 28, 2009, 10:58:46 pm »

If you had testing enabled its like xfce4 got updated to 4.6.0
Try reinstalling the hicolor-icon-theme package for solving a known issue with Xfce.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Strange Update
« Reply #2 on: July 28, 2009, 11:00:46 pm »

btw, you can see the upgraded packages in /var/log/pkgtools, maybe worth to take a look there.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

Pita

  • Vectorian
  • ****
  • Posts: 1326
Re: Strange Update
« Reply #3 on: July 28, 2009, 11:57:00 pm »

If you had testing enabled its like xfce4 got updated to 4.6.0
Try reinstalling the hicolor-icon-theme package for solving a known issue with Xfce.

I suspected that it was xfce4, however, testing was not enabled. I just double-checked.
Owner of machine would not know how to enable it.

Updated on July 28 were packages to:

hardinfo-0.5.1
ruby-1.8.6
thunar-volma-0.2.0

and yes

xfce4-4.6.0

Regards

Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Strange Update
« Reply #4 on: July 29, 2009, 08:48:41 am »

Yes pita, sorry, the packages were moved to extra...
The solution would be to reinstall the hicolor-icon-theme... the owner can do it through gslapt, I think its easy enough.
If you can pass him a long command, running this as root should fix it also:
Code: [Select]
/usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: Strange Update
« Reply #5 on: July 29, 2009, 10:09:34 am »

Sounds like the same issue I experienced:

http://forum.vectorlinux.com/index.php?topic=10224.0
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

zhymm

  • Packager
  • Member
  • ****
  • Posts: 20
Re: Strange Update
« Reply #6 on: July 29, 2009, 10:41:35 pm »

Aye, this issue bit me in the behind, also.  I simply replaced the missing icons on my panel.  I noticed a blank icon was present on mouse-over, so just did a right-click/properties and searched for an appropriate icon.

The Xfce Menu was restored when I rebooted (sounds like an old Windows tactic ... reboot). :P

One problem I have not resolved is missing icon(s) for panel applet(s).  My sound mixer icon vanished and I know not how to restore it.  :'(

Old Man Zhymm
Logged
If I were organized I'd be dangerous.

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Strange Update
« Reply #7 on: July 30, 2009, 07:23:28 am »

Hi zhymm,

Try running this command as root:
Code: [Select]
/usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
Let us know
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

zhymm

  • Packager
  • Member
  • ****
  • Posts: 20
Re: Strange Update
« Reply #8 on: July 30, 2009, 10:32:34 am »

Hi zhymm,

Try running this command as root:
Code: [Select]
/usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
Let us know
Tried the above.

Nope, no sound icon love here.  :-[
Logged
If I were organized I'd be dangerous.

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Strange Update
« Reply #9 on: July 30, 2009, 11:44:46 am »

:(

Maybe reinstalling the hicolor-icon-theme package through gslapt ot slapt-get. I will try to take a closer look when I get home from work.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: Strange Update
« Reply #10 on: July 30, 2009, 03:53:28 pm »

:(

Maybe reinstalling the hicolor-icon-theme package through gslapt ot slapt-get. I will try to take a closer look when I get home from work.

Tried this on the HP Mini - still running XFCE 4.6 - and got the Master and Battery icons back in the panel.....
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Strange Update
« Reply #11 on: July 30, 2009, 06:34:17 pm »

HP Mini-Note 2133, VL-6.0-STD-Gold

Owner of machine made an automated update. After rebooting all the icons on the
panel were missing and the xfce-menu applet was gone. I do not know what was
updated. Whatever it was that was not nice to happen. Added the icons now again
manually.

 :-[ My apologies. I didn't know there were issues with Xfce 4.6.0, hadn't seen any reported, so I moved it out of testing. Whoops....

OT - I have an interest in the HP 2133. At the moment, its got Zenwalk installed, but I've not been able to get the wireless drivers working (compiled without problems, but I get errors trying to load the module).

Can you PM me with any details of the install to this machine - I would really like to get it sorted, and would have prefered Vector on it anyway (had problems, may have been the Vector CD that I had with me...). I'm especially interested in how the wireless was enabled...

Paul.
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Strange Update
« Reply #12 on: July 30, 2009, 06:48:18 pm »

HP Mini-Note 2133, VL-6.0-STD-Gold

Owner of machine made an automated update. After rebooting all the icons on the
panel were missing and the xfce-menu applet was gone. I do not know what was
updated. Whatever it was that was not nice to happen. Added the icons now again
manually.

 :-[ My apologies. I didn't know there were issues with Xfce 4.6.0, hadn't seen any reported, so I moved it out of testing. Whoops....

OT - I have an interest in the HP 2133. At the moment, its got Zenwalk installed, but I've not been able to get the wireless drivers working (compiled without problems, but I get errors trying to load the module).

Can you PM me with any details of the install to this machine - I would really like to get it sorted, and would have prefered Vector on it anyway (had problems, may have been the Vector CD that I had with me...). I'm especially interested in how the wireless was enabled...

Paul.

Paul: I cant remember the details, but I do remember that Steve and Uelsk8s worked specially in the HP-Mini wireless driver. Some kernel tweaks iirc.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

zhymm

  • Packager
  • Member
  • ****
  • Posts: 20
Re: Strange Update
« Reply #13 on: July 30, 2009, 08:06:42 pm »

:(

Maybe reinstalling the hicolor-icon-theme package through gslapt ot slapt-get. I will try to take a closer look when I get home from work.

Woohoo, that worked!  Icon love is back! :D
Logged
If I were organized I'd be dangerous.

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Strange Update
« Reply #14 on: July 30, 2009, 08:11:45 pm »

Cool, this should be fixed in 4.6.1... lets pray :D
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Pages: [1] 2