VectorLinux
October 21, 2014, 02:00:47 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 2 [3]
  Print  
Author Topic: DANGER-Will Robinson!!  (Read 11486 times)
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #30 on: August 23, 2009, 07:36:47 pm »

granny,
Why do you need the modules loaded to rescue the system and make it boot the new kernel?

At the moment, I can't do much of anything. For example, I can't mount an NTFS drive. I can't fix the corrupted bootsect.lnx file because when I boot with the VL 6 Light CD, it uses the 2.6.27.12 kernel but the installation is using the 2.6.27.29 kernel. When I do the dd command to create the bootsect.lnx file, it sets up a wrong boot sector image and I get a screen of 99s when the XP boot loa.der tries to chain to /dev/hda6. I can't go online because there are no network modules. I have no sound. When I try to load modules with modprobe, I can't get the 2.6.27.29 modules loaded because the 2.6.27.12 kernel was loaded by the VL Light CD.

I'm sure this is fixable but I don't know how to do it. I haven't had a chance to see if I can get the LiveCD to boot me into my VL on /dev/hda6.

I forgot something that may be important. I was able to get the XP boot loader to display LILO, but when I pick "linux" or anything else (tui or gui) I get this message:
Loading linux EBDA is big; kernel setup stack overlaps LILO second stage.

I haven't googled on that yet. Will do it after I post this.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #31 on: August 23, 2009, 09:06:34 pm »

I'm back in business! I followed newt's suggestion in the VL Light Live 6.0 RC1 Feedback section and booted with the Light Live RC1 CD, tabbed for a more customizable boot option, and changed the command so that it reflected my installation on /dev/hda6. It worked! It got me into my installation with the 2.6.27.29 kernel and I was able to do
dd if=/dev/hda6 of=/tmp/bootsect.lnx bs=1 count=512
to get a proper bootsect.lnx file for the XP boot loader to use. I then checked the contents of lilo.conf, which were fine, and ran lilo -v. I copied bootsect.lnx to my FAT32 Windows Drive D and booted into XP. I then moved bootsect.lnx to C:\. I decided to copy it from inside Windows to avoid any funny business with the NTFS partition.

Holding my breath, I rebooted into VectorLinux through the XP boot loader. I got the LILO screen and had a successful boot into VL 6 Light on my /dev/hda6. Modules are all back. Now we'll see what happens tomorrow after a night of the computer being turned off.

Tomorrow I'll have to decide if I want to chance another Big Adventure when I remove the old kernel from my older desktop.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Pages: 1 2 [3]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!