VectorLinux
July 22, 2014, 05:18:26 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: Can't get Palm to sync  (Read 4729 times)
Hiero2
Member
*
Posts: 57


« Reply #15 on: April 25, 2010, 04:59:31 am »

SOLVED.

FYI - I've had pretty much the same problem in another distro (openSUSE) - and since I'm the OP, I'm posting to share a little I've learned. The problem is apparently centered around how udev behaves. USBTTY0 and 1 (and for that matter, 2 etc) do not normally exist. Udev creates them when you plug your device in. And deletes them when you unplug it - even if you created them previously. The preceding code, originally from Joe1962 controls how udev handles that device node creation
Code:
KERNEL=="ttyUSB[13579]", SUBSYSTEMS=="usb", ATTRS{product}=="Palm Handheld",  SYMLINK+="pilot", GROUP="users", OPTIONS+="last_rule"

This is the key to how I resolved my issues. First, for some reason, I had to reboot for this to take effect. Theoretically, that should not be necessary, but for me it was.

The first section of the above udev rule, "Kernel", tells the kernel to look for the creation of ttyUSB1 or 3 or 5 etc to enact this rule. So, this rule only acts on those ttyUSB numbers. It will not affect ttyUSB0, nor ttyUSB2, etc. So far as I can tell from the udev man page, the ONLY thing this rule does is to force udev to create these ttyUSB nodes with the "users" group having permissions. Therefore, your user name needs to be a part of the users group. I edited this rule file to include ALL the ttyUSB nodes (KERNEL=="ttyUSB[0123456789]"; which may not have been necessary - idk.

So here is what I did:
  • udev default group for the usbTTY nodes was "dialout" (may vary by distro). I added myself to that group. No difference.
  • added a udev .rule file to /etc/udev/rules.d/ named 20-palm.rules. It was a text file with the text stated previously. The name of the file doesn't matter, other than it should be the lowest number in the directory, starting the name, and it has to end ".rules"
  • Doing this caused my usbTTY nodes to have the desired group ownership.
  • I verified that my user name was a member of the "users" group, but I was still not able to sync.
  • I rebooted, and logged in as root. I was able to sync as root.
  • I rebooted, and logged in as user, and I was able to sync.

Obviously, the reboot step to login as root would have had no impact, but it did tell me that there wasn't some other problem.

Best Regards to All;
Hiero2
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!