VectorLinux
November 22, 2014, 05:50:34 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Can't get Palm to sync  (Read 5187 times)
Hiero2
Member
*
Posts: 57


« on: August 14, 2009, 07:05:19 am »

Well, I think I've been all up and down other posts - and I'm not getting it. The Palm is attaching to ttyUSB0 and 1, but I can't get J-Pilot or Evolution (using gnome-pilot) to make the connection.

Other relevant posts - that didn't resolve the issue are:
>>
Quote
Palm Tungsten USB cradle
http://forum.vectorlinux.com/index.php?topic=4856
     recommended solution found in document http://www.pilot-link.org/README.usb
  However, VL is finding and attaching the Palm, as I said. The kernel and udev are doing their bit, so there is nothing for me to do from the instruction set there - I think. The document did teach me to check the permissions on the ttyUSB files (0666, ok), and the "messages" log - which tells me the Palm is attaching to ttyUSB0 and ttyUSB1 (see attached messagelog_usbsnip.txt)

>>
Quote
Getting j-pilot to sync with Sony Clie
http://forum.vectorlinux.com/index.php?topic=5963
   This is close. But not quite. From this post, I tried udevmonitor and udevinfo. Neither told me anything I can use, ignorant newb that I am  Sad. But the results are also attached (since thats a lot of lines of stuff) for you, 'dear reader', to interpret, if you can!

Using my own Google-fu, as suggested by BigPaw, I found this http://lists.pilot-link.org/pipermail/pilot-link-general/2009-June/003506.html. Working with the suggested
Quote
pilot-xfer -p usb: -l
, the Palm DOES talk to VL. I get a list of apps on the Palm. This suggests I should be able to connect using "usb:", rather than ttyUSB1, but gnome-pilot sez "Failed to connect using device 'Gearbox', on port 'usb:'. Check your configuration, as you requested new-style libusb 'usb:' syncing, but have the old-style 'visor' kernel module loaded. You may need to select a 'ttyUSB...' device. " But it doesn't matter which device I try - I've tried each of them. Neither J-Pilot nor gnome-pilot get through.

I've also tried using pilot-xfer with the -f switch to fetch the databases from the Palm. It doesn't work, pops up the "Failed to connect . . ." message as above. Repeat using ttyUSB0 and 1 as ports, and still no go. But it got the list???

Suggestions?
« Last Edit: August 14, 2009, 07:47:54 am by Hiero2 » Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: August 14, 2009, 09:11:35 am »

What type of Palm do you use.  I have an E2. If we have the same hardware I could fire it up (have not use it for some time) and see if I can make a go of it?
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Hiero2
Member
*
Posts: 57


« Reply #2 on: August 14, 2009, 10:21:41 am »

I've got a Palm T/X. I think that is sometimes referred to as a Titanium X, but Palm just calls it a T/X. I've seen posters saying it works fine in Debian, and I got it to sync in Ubuntu 9, but not here in VL.

I'm wondering if maybe I should pay attention to the libusb/visor bit in the error message, but I don't have the faintest what to do about that!

Thanks;
Mark
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: August 14, 2009, 10:29:12 am »

I start work in 45min, so I'll have to try to set up my palm later.  One think I do remember when I set it up for testing the vl-60 release was that I had to call j-pilot as root from the terminal to get it to work.  I also remember grannygeek, giving me some instruction on how she was able to set up hers without doing that.  I won't be back at my computer till Sat. evening but I can take a look at it then.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #4 on: August 15, 2009, 05:07:52 pm »

I have no idea what I'm doing but I do sync my Clie and J-Pilot frequently. I just follow what others have suggested.

This is from an entry I have in Tuxcards:

You should have the package for pilot-link installed (look in /var/log/packages). Your USB port must be working.

You need to load 2 more modules.

Type in a terminal as root:

/sbin/modprobe usbserial
/sbin/modprobe visor   

Check lsmod to make sure the modules are now present. Then you need to check that the USB serial ports are present, otherwise create them like this:

Type as root in a terminal:

/usr/bin/mknod /dev/ttyUSB0 c 188 0
/usr/bin/mknod /dev/ttyUSB1 c 188 1   

Then make them read-writeable to the user:

Type as root in a terminal:
/bin/chmod 0666 /dev/ttyUSB?
or
/bin/chmod a+rw /dev/ttyUSB?

The above directions came from Joe1962. When you follow them, you should be able to hotsync as root with JPilot. However, you won't be able to hotsync as user, which is doubtless what you want. derrell posted the solution to this on the forum quite some time ago:

Add this rule to a file in /etc/udev/rules.d that is numbered lower than what's in there already.  I used 04-local.rules as the file name. As root, open a text editor like Mousepad or Leafpad. Copy the line below and paste it into the text editor:

Code:
KERNEL=="ttyUSB[13579]", SUBSYSTEMS=="usb", ATTRS{product}=="Palm Handheld",  SYMLINK+="pilot", GROUP="users", OPTIONS+="last_rule"
(That should all be one line, no returns except at the end of "last_rule" .) Save in /etc/udev/rules.d as 0x-local.rules replacing the "x" with a number lower than the other .rules files.

derrell said:
Adding the last_rule option is what made it all work.  There is something down stream that is changing the owner and group of /dev/pilot -> /dev/ttyUSB1 -> tts/USB1 to root.  I never did find where it was happening. 

Also setting the group to users is probably not the most secure thing to do either so you might want to think about that. 

===============================

Note that if you try to hotsync and are unsuccessful, ttyUSB0 and 1 will disappear. You will have to reload them and make them read/writable by users as above. ttyUSB0 and 1 will also disappear after a successful hotsync. I don't know why this happens or how to make /dev/ttyUSB persist. Maybe some other forum member does.

If you are successful and want to have your computer able to run a JPilot hotsync without loading modules and creating ports, add these lines to /etc/rc.d/ rc.local:
/sbin/modprobe usbserial
/sbin/modprobe visor
/usr/bin/mknod /dev/ttyUSB0 c 188 0
/usr/bin/mknod /dev/ttyUSB1 c 188 1
/bin/chmod 0666 /dev/ttyUSB?

Do this as root, of course.

Let us know if this works for you. This is the limit of my knowledge of hotsyncing. It works for me and I hope it'll work for you.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Hiero2
Member
*
Posts: 57


« Reply #5 on: August 16, 2009, 11:54:41 am »

Granny;

First thing - thanks. However, it isn't there yet. And, actually, I'm not quite sure where it is!

I did get it to sync as root, using pilot-xfer, gnome-pilot, and j-pilot. But not as user. And, I'm not quite sure WHY it was syncing as root this time.

I tried to go step by step this morning. At first, I used lsmod to check the modules loaded. I didn't see usbserial and visor, so I loaded them. Added those lines to rc.local, and made the other changes, as you recommended. Then it synced as root. Logout / login to user. Verify ttyUSB permissions, A-ok. But, no sync.

Still as user, I rechecked the ttyUSB rights. They weren't set at 0666 anymore. USB0 was set to group uucp, others got 0. So, if I remember correctly, that is  0660. I chmoded to 0666. Checked and verified. Tried again - failed, and noted that the ttyUSB0 rights had been CHANGED BACK! Something in the process is resetting the rights.

After that, I checked the system messages log I attached last week, and I see that modules usbserial and visor DID load then! So I undid the rc.local changes, rebooted, and root still syncs. I check lsmod, usbserial and visor are loaded. Maybe I forgot to check syncing as root last week???

Root syncs, user can't. The udev rule edit doesn't seem to be making a difference, but I'm wondering if one of the settings there isn't right for me.
Quote
KERNEL=="ttyUSB[13579]", SUBSYSTEMS=="usb", ATTRS{product}=="Palm Handheld",  SYMLINK+="pilot", GROUP="users", OPTIONS+="last_rule"
For instance, the kernel setting - what does that do? The symlink setting is "pilot", but I'm connecting to "usb:", not /dev/pilot. Could that be making a difference? What would happen if I edited it to SYMLINK+="usb:"? I wouldn't think that would lock my machine if it was a bad setting, but I sure don't know.

So I have syncing as root, which is ok so long as I am logging in as root. But, everyone in Linux-country seems to think that is a bad idea.  Wink

However, I do think I have graduated from noob status. Some of this is actually starting to make sense.  Shocked Grin

Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #6 on: August 16, 2009, 03:49:12 pm »

I'm sorry you're still not able to sync as root. I don't think I can help much, as I don't understand much of what's going on. I just copy things others suggest, try them out, and see what happens. If it works, I'm glad even though I don't know why. If it doesn't, I have to continue looking for a solution.

My first suggestion: Never log in as root. It's totally unnecessary. Just log in as user and when you need to do a root thing, open a terminal, type su, type your root password, and do whatever root things you need to do. Then type exit at the prompt and you're back at your user account. This is a lot easier than logging in as root and logging out, then logging in as user.

When we have Ubuntu refugees posting here, they usually suggest
sudo somecommand
which is the Ubuntu way. It's not the way Linux has worked from time immemorial and was dreamt up as a way to make things "easier" for Windows users. I disagree and I think that ultimately it makes things harder. For example, sudo works for one command. Having to sudo for a series of commands is majorly annoying. When you su to root, you can do as much as you need to before you exit back to user. You don't have to type sudo again and again.

Now to get back to your situation. I do know that the new file in /etc/udev/rules.d is essential if there is to be any hope of syncing your Palm as user. Did you give the file a number that is lower than any other file in /etc/udev/rules.d? Is the filename exactly right? On this computer, my file is 04-local.rules .

I don't understand what the options in 04-local.rules do. I just copied the line as suggested and it works for me. If I don't have the 04-local.rules, I can't sync as user. I don't think the SYMLINK option makes any difference, as I don't have a pilot symlink but I can sync fine.

Be sure you do everything in one sequence. Make the changes I suggested to /etc/rc.d/rc.local and log in as user. Don't poke around in /dev checking permissions, etc., because they should be properly set right after login. Then start JPilot and do File menu, Preferences. Under the Settings tab I have /dev/ttyUSB1 in the box for Serial Port and it's repeated in the box immediately to the right. Go through the rest of the tabs and set things up as you wish. Also go to File menu, Install User and enter your user name as it is in your Palm device and a random number. After you have done these things you can try a Hotsync. Have your Palm turned on and the HotSync icon ready to click. First tap the HotSync icon in J-Pilot and then immediately tap the HotSync icon on the Palm screen.

My experience is that any time you try a HotSync, the /dev/ttyUSB0 and 1 ports will disappear after the attempt whether or not you hotsynced successfully. So if you want to try again, you have to close JPilot and go through the port creation and permissions stuff by su-ing to root, then exit back to user, restart JPilot, and try again.

When I have trouble like this, I usually find that I made a little mistake somewhere. Those can be very hard to pick up. I'm not saying this is what's happening to you, but it's something to keep in mind.

If you're still unsuccessful in syncing as user, I can't help. Google is your friend and as I recall, there was a lot of information on the JPilot Web site. I hope someone on this forum can pick up from here because I don't know what else to suggest.

Good luck!
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Hiero2
Member
*
Posts: 57


« Reply #7 on: August 16, 2009, 04:32:42 pm »

Thanks Granny. I DO get syncing as root. But, like you say, logging in as root is not such a good idea, and my j-pilot sync as root is not available for me as "user". I've done everything you said, and I did it as you said to do it. When I was doing that, I just happened to have a file manager open - which was why I noticed the permissions changing on the ttyUSB0. And then, when it didn't work as my "user", I think I know why. It doesn't matter how many times I chmod it, if it gets changed back just before the sync tries to "talk"!

I think you are right, though, that we've gone as far as you can take me. We need somebody who understands "why" on some of this stuff to make it work, because repeating exactly what you have done is not getting the same results.

But, I surely do thank you, because you have been very helpful in getting me farther along. At least now I can get it to sync as root.

I might even pay for support at this point, if I thought that it would get me the answer! I've spent a good part of a week on this issue. I just happen to have the time off from regular work! (lucky me).
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #8 on: August 16, 2009, 05:06:55 pm »

I'm sorry it didn't work. If you find the solution, be sure to let us know. It may help someone else.

I dearly love my Clie and dread the day when it stops working, which is bound to come. Sony discontinued the Clie a few years ago. It does everything I want and it works with J-Pilot. I considered getting a Palm T|X, but I couldn't justify spending so much for what is now a dead product, especially since my Clie is working fine.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
OU812
Vectorite
***
Posts: 156



« Reply #9 on: August 18, 2009, 09:14:26 pm »

Are you a member of the tty group? If not, you'll need to add yourself to this group. This may fix the problem. I had this problem when I ran zenwalk. Here's the thread:

http://support.zenwalk.org/viewtopic.php?f=10&t=5157&p=31222&hilit=clie#p31222

john
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #10 on: August 19, 2009, 06:10:34 pm »

Are you a member of the tty group? If not, you'll need to add yourself to this group. This may fix the problem. I had this problem when I ran zenwalk. Here's the thread:

http://support.zenwalk.org/viewtopic.php?f=10&t=5157&p=31222&hilit=clie#p31222

I'm not a member of the tty group but my Clie syncs fine. However, just in case group membership has something to do with the problem, here are the groups I belong to as user:
sys adm disk lp wheel floppy audio video cdrom games slocate plugdev scanner users

--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Hiero2
Member
*
Posts: 57


« Reply #11 on: August 20, 2009, 12:47:58 pm »

Granny, Ou -  Thank you for trying.

I've given up. I'm afraid my VL6 is wiped and replaced with Debian. I've learned a lot, and I'll be back, but it was just eating up too much time getting stuff to work. Right after I last replied, I tried to burn a CD - it wouldn't. Got to fix that. Then the kernel update, and I couldn't boot back to the gui 'coz of the nvidia card. I got the nvidia working once, and I could do it again, but it has just all taken too much time.

Vector is still a great distro, so I'll be back someday, but just not this week. One of the old hands on here commented that slackware (and thus VL) were closer to Unix standards than the major distros, and therefore would, in the long run, benefit the end-user best. She had a point. I have learned a lot more about Linux by getting the VL running than I would have just using the Ubuntu on the other machine (which has been running the whole time). But, I wanted to get a little closer, and wanted to try the lighter desktop, etc.

Thank you  very much.

Mark
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #12 on: August 20, 2009, 06:36:59 pm »

Sorry our efforts were unsuccessful. I was hoping you'd figure out what was making your sync as user fail. I understand how you can run out of time and go with what works.

When you come back we'll roll out the welcome mat.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Uncle Harry
Member
*
Posts: 6


« Reply #13 on: October 15, 2009, 09:12:35 am »

For me, all I had to do was make myself a member of the uucp group.  This was because once I pressed the sync button on cradle (I'm using Tungsten E2 and USB cable that has the button on it for syncing), /dev/tts/USB1 was created.  Here is what it looked like:

crw-rw---- 1 root uucp 188, 1 2009-10-15 09:23 /dev/tts/USB1

Before I realized I should add myself to the uucp group, I tried all of the suggestions out there about adding a rules file to /etc/udev/rules.d
That did create  /dev/pilot when I pressed sync on the cradle, but it was linked to tts/USB1 anyway:

lrwxrwxrwx 1 root root 8 2009-10-15 09:23 /dev/pilot -> tts/USB1

I just wanted to be able to sync with Jpilot, and it works.  So I don't know if other apps need the /dev/pilot link.  Jpilot was able to use /dev/tts/USB1 without me configuring anything.

Just to reiterate what others have said, press the sync button on the cradle first, then click the sync button in Jpilot (or do your pilot-xfer or whatever).
Logged
Hiero2
Member
*
Posts: 57


« Reply #14 on: October 15, 2009, 11:10:26 am »

Thanks, Uncle Harry. Too bad I can't test it any more, but your experience is a valuable addition to the thread. It certainly could be something like this that was stopping me.

Regards;
Hiero2
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!