VectorLinux
December 17, 2014, 02:46:10 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2 3
  Print  
Author Topic: SOLVED ********: CDROM is not available - HELP IS NEEDED  (Read 6231 times)
nj_jak
Member
*
Posts: 47


« on: August 15, 2009, 01:09:45 am »

Hi - I am getting fustrated, but I want to hang on to VL, so please help me!

I am running VL SOHO 5.9 with KDE, and I chose OSX look alike on the setup menu.
After upgrade of harware, I cannot use my CDROM (DVD writer) which I find very odd since I made a fresh install from the cdrom.

During setup I selected to use HAL (since I have vast system resources), and USB sticks, Card readers and external HD (USB) all pop up in a 'What to do with this' window. Inserting a cd in the cdrom is totally ignored by the system.
I tried changing HAL to VL-hot in VASMCC, and the behaviour of USB devices changes i.e. an icon apears on the desktop (but only one - as I understand the description an unmount icon should be there aswell). Still no communication with the cdrom. Changing back to HAL doesn't bring up anything related to the cdrom.

So I tried (in VASMCC) running the 'optical drives / CDROM/DVDROM setup'
The computer asks 'Excuse me, do you have a cdrom?' Answer is Yes (I installed from it!) then I try to scan for the drive (after putting a cd with picture files on it in the slot) - After several attempts I get the depressing message:
"I'm sorry, but an IDE CD-ROM drive could not be found on any of the devices that were scanned. You are on your own now..."

Of course I am not copletely left alone -  I have you guys - so please help me out!

My Hardware facts:
Old setup: ASUS P5VDC-MX, Intel Celeron (3,33 GHz), 1 gb DDR2 RAM - dual boot (VL + WinXP)
New setup: Asrock M3A780GXH/128M, AMD Phenom II X3 (2,8 Ghz), 4 gb DDR3 RAM - only VL
Mentioned parts were the only parts replaced on the system.
« Last Edit: September 03, 2009, 02:12:28 am by nj_jak » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4037



« Reply #1 on: August 15, 2009, 05:43:56 am »

When using vl-hot under KDE, you only get one icon on desktop. Unmounting is done from the right-click menu. Vl-hot does not handle cd-rom devices.

Try these commands and see if your CDROM drive shows up:
probedisk
cat /proc/scsi/scsi
cat /var/log/messages | grep CD-ROM

Also, post the contents of your /etc/fstab
Logged
nj_jak
Member
*
Posts: 47


« Reply #2 on: August 16, 2009, 07:33:44 am »

Hi Nightflier, thanks for responding.

Below are my results, the fstab section regarding the cd rom is identical to the fstab on my spare laptop (IBM Thinkopad T22 running the same VL SOHO 5.9 configuration) where HAL detects when new cd is inserted.

Further info on hardware: the cdrom/dvdwriter is attached to the only IDE connectroe on the motherboard.

I ran the commands you suggested as root:

probedisk:
/dev/sda|Direct-Access|ATA      ST3160211AS

cat/proc/scsi/scsi:
bash: cat/proc/scsi/scsi: No such file or directory

cat var/log/messages | grep CD-ROM:
cat: var/log/messages: No such file or directory

contents of my /etc/fstab:
# /etc/fstab: static file system information.
#
# The following is an example. Please see fstab(5) for further details.
# Please refer to mount(1) for a complete description of mount options.
#
# Format:
# <file system>   <mount point>   <type>   <options>   <dump>   <pass>
#
# dump(Cool uses the <dump> field to determine which file systems need
# to be dumped. fsck(Cool uses the <pass> column to determine which file
# systems need to be checked--the root file system should have a 1 in
# this field, other file systems a 2, and any file systems that should
# not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

# The Linux partitions
/dev/sda1 / reiserfs  noatime  0  1
/dev/sda6 /home reiserfs noatime  0 2

# Shared Windows/Linux partition
#/dev/hda1   /mnt/dos  msdos  umask=0   0  0
#/dev/hda1   /mnt/win  vfat   fmask=111,dmask=0,quiet,shortname=mixed,user  0  0
#/dev/hda1   /mnt/win  ntfs   umask=0   0  0

# Floppy disks
# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.
/dev/fd0   /mnt/floppy   auto   defaults,noauto,user   0 0
#/dev/fd1  /mnt/floppy   auto   defaults,noauto,user   0 0

# If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.
#/dev/hdd   /mnt/ls120   auto   defaults,noauto,user   0 0

# CDROM, CDWRITER, DVD
/dev/cdrom    /mnt/cdrom   iso9660   defaults,noauto,ro,user   0 0
#/dev/cdwriter /mnt/cdwriter   iso9660   defaults,noauto,rw,user   0 0
#/dev/dvd      /mnt/dvd    auto   defaults,noauto,ro,user   0 0

# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de  /mnt/nfs  nfs  defaults  0 0

# proc file system:
proc   /proc   proc   defaults   0 0

# Unix98 devpts filesystem:
none  /dev/pts  devpts  gid=5,mode=666  0 0

# Shared memory filesystem:
tmpfs   /dev/shm    tmpfs defaults 0  0

# Basic USB filesystem
sysfs  /sys  sysfs  defaults  0 0
usbfs /proc/bus/usb usbfs rw,devmode=0666 0 0

# example of a VFAT USB pendrive
#/dev/sda1  /mnt/pendrive vfat   fmask=111,dmask=0,noauto,user,quiet,shortname=mixed 0 0


# Swap partitions
# The 'sw' option means auto activating with 'swapon -a'.
/dev/sda5   none   swap   sw   0  0



Logged
Hiero2
Member
*
Posts: 57


« Reply #3 on: August 16, 2009, 08:46:29 am »

jak;

I'm going to make a guess as to your solution - just to see if I can. My guess is:
In your fstab, uncomment the DVD and cdwriter lines (as root). Restart.

I'm guessing your Thinkpad has different hardware, and that your hardware updgrade was this new DVD writer.

Now, as I am a newb still,  if you want, you might wait for nightflier to concur. But, the above will be quick and easy, and no risk. If it doesn't work - you might end up messing with udev, and that is a little deep for me yet.

Hiero2
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4037



« Reply #4 on: August 16, 2009, 11:45:50 am »

Uncommenting the "dvd" entry in fstab most likely won't change anything for the worse nor better. Problem seems to be that the optical drive is not detected.

Looking at your command outputs, there are some syntax errors:
cat/proc/scsi/scsi needs a space after cat, like this:
cat /proc/scsi/scsi
cat var/log/messages | grep CD-ROM needs a slash before var:
cat /var/log/messages | grep CD-ROM


Assuming you upgraded the parts yourself, and are comfortable peeking inside, I would suggest opening the case and disconnecting, then re-connecting the power and data cables to the cd-rom/dvd.

BTW, what kind of drive is it, sata or ide?
« Last Edit: August 16, 2009, 11:49:36 am by nightflier » Logged
nj_jak
Member
*
Posts: 47


« Reply #5 on: August 17, 2009, 12:31:08 am »

Sorry - will check syntax better next time.

have NOT tried the suggested changes to etc/fstab


root:# cat /proc/scsi/scsi *** returns this:
Attached devices:
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: ST3160211AS      Rev: 3.AA
  Type:   Direct-Access                    ANSI  SCSI revision: 05


root:# cat /var/log/messages | grep CD-ROM *** returns nothing

The Ddrive is IDE and worked well on my old hardware, and it also worked during installation, so I do not really think the disconnect/connect will do anything.

A few weeks ago I installed VL Std 6.0, and I had no problem using the CD-ROM >>> but unfortunately 'She, who must be obbeyed' did not like that flavour, and I was optimistic enough to telle her, that by the help of the forum I am sure to get it working in VL SOHO 5.9.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4037



« Reply #6 on: August 17, 2009, 04:55:35 am »

If it is an IDE drive, it will be /dev/hdx   (x = a, b, c, d).
Just start running through the possibilities, as root, in a terminal:
Code:
mount /dev/hdx /mnt/cdrom

If none work, do try resetting the cables. It would not be the first time I've seen that fix this kind of issue.
Logged
nj_jak
Member
*
Posts: 47


« Reply #7 on: August 21, 2009, 12:08:34 am »

Hello I'm back.

Have tried the mount command - no succes
Have tried the cable resetting (on the motherboard and on the device) - no succes

Starting the computer with a bootable CD in the drive boots up on the CD. This must mean, that the connection between the CD-ROM device and the motherboard is OK.

Any new suggestions?
Logged
nj_jak
Member
*
Posts: 47


« Reply #8 on: August 21, 2009, 12:23:29 am »

More information:

Looked into the BIOS settings, this is the properties for the IDE1 Master:
Device:       ATAPI CDROM
Vendor:       TSSTcorpCD/DVDW SH-S182M
LBA Mode:   Supported
PIO Mode:    4
Async DMA: MultiWord DMA-2
Ultra DMA:   Ultra DMA-2

I tried changing the 'type' setting for the drive from 'Auto' to 'CD/DVD' - but no change to the (missing) behaviour of HAL.
Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #9 on: August 21, 2009, 03:04:45 am »

Hi nj_jak,

I understand that the CDROM is an IDE device not a SATA correct?

Have you checked the Bios that P-ATA and S-ATA are being used?
Note: that the actual names maybe different.

Open a terminal, then type: dmesg | grep hd after that type dmesg | grep sd

Please post the output. These commands are reading from the startup.

Bigpaws
Logged
nj_jak
Member
*
Posts: 47


« Reply #10 on: August 21, 2009, 11:39:12 pm »

Hi bigpaws,

yes, CD drive is IDE, HD is SATA

the output you asked for:

jakobsen:$ dmesg | grep hd
    ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hda:pio, hdb:pio
hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
hda-intel: Invalid position buffer, using LPIB read method instead.

jakobsen:$ dmesg | grep sd
sd 2:0:0:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
sd 2:0:0:0: [sda] Write Protect is off
sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 2:0:0:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
sd 2:0:0:0: [sda] Write Protect is off
sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2 < sda5 sda6 >
sd 2:0:0:0: [sda] Attached SCSI disk
sd 2:0:0:0: Attached scsi generic sg0 type 0
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
wbsd: Winbond W83L51xD SD/MMC card interface driver
wbsd: Copyright(c) Pierre Ossman
ReiserFS: sda1: found reiserfs format "3.6" with standard journal
ReiserFS: sda1: using ordered data mode
ReiserFS: sda1: journal params: device sda1, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: sda1: checking transaction log (sda1)
ReiserFS: sda1: journal-1153: found in header: first_unflushed_offset 8171, last_flushed_trans_id 15845
ReiserFS: sda1: journal-1206: Starting replay from offset 68058051780587, trans_id 3227911392
ReiserFS: sda1: journal-1299: Setting newest_mount_id to 110
ReiserFS: sda1: Using r5 hash to sort names
Adding 2097136k swap on /dev/sda5.  Priority:-1 extents:1 across:2097136k
ReiserFS: sda6: found reiserfs format "3.6" with standard journal
ReiserFS: sda6: warning: CONFIG_REISERFS_CHECK is set ON
ReiserFS: sda6: warning: - it is slow mode for debugging.
ReiserFS: sda6: using ordered data mode
ReiserFS: sda6: journal params: device sda6, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: sda6: checking transaction log (sda6)
ReiserFS: sda6: journal-1153: found in header: first_unflushed_offset 5707, last_flushed_trans_id 29341
ReiserFS: sda6: journal-1206: Starting replay from offset 126022930404939, trans_id 3222398652
ReiserFS: sda6: journal-1299: Setting newest_mount_id to 111
ReiserFS: sda6: Using r5 hash to sort names
Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #11 on: August 22, 2009, 04:57:29 am »

I am not seeing any reference to your CDROM.

Can you attach the output of dmesg as a file. To
create the file type this:

dmesg > dmesg.txt

According to your post you mention that the Bios
is set for PATA and SATA.

Bigpaws
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4037



« Reply #12 on: August 22, 2009, 06:57:30 am »

I agree with bigpaws that the answer may be in BIOS. Possibly in the IDE mode settings. I have seen many different combinations, like legacy, enhanced, native, combined. They all affect how the drives get reported to the OS, as well as the sequence that they appear in.

Caution: changing the settings may affect the boot sequence. Make sure to write down the original settings in case you need to go back.
« Last Edit: August 22, 2009, 06:59:02 am by nightflier » Logged
nj_jak
Member
*
Posts: 47


« Reply #13 on: August 22, 2009, 07:02:04 am »

Hi Bigpaws,
Thanks for the quick response, I have attached the file - I really hope this will give the info needed to solve the problem.

I will check the BIOS setting on my next logon.

Have a nice weekend - greetings from (today) sunny Denmark

Logged
nj_jak
Member
*
Posts: 47


« Reply #14 on: August 22, 2009, 07:04:13 am »

Hi Nightflier,

I suspect the BIOS setting too, but for now I will wait until Bigpaws has looked into the dmesg file.
Logged
Pages: [1] 2 3
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!