Please support VectorLinux!

Author Topic: Error compiling lyx-1.6.4 in VL5.9 [SOLVED]  (Read 966 times)

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Error compiling lyx-1.6.4 in VL5.9 [SOLVED]
« on: August 27, 2009, 07:35:27 pm »
I am trying to compile lyx-1.6.4 but encounter error as below....



I suspect it is due to libpng so I also include this in my /usr/lib...



Anyone have any idea how to solve it? Thanks. :)
« Last Edit: August 28, 2009, 12:57:10 am by hata_ph »

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Error compiling lyx-1.6.4 in VL5.9
« Reply #1 on: August 28, 2009, 12:56:53 am »
Ok. I think I what is the root cause. I have upgrade qt4 to version 4.4.1 which cause problem with libpng-1.2.37 (which I upgraded from version 1.2.29). I have to downgrade qt4 to version 4.3.2 to successfully compile lyx-1.6.4. Could it be qt4-4.4.1 need to repackage with the new libpng-1.2.37?