VectorLinux
July 30, 2014, 06:58:00 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: X repeatedly starting at the wrong resolution  (Read 1085 times)
steelcommuter
Member
*
Posts: 4


« on: August 29, 2009, 11:59:23 am »

I can't figure this out:

I have Vector Linux 6.0 standard, an NVIDIA graphics card using the proprietary driver, and a 1920x1080 monitor.  Whenever I log-in to XFCE or KDE, the desktop display is set at 1920x1200.  The panel is off-screen on the bottom and I have to move the mouse down the screen to display the panel.

I can change the display settings to 1920x1080, and then it is fine.  I have checked xorg.conf, and it shows the correct resolution in the screen information.  I checked the NVIDIA driver settings, and it is also set at the correct 1920x1080 resolution. 

Unfortunately, everytime I reboot the computer and log-in, regardless of account or window manager, it is again set at 1920x1200 and I have to change it.  I did not have this problem on a previous install of VL 6.0 with the same monitor and PC.  I had to reinstall the root system after a removal of GSB Gnome removed critical parts of the OS. 

I would appreciate any suggestions from people concerning what file or process I should look at to see why it logs in at the wrong resolution.  I have appended my xorg.conf

Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/share/X11/rgb"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/TTF"
FontPath     "/usr/share/fonts/OTF"
FontPath     "/usr/share/fonts/Type1"
FontPath     "/usr/share/fonts/misc"
FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
Load  "glx"
Load  "extmod"
Load  "xtrap"
Load  "record"
Load  "dbe"
#Load  "dri"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "us"    ## KEYBOARD_MAP!
Option  "XkbModel"  ""    ## KEYBOARD_MODEL!
Option  "Xkbvariant"  ""    ## KEYBOARD_VARIANT!
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/input/mice"
Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 DisplaySize 506 286 # 96 DPI @ 1920x1080
  Option "UseEdidFreqs" "1"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
HorizSync 30-81
VertRefresh 56-60
EndSection

Section "Device"
Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "USEdidDPI" "false"
Option "DPI" "96 x 96"
Identifier  "Card0"
Driver      "nvidia"
VendorName  "nVidia Corporation"
BoardName   "NV34 [GeForce FX 5200]"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport   0 0
Depth     1
Modes "1920x1080" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
Modes "1920x1080" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
Modes "1920x1080" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
Modes "1920x1080" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
Modes "1920x1080" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
Modes "1920x1080" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "on"
EndSection
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #1 on: August 29, 2009, 03:25:13 pm »

I know this won't solve your problem, but a shortcut could ease your pain.

Press ctrl+alt+-

You can press that repeatedly to cycle through your resolutions
Logged

GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #2 on: August 29, 2009, 03:48:55 pm »

This is purely a guess on my part, but in this section:

Section "Monitor"
 DisplaySize 506 286 # 96 DPI @ 1920x1080
  Option "UseEdidFreqs" "1"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
HorizSync 30-81
VertRefresh 56-60
EndSection

You might try changing the HorizSync and VertRefresh settings. For my 1600x1200 LCD monitor, I have:

HorizSync 31.5-64
VertRefresh 40-90

Back up your xorg.conf file, try those and see if you get the resolution you want. Also, if your monitor has an Autoadjust button, press that and see if the monitor catches on.
--GrannyGeek
« Last Edit: August 29, 2009, 03:51:55 pm by GrannyGeek » Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #3 on: August 29, 2009, 03:58:51 pm »

I know this won't solve your problem, but a shortcut could ease your pain.

Press ctrl+alt+-

You can press that repeatedly to cycle through your resolutions

Unfortunately, that shortcut doesn't work with the XFce desktop. XFce uses the Alt key for its own purposes and therefore the Alt key is not operative for non-XFce keystrokes.

I ran into the same issue with shortcuts in Inkscape, some of which use Alt.

Maybe there's a workaround I don't know about.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
steelcommuter
Member
*
Posts: 4


« Reply #4 on: August 30, 2009, 12:19:42 pm »

I'll try double checking the values in the xorg.conf.  I just think this is weird, because I've never had a problem like this before.  It worked fine for VL 6 before I reinstalled, and Linux Mint on the other hard drive doesn't do this, either.  I'll compare the two versions of xorg.conf, for starters.

Thanks for the responses.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!