VectorLinux
September 20, 2014, 03:37:34 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Default Soundcard  (Read 3533 times)
ThurmanMerman
Member
*
Posts: 12



« on: November 29, 2006, 11:34:47 am »

The install process of VL 5.8 RC3 found 2 soundcards on my system (even though I have
the onboard sound turned off thru the BIOS). Well needless to say VL5.8 chose the
onboard sound as card 0 (the default), even though I had picked my Sound Blaster card
while installing. So in doing alot of search in these forums and the internet I finally found
a resolve to this, and hope this can help anyone else in the future with this problem.


1)From terminal input this command: cat /proc/asound/cards

2) In my case it came back with Via(card 0), and Live(card 1, but the one I prefer)

3) With root privilidges edit file /etc/skel/.asoundrc

4) Find these lines:
pcm.!default {
    type plug
    slave.pcm "ossmix"     # use our new PCM here
}

5) Change them to:
pcm.!default {
type hw
card Live
}
ctl.!default {
type hw
card Live
}

6) Chage the instances of Live with your card of choice from step 1
Logged

Servo vestri amicitia propinquus,  quod vestri hostilis magis propinquus.
carsten
Vectorite
***
Posts: 137


I know why birds sing ...


« Reply #1 on: December 04, 2006, 11:32:48 am »

Hy,
same story by me. Embarrassed
Tried your fix, it worked one time, now it is fallen silent again.  Huh When I put the speakers plug in the mainboards jack everthing is as it should be. Attemps to run ALSA-Config via VASM did not help either. Very curious.
I hope this can be fixed for the final releas, as I am willing to trade in my SOHO 5.0 for Standard now.

Carsten
Logged

Tam exacte ut oportet, non ut licet!
carsten
Vectorite
***
Posts: 137


I know why birds sing ...


« Reply #2 on: December 06, 2006, 01:34:00 pm »

Hy,
some news.
I did a re-install, same again. ALSACONFIG did not cure the problem.
Only when I deactivated the Onboard-sound at BIOS and rerun setup it worked. Presently everything is working just fine. May this is a minor glitch in Alsaconfig

Carsten
Logged

Tam exacte ut oportet, non ut licet!
ThurmanMerman
Member
*
Posts: 12



« Reply #3 on: December 21, 2006, 12:11:39 am »

As my original post stated "I have the onboard sound turned off thru the BIOS". I obviously had already ventured down that path, but just as you, upon rebooting the sound went back to the onboard sound (even though it was still shut-off thrtu the BIOS). So I tried another approach, I ran alsaconfig and chose the onboard sound, lo and behold my Sound Blaster Live card worked, thusly tricking the OS into using the preferred sound device. Truth is sometimes better than fiction. Good Luck
Logged

Servo vestri amicitia propinquus,  quod vestri hostilis magis propinquus.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!