VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Kernel 2.6.30 on VL 6 ??  (Read 4126 times)

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Kernel 2.6.30 on VL 6 ??
« on: September 04, 2009, 09:18:32 am »

I'm going to try compiling kernel 2.6.30 and see if it will work OK with VL 6.0 Gold Standard Edition. I am just wondering if anyone else has tried this and what your comments might be....
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Kernel 2.6.30 on VL 6 ??
« Reply #1 on: September 04, 2009, 10:21:25 am »

we have some 2.6.30 kernels here
they seem to work pretty good in the testing we did
ftp://vectorlinux.osuosl.org/pub/vectorlinux/Uelsk8s/test/kernel
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3280
Re: Kernel 2.6.30 on VL 6 ??
« Reply #2 on: September 04, 2009, 04:06:37 pm »

Yeah. I gave it a go. With some customizations it gave me much better battery life on my laptop. This does require special options enabled which are not enabed by defaul in the defat configuration.

I still have it running on one my installs

Pita

  • Vectorian
  • ****
  • Posts: 1346
Re: Kernel 2.6.30 on VL 6 ??
« Reply #3 on: September 06, 2009, 05:42:21 pm »

Just installed this kernel and modules, src. Off hand all seems to be working
including all sound modules loaded and sound working unlike with kernel 2.6.27.29
where the sound modules did not load.
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1346
Re: Kernel 2.6.30 on VL 6 ??
« Reply #4 on: September 08, 2009, 06:22:06 pm »

It seems I cannot get nvidia going.

Error message:

Using: nvidia-installer ncurses user interface
-> License accepted by command line option.
-> Installing NVIDIA driver version 173.14.12.
-> Skipping check for conflicting rpms.
-> Not probing for precompiled kernel interfaces.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.30.4/source'
-> Kernel output path: '/lib/modules/2.6.30.4/build'
ERROR: If you are using a Linux 2.4 kernel, please make sure
       you either have configured kernel sources matching your
       kernel or the correct set of kernel headers installed
       on your system.

       If you are using a Linux 2.6 kernel, please make sure
       you have configured kernel sources matching your kernel
       installed on your system. If you specified a separate
       output directory using either the "KBUILD_OUTPUT" or
       the "O" KBUILD parameter, make sure to specify this
       directory with the SYSOUT environment variable or with
       the equivalent nvidia-installer command line option.

       Depending on where and how the kernel sources (or the
       kernel headers) were installed, you may need to specify
       their location with the SYSSRC environment variable or
       the equivalent nvidia-installer command line option.
Logged

lopanrs

  • Member
  • *
  • Posts: 15
    • Blog
Re: Kernel 2.6.30 on VL 6 ??
« Reply #5 on: September 14, 2009, 09:23:24 pm »

Hi Vector users.
I'm new here and have a few questions about this kernel update to 2.6.30.
It seems to work fine on VL6 STD Gold, but my PCI Capture card now have no sound from LINE IN, with the stock Vector kernel it works.
Searching the web i found this http://patchwork.kernel.org/patch/29660/  it sounds related to my problem
I try with kernel 2.6.31 too, without success. :(


my dmesg and bttv file from /etc/modprobe.d/
Code: [Select]
[ 4362.389724] bttv: Bt8xx card found (0).
[ 4362.389724] bttv0: Bt878 (rev 17) at 0000:05:07.0, irq: 17, latency: 32, mmio: 0xc6000000
[ 4362.389724] bttv0: using: Prolink PixelView PlayTV MPEG2 PV-M4900 [card=139,insmod option]
[ 4362.389724] bttv0: gpio config override: mask=0x3f, mux=0x21,0xffffffff,0xffffffff,0xffffffff
[ 4362.389724] IRQ 17/bttv0: IRQF_DISABLED is not guaranteed on shared IRQs
[ 4362.389724] bttv0: risc main @ 35605000
[ 4362.389724] bttv0: gpio: en=00000000, out=00000000 in=00afc0ff [init]
[ 4362.389724] bttv0: BT878A ARESET
[ 4362.389724] bttv0: tuner type=43
[ 4362.449720] bttv0: audio absent, no audio device found!
[ 4362.449720] bttv0: registered device video0
[ 4362.449720] bttv0: registered device vbi0
[ 4362.449720] bttv0: registered device radio0
[ 4362.449720] bttv0: video mux: input=0 mux=2
[ 4362.449720] bttv0: PLL: 28636363 => 35468950 .. ok
[ 4362.484011] input: bttv IR (card=139) as /class/input/input7
bttv file:
Code: [Select]
options bttv card=139 tuner=59 i2c_scan=1 radio=1 bttv_debug=1
options tvaudio tea6300=1 tda9850=1 tda9855=1 debug=1
Thanks, and sorry my bad english. :p
« Last Edit: September 14, 2009, 09:35:58 pm by lopanrs »
Logged
VL SoHo 7.0 @ 3.7.5-pf

vincent2

  • Vectorite
  • ***
  • Posts: 418
aircrack on Kernel 2.6.30 on VL 6 with usb RTL8187
« Reply #6 on: October 24, 2009, 01:06:11 pm »

Bonjour!
Tried kernel 2.6.30 on VL6.0 with usb  RTL8187 wifi adoptor, aircrack still can't fuction as normal (while boot into mandriva 2009.1 on the same laptop aircrack works flawlessly),
"airodump-ng --ivs -w name -c 6 mon0"
returned with error.......
any patch kernel as solution?
Logged