Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [Solved] xfce4.4.3 (VL 6.0) xflock4 does not work  (Read 6035 times)


  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
[Solved] xfce4.4.3 (VL 6.0) xflock4 does not work
« on: September 05, 2009, 06:54:33 pm »

Attempting to run xflock4 from either a keyboard shortcut (Ctrl-Alt-Del) or the terminal does nothing. It just sits there.

Also while in xscreensaver it also tells me "xscreensaver-demo: locking not enabled".

Any ideas?

EDIT: ok, after some googling about here is the solution:

1) remove xscreensaver daemon from process list
2) chmod a+s /usr/bin/xscreensaver
3) chmod 755 /usr/bin/xlock
4) restart xscreensaver daemon

« Last Edit: September 06, 2009, 01:06:34 pm by lagagnon »
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll