Please support VectorLinux!

Author Topic: passwords do not work - Corrupt file?  (Read 1451 times)


  • Member
  • *
  • Posts: 10
passwords do not work - Corrupt file?
« on: September 24, 2009, 07:34:34 am »
I have just changed the hard drive on my M700 and decided to do a fresh install (dual boot with Windows). After the first reboot I needed to run vxconf from text.

I typed su and it asked for the password. I have used the correct password but it does not work, it just says incorrect password. I have now tried many times. I have also tried to login as a user to see if that password will work, but it does not.

I think I will just reinstall. However, for reference, is is possible for passwords to become corrupt? If so what would be a way of sorting the problem


  • Administrator
  • Vectorian
  • *****
  • Posts: 3497
Re: passwords do not work - Corrupt file?
« Reply #1 on: September 24, 2009, 07:52:02 am »
You said you changed the hard drive.
There are a couple of possible scenarios, but the most likely is probably the following.

* The location of the drives changed in the process.
This means that what you used to have as /dev/hda is now /dev/hdb or something else...

If this happened, then your /etc/fstab needs to be adjusted so that your /home partition is mounted.

If you are not familiar with partitioning and /etc/fstab, the easiest way out is to reinstall if you dont mind losing the data.
Otherwise, I would boot a live cd to find out the new locations of the partitions, and then simply modify the /etc/fstab for my vl install. That should do it


  • Member
  • *
  • Posts: 10
Re: passwords do not work - Corrupt file?
« Reply #2 on: September 24, 2009, 09:30:46 am »
Thanks for the help. It was a fresh install rather than moving an existing version.

Reinstalling did the trick.

Thanks for the quick reply