VectorLinux
July 22, 2014, 05:27:13 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Lilo says it cant find vmlinuz and it won't install[SOLVED]  (Read 2425 times)
vovane
Member
*
Posts: 50


« on: October 06, 2009, 05:57:14 am »

I installed VL6.0 after a year of using various operating systems and now i found myself back in the Vector.But everytime i try to install LILO it says that it can't find vmlinuz and installation aborts.I am using the install CD to boot Vector,but it's not as good as lilo would be.I would appreciate any help Smiley
« Last Edit: October 06, 2009, 07:27:04 am by vovane » Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #1 on: October 06, 2009, 06:06:09 am »

log in as root in a terminal

Code:
vliloconf
Logged

vovane
Member
*
Posts: 50


« Reply #2 on: October 06, 2009, 06:07:44 am »

"Cannot find kernel(vmlinuz).Aborting install."
That's what i got after M0E-lnx command,and i got that before.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #3 on: October 06, 2009, 06:11:07 am »

Post the output of
Code:
ls -l /boot/
Logged

vovane
Member
*
Posts: 50


« Reply #4 on: October 06, 2009, 06:27:31 am »

Here it is.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #5 on: October 06, 2009, 06:35:56 am »

Yeah... you dont have a kernel.
Dont know whow you did this, or what happened, but this is how you solve it.

Code:
installpkg ftp://ftp-osl.osuosl.org/pub/vectorlinux/veclinux-6.0/kernels/kernel-2.6.27.12-i686-1vl60.tlz
run that as root in a terminal.
Then run vliloconf again.

As a safety precaution, I would also do
Code:
installpkg ftp://ftp-osl.osuosl.org/pub/vectorlinux/veclinux-6.0/kernels/kernel-modules-2.6.27.12-i686-1vl60.tlz
« Last Edit: October 06, 2009, 06:37:42 am by M0E-lnx » Logged

vovane
Member
*
Posts: 50


« Reply #6 on: October 06, 2009, 06:50:24 am »

Thank you,it works O.K. now!Btw,how can a situation like mine happen?I performed an ordinary setup from .iso which i used with install CD from Vector5.9. and did not do anything serious Smiley
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #7 on: October 06, 2009, 06:53:42 am »

I dont know..
Did you burn the ISO to a cd and boot off it?
or did the installer pick up the 5.9 ISO as an installation media source?
Are you sure this is 5.9?
Logged

vovane
Member
*
Posts: 50


« Reply #8 on: October 06, 2009, 07:23:26 am »

The installer surely was 5.9 installer,but i had the 6.0 .iso on the another hard disk and installer found it.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #9 on: October 06, 2009, 07:26:37 am »

yeah... that might have caused it

The contents of the ISO changed a bit from 5.9 to 6.0 (STD)... You should have burned your 6.0 ISO
Logged

vovane
Member
*
Posts: 50


« Reply #10 on: October 06, 2009, 07:42:01 am »

Thanks for the info.I did burn it to a CD,but it seems like my CD got some scrathes on it in a mysterious way when i was not watching Smiley It said that it couldnt extract required/veclinux.tlz after mere 20 mb,but when i started installation i destroyed my Debian so i wanted to install 5.9 to burn 6.0 Smiley
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #11 on: October 06, 2009, 07:50:39 am »

yeah.. that means it's a bad download or bad burn.

Check the md5sums before installing.
Logged

vovane
Member
*
Posts: 50


« Reply #12 on: October 06, 2009, 07:54:56 am »

When i said about scratches i forgot to say that md5sums were okay:)
Logged
raleeha
Member
*
Posts: 67



« Reply #13 on: July 17, 2011, 01:24:25 pm »

Quote
"Cannot find kernel(vmlinuz).Aborting install."
That's what i got after M0E-lnx command,and i got that before.

Code:
ls -l /boot
total 12
drwx------ 2 root root 12288 Jul  1 16:01 lost+found/

i wonder why this directory is empty?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!