VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Installed new Kernel - Wireless Module WL Not Found (read instructions - solved)  (Read 5208 times)

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly

I installed the patched kernel on my HP Mini 1010 and am unable to get the WL module to load. Tried 'depmod -aq' (ok) followed by 'modprobe wl' (fatal error).....

lsmod - old kernel:

Quote
root:# lsmod
Module                  Size  Used by
i915                   30208  1
drm                    70824  2 i915
snd_seq_dummy           3716  0
snd_seq_oss            31872  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                48368  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7436  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37408  0
snd_mixer_oss          15104  1 snd_pcm_oss
speedstep_lib           4740  0
acpi_cpufreq            7948  0
freq_table              4352  1 acpi_cpufreq
snd_hda_codec_idt      56192  1
rtc_cmos               10144  0
rtc_core               15132  1 rtc_cmos
rtc_lib                 3328  1 rtc_core
uvcvideo               54408  0
i2c_i801                9616  0
compat_ioctl32          2048  1 uvcvideo
videodev               33792  1 uvcvideo
i2c_core               21268  1 i2c_i801
serio_raw               6020  0
v4l1_compat            14852  2 uvcvideo,videodev
snd_hda_intel          25544  2
ieee80211_crypt_tkip     9728  0
snd_hda_codec          60928  2 snd_hda_codec_idt,snd_hda_intel
iTCO_wdt               10916  0
snd_hwdep               7812  1 snd_hda_codec
snd_pcm                67972  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
sky2                   42756  0
snd_timer              19976  2 snd_seq,snd_pcm
snd                    51492  16 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
wl                   1068292  0
soundcore               7008  1 snd
ieee80211_crypt         5380  2 ieee80211_crypt_tkip,wl
video                  17040  0
snd_page_alloc          8840  2 snd_hda_intel,snd_pcm
output                  3456  1 video
wmi                     6568  0
joydev                 10048  0
evdev                  10144  9

lsmod - new kernel:

Quote
root:# lsmod
Module                  Size  Used by
sky2                   42756  0
i915                   30464  1
drm                    70824  2 i915
snd_hda_intel         397104  2
snd_hwdep               8196  1 snd_hda_intel
snd_seq_dummy           3588  0
snd_seq_oss            31616  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                52016  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7564  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            46208  0
snd_pcm                75268  2 snd_hda_intel,snd_pcm_oss
snd_timer              20872  2 snd_seq,snd_pcm
snd_page_alloc          8712  2 snd_hda_intel,snd_pcm
snd_mixer_oss          15616  1 snd_pcm_oss
snd                    54052  14 snd_hda_intel,snd_hwdep,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore               7008  1 snd
speedstep_lib           4740  0
acpi_cpufreq            7948  0
freq_table              4352  1 acpi_cpufreq

Looks like I am missing something.....  ;)

My understanding is that the wl wireless driver is kernel dependent?????

Please point me in the right direction so I can get wireless working with the patched kernel.

Thank you - David
« Last Edit: October 15, 2009, 08:38:58 am by never_stop_learning »
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Installed new Kernel - Wireless Module WL Not Found
« Reply #1 on: October 14, 2009, 04:12:39 pm »

Did you follow these instructions:
http://forum.vectorlinux.com/index.php?topic=10385.0

particularly step 3 which deals with drivers like you're talking about
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Installed new Kernel - Wireless Module WL Not Found
« Reply #2 on: October 14, 2009, 08:26:13 pm »

After installing a new kernel, you must also install the kernel-modules package.

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly

Thought I installed the kernel-modules package. Must have been in a hurry and didn't.

D'oh #1: Install all the packages PROPERLY.....

Read the instructions regarding how to install a new kernel and followed them. Downloaded and installed the new wl driver. Everything works (posting from the new kernel now).

D'oh #2: Read the directions and follow them.

My apologies for the fire drill.
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std