Please support VectorLinux!

Author Topic: Vector Linux 6.0 KDE-Classic Beta 3 feedback  (Read 4570 times)

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Vector Linux 6.0 KDE-Classic Beta 3 feedback
« on: October 19, 2009, 06:47:16 am »
Thank you for helping us out by testing and reporting your findings in this forum.

Please post any bugs, comments or requests below.

nj_jak

  • Member
  • *
  • Posts: 47
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #1 on: October 20, 2009, 01:00:18 am »
Downloaded and installed on old lappy. This release seems to work better on the java-applet issue we have discussed. Will test further.

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #2 on: October 20, 2009, 06:07:58 am »
few small things
1)icons missong for games for kids catagory, and Kandy
2)kpackage doesnt recognize tlz packages(works good with tgz though).
3)hplip pkg in /


otherwise looks like a great release.

TLM

  • Member
  • *
  • Posts: 88
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #3 on: October 20, 2009, 10:03:54 pm »
Can't mount my USB flash drives or external HDs when plugged in under HAL. Have to use VL HOT or add all my thumb drives to mount at boot time using VASM. This is very inconvenient if I need to plug in a friend's drive to grab or share a file. I was using VL 591 SOHO, and I could plug in any thumb drive and it would appear in Storage Devices and let me open it. I even used the option in VASM to mount all drives. Am I missing something here? Thanks.
Particle board should be outlawed.

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #4 on: October 21, 2009, 04:47:04 am »
TLM, that was unexpected. I have not had any problems with HAL. On all versions, including this one, inserting a USB device causes it to appear in "Storage devices", as well as triggering a pop-up window asking what I want to do. Did it work for you in B2? Are anyone else having same problem?

TLM

  • Member
  • *
  • Posts: 88
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #5 on: October 21, 2009, 08:00:59 am »
I did not test usb drives in Beta 2, however they did work flawlessly in VL 591 SOHO. In this Beta 3, it pops up a message that a security policy in place prevents it from mounting. I will test further this evening and post details of the message.
Particle board should be outlawed.

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #6 on: October 21, 2009, 08:36:28 am »
usb thumbdrive works here with no problems.
tested with hal in kde
« Last Edit: October 21, 2009, 08:42:14 am by uelsk8s »

MikeCindi

  • Tester
  • Vectorian
  • ****
  • Posts: 1073
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #7 on: October 21, 2009, 09:39:05 am »
I'm getting the same problem as TLM that was not present in B2. There is a specific message that comes up about a boot time permission I believe (not at my test machine right now so will post it later).
The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #8 on: October 21, 2009, 10:19:49 am »
using vasm(vmount) to add thumbdrive to mount at boot the filesystem type is "type" instead of "fat32"
and now i get the "permissions denied" error.

MikeCindi, TLM, can you guys try and remove your removeable drives from /etc/fstab and see if they work in kde after that?

MikeCindi

  • Tester
  • Vectorian
  • ****
  • Posts: 1073
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #9 on: October 21, 2009, 03:56:35 pm »
I actually just connected it after booting and that corrected the access to my USB drive (functionally what uelsk8s suggested I believe). I'll just have to remember that in the future when booting until the next beta or RC. Otherwise I've not had problems yet but I also haven't done much yet.
The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143

TLM

  • Member
  • *
  • Posts: 88
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #10 on: October 21, 2009, 08:12:03 pm »
This is what I am getting:

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal")

I get the above Konqueror Error whenever I insert a USB thumbdrive and click on the resulting dialog box to open the drive in a new window. The thumb drive appears in Storage Devices, however I get the same result whenever I try to open it from there.

Particle board should be outlawed.

TLM

  • Member
  • *
  • Posts: 88
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #11 on: October 21, 2009, 10:30:43 pm »
Ok, I just reinstalled KDE Classic Beta 2, and I have the same issue with it.

I then went into VASM and set my thumb drive to mount at boot time. Rebooted and the drive was mounted. (I left it plugged in during the reboot) I then attempted to unmount it and got this error message:

Unfortunately, the device system:/media/sdb1 (/dev/sdb1) named 'PNY-2G' and currently mounted at /mnt/win could not be unmounted.
Unmounting failed due to the following error:
A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Unmount" error name "(unset)" destination "org.freedesktop.Hal")

This is the same test machine that I had VL591 SOHO on. No issues with VL591.

Test machine specs as follows:

BioStar K8 VGA-M Motherboard
AMD Athlon 3400+ cpu
2 gig PC3200 DDR
250 gig Seagate SATA drive
NVIDIA GeForce FX 5200 AGP

Particle board should be outlawed.

vector

  • Administrator
  • Vectorite
  • *****
  • Posts: 479
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #12 on: October 21, 2009, 10:53:50 pm »
Theres an error in the hal.conf file at /etc/dbus-1/system.d/hal.conf............The easiest way to fix this is fire up gslapt, update if neccesary, search for hal..........once found right click and choose the reinstall option then execute that. Once thats done use mc or your favorite file manager and navigate to /etc/dbus-1/system.d.
 You will see two hal files there hal.conf and hal.conf.new delete hal.conf and rename hal.conf.new to hal.conf.....once thats done reboot the system and your usb devices should work just fine. Anymore  problems...... lets us know...........:)

Cheers,
Vec

TLM

  • Member
  • *
  • Posts: 88
Re: Vector Linux 6.0 KDE-Classic Beta 3 feedback
« Reply #13 on: October 21, 2009, 11:36:59 pm »
Theres an error in the hal.conf file at /etc/dbus-1/system.d/hal.conf............The easiest way to fix this is fire up gslapt, update if neccesary, search for hal..........once found right click and choose the reinstall option then execute that. Once thats done use mc or your favorite file manager and navigate to /etc/dbus-1/system.d.
 You will see two hal files there hal.conf and hal.conf.new delete hal.conf and rename hal.conf.new to hal.conf.....once thats done reboot the system and your usb devices should work just fine. Anymore  problems...... lets us know...........:)

Cheers,
Vec

I performed the steps above. Everything now works perfectly  ;D You the man! One note: Upon renaming the hal file, the KDE crash handler pops up, but nothing to worry about. After rebooting, USB devices will mount and unmount like they are supposed to. One step closer to final release; can't wait! Testing SOHO Alpha 2 also; working great!
Particle board should be outlawed.