Please support VectorLinux!

Author Topic: HOWTO: Fix Firefox/Seamonkey/KDE render problem w/ ATI/Nvidia open-source driver  (Read 4451 times)

newt

  • Vectorian
  • ****
  • Posts: 1132
The problem mainly manifests itself in internet browsers (Firefox, seamonkey, chrome) using various open-source drivers (ati, radeon, nv, openchrome, etc) and causes rendering problems that look like overlapping images, text, and/or menu items (see images below for examples).

I've also noticed an inability in SOHO 6 Betas where the system will not display KDE Kickoff-style menu properly, rather it just displays the outline of where the menu _should_ be.  The fix below seems to have fixed this issue as well.

The fix:
    -as root, edit /etc/X11/xorg.conf
    -in the 'Device' section, add: Option "XAANoOffscreenPixmaps" "1"
    -save xorg.conf and restart X

Example)
Code: [Select]
Section "Device"
    Identifier  "Card0"
    Driver      "radeon"
    VendorName  "ATI Technologies Inc"
    BoardName   "Radeon Mobility"
    BusID       "PCI:1:5:0"
    Option      "XAANoOffscreenPixmaps" "1"
EndSection

Your driver, vendorname, and boardname will probably not be exactly as posted above.

This problem has plagued many folks in our community.  Hopefully this solves the issues for these folks.  Now we can use the most recent ff/sm releases without the annoying artifacts.
« Last Edit: February 28, 2010, 09:07:17 am by newt »

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Fabulous! I'm not at my ATI computers now but I'll give this a try tomorrow. I'll report what happens.
--GrannyGeek
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

roarde

  • Vectorian
  • ****
  • Posts: 585
  • move the needle
Posting this again here so it's more easily found:

I had the identical problem with the Openchrome driver on a chrome9, and this solution solved it. Going back to the vesa driver would have been unacceptable, because the reduction in rendering speed on this slow machine would have made many things simply unviewable once again.

Thank you.
Robert
VL Light RC 1.2

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Thanks for this! I've just installed 6.0 Standard and will give it a try if I have any problems (or maybe anyway, just to be on the safe side).

CP .

Andy Price

  • Packager
  • Vectorite
  • ****
  • Posts: 237
Thanks newt, I had almost had to abandon Firefox as this problem was getting so bad - even the Google home page wouldn't render correctly! No problems so far since carrying out the mod you describe.
Andy

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Thanks from me too newt. I've made this change to my xorg.conf file today and have had no problems with my browser display since.