VectorLinux
October 22, 2014, 05:22:03 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Hibernate Error: CPUfreq Unsupported and extra_pages_allowance <SOLVED>  (Read 4280 times)
LLL
Global Moderator
Vectorite
*****
Posts: 263


The sun is shining...


« on: October 23, 2009, 07:36:15 pm »

Update: With Uel's help, I was able to get past 2 errors, one the cpufreq scaling_setspeed and the other an issue with the extra_pages_allowance in my hibernate.conf file. See below for solutions.

--

Any ideas on why hibernation kicks back to where I was, outputing this in a popup or terminal (depending on how the hibernate command was issued):

Code:
root:# hibernate

Message from syslogd@Vector at Fri Oct 23 23:16:24 2009 ...
Vector kernel: Freezing processes & syncing filesystems.

Message from syslogd@Vector at Fri Oct 23 23:16:43 2009 ...
Vector kernel: Preparing Image. Try 1.

Message from syslogd@Vector at Fri Oct 23 23:16:43 2009 ...
Vector kernel: Starting to save the image..

Message from syslogd@Vector at Fri Oct 23 23:16:43 2009 ...
Vector kernel: Writing caches...

Message from syslogd@Vector at Fri Oct 23 23:16:43 2009 ...
Vector kernel: Doing atomic copy.

Message from syslogd@Vector at Fri Oct 23 23:16:43 2009 ...
Vector kernel: Doing atomic copy/restore.
hibernate: Suspend reported the following errors:
 - Suspend was aborted (see dmesg).
 - A suspend is already in progress?

Message from syslogd@Vector at Fri Oct 23 23:16:43 2009 ...
Vector kernel: Post atomic.

Message from syslogd@Vector at Fri Oct 23 23:16:43 2009 ...
Vector kernel: Cleaning up...
/tmp/tmp.hibernate.DWLp86: line 6: syntax error near unexpected token `>'
/tmp/tmp.hibernate.DWLp86: line 6: `[ -f "/sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed" ] && echo <unsupported> > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed'

dmesg says...
Code:
TuxOnIce debugging info:
- TuxOnIce core  : 3.0-rc7
- Kernel Version : 2.6.27.12
- Compiler vers. : 4.2
- Attempt number : 1
- Parameters     : 1025 1335304 0 1 0 0
- Overall expected compression percentage: 0.
- Checksum method is 'md4'.
  0 pages resaved in atomic copy.
- Compressor is 'lzf'.
  Compressed 658964480 bytes into 352692583 (46 percent compression).
- Max outstanding reads 0. Max writes 3280.
  Memory_needed: 1024 x (4096 + 188 + 76) = 4464640 bytes.
  Mutex contention while reading:
  Contended      Free
          0         0
  Mutex contention while writing:
  Contended      Free
          0    160880
  Free mem throttle point reached 0.
- SwapAllocator active.
  Swap available for image: 533766 pages.
- FileAllocator inactive.
- I/O speed: Write 64597 KB/s.
- Extra pages    : 3148 used/500.
- Result         : Hiberation was aborted.
                 : The extra pages allowance is too small.
[fglrx] It's not necessary to adjust system aperture on this ASIC

Running on VL6.0, XFCE, 2.6.27.12 on a Thinkpad T43p with 2GB RAM and a 2187MB Linux Swap partition, denoted in lilo.conf as:
Code:
image = /boot/vmlinuz
root = /dev/sda2
label = VectorLinux
append = "resume=swap:/dev/sda1" # "splash=silent"
initrd = /boot/initrd
read-only


I've Googled ad nauseum without any meaningful results. Any tips? Suspend to RAM works very well, but hibernate is better for me, and the times when I plan to leave my machine for days.

Thanks!

LLL
« Last Edit: October 25, 2009, 02:42:03 pm by LLL » Logged

Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
LLL
Global Moderator
Vectorite
*****
Posts: 263


The sun is shining...


« Reply #1 on: October 24, 2009, 05:45:08 am »

Apparently my Googling skills are improving...found this, a Gentoo bug report, indicating same issue. Some (in this report) seem to think the bug is fixed in hibernate script version 1.99, but that's what VL already had packaged. At the very bottom, another user indicates it's been fixed in the latest hibernate script, version 2.0.

http://bugs.gentoo.org/show_bug.cgi?id=223645

I've downloaded the TuxonIce provision of v2.0, and read the README on installation. It cautions as below...
Quote
AVOIDING DATA LOSS
------------------
If you are using the hibernate script with vanilla swsusp or TuxOnIce, then it
is strongly recommended that you install the script init.d/hibernate-cleanup.sh
into /etc/init.d (or the relevant place on your distribution), and arrange for
it to be run on boot from rcS.d, somewhere before enabling swap or clearing out
/var/run, but after mounting your filesystems (/var in particular).

This script will invalidate any suspend image on a clean boot so that the image
cannot be later resumed from (leading to corruption of your filesystems).
...which makes me a little nervous that the VL package of the hibernate script may have some VL-specific tweaking that I don't know about.

Any hibernating experts - or packagers of the hibernate script - that can offer guidance? I'm all for poking around, but the explicit warning around data-loss is a littly too borky for me! I will post back if I figure anything else out.

Thanks,

LLL
Logged

Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #2 on: October 24, 2009, 06:00:22 am »

LLL,
we use vanilla scripts.
It looks like we need to alter them so they run the hibernate-cleanup.sh

Uelsk8s
Logged
LLL
Global Moderator
Vectorite
*****
Posts: 263


The sun is shining...


« Reply #3 on: October 24, 2009, 06:29:50 am »

Thanks for checking in, Uel.

Is this something I could do when attempting to package hibernate script 2.0? Where would the cleanup.sh go in order to be run in VL? It's a little beyond my abilities/understanding, but I can grunt it out with direction...unless there's someone already assigned to this package.

LLL
Logged

Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #4 on: October 24, 2009, 06:45:25 am »

I packaged new hibernate scripts package
you can grab it from testing repo
just install it and reboot, then let me know if it works.  Smiley
Logged
LLL
Global Moderator
Vectorite
*****
Posts: 263


The sun is shining...


« Reply #5 on: October 25, 2009, 02:39:20 pm »

Uel,

Your updated script eliminated the cpufreq error, but still no hibernating - it starts, but then kicks right back to where I was without powering down. I did some more research, and found there's an issue with the extra_pages_allowance setting as it relates to fglrx drivers for ATI video cards. I added "ProcSetting extra_pages_allowance 7500" to /etc/hibernate/hibernate.conf:
Code:
# hibernate.conf is split into separate configuration files.
#
# Each file is tried in the order below, until an available suspend
# method is found.
#
# Options specific to a particular suspend method should be placed in the
# appropriate configuration file (suspend2.conf, ususpend.conf, disk.conf
# or ram.conf).
# Options common to all suspend methods should be placed in common.conf.
#
# See hibernate.conf(5) for help on the configuration items.

TryMethod suspend2.conf
TryMethod disk.conf
TryMethod ram.conf

ProcSetting extra_pages_allowance 7500

More info (barely) is available here: http://www.gentoo-wiki.info/Hibernate-script

Thanks, Uel for your help!

LLL

P.S. I've marked this post SOLVED! (And my machine is now hibernating.)
« Last Edit: October 25, 2009, 02:43:19 pm by LLL » Logged

Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
LLL
Global Moderator
Vectorite
*****
Posts: 263


The sun is shining...


« Reply #6 on: December 27, 2009, 05:55:11 pm »

Another update...

I just started using Compiz, obviously upping my video demands (I really just wanted the 'scale' feature - functional and pretty!!). Anyway, adding compiz took me back to the hibernate (suspend to disk) that wouldn't last: It would start, then kick right back to where I was. I increased the extra_pages_allowance in hibernate.conf (as per above) to 10000, and now I'm hibernating again.

Not sure what implications are for allowing more and more pages (perhaps more disk space for the suspend?), but seems increasing the amount (when /var/log/hibernate.log indicates that the allowance is too small) does the trick.

FWIW,

LLL

Edit: For those interested: http://wiki.cchtml.com/index.php/Suspend2
« Last Edit: December 27, 2009, 05:56:47 pm by LLL » Logged

Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!