VectorLinux
October 31, 2014, 12:47:35 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: laptop won't mount multimedia cdrom (Solved)  (Read 1403 times)
sledgehammer
Vectorian
****
Posts: 1425



« on: October 25, 2009, 06:20:06 pm »

I thought my problem (can't play XMMS on CD-ROM) was gnome-mount, and this Forum successfully showed me how to delete gnome-mount, whereupon XMMS played the file, but, as Pita surmised at the end of that thread (Removing gnome-mount, posted in Technical General on Oct 22, 09), removing gnome-mount didn't help for long. As soon as I rebooted, the CD-ROM would not mount the file.  I reloaded gnome-mount but that didn't help.  I tried to follow Pita's suggestion re switching XMMS to digital, but don't see how to do that.

As my other T-42 (also running VL 6.0 standard) mounts the multimedia CD-ROM fine, I am not sure why this T-42 doesn't, or at least doesn't with any regularity.  It mounts CD's with text or programs on it just fine, though, unlike on my other T-42, I have to click on the mounting icon at the bottom (doesn't seem to show files on CDROM automatically). I have reinstalled all programs that I think might work, but neither Thunar nor XMMS shows the multimedai file in question.  As I mentioned in the other thread, my other T-42 shows it fine.   And though the CDROM shows up in when I push the mounter button at the bottom of the screen, it shows as red (not mounted) on multimedia files (contra text CD text files which show mounted).

My own guess is that I have removed some library that is needed but have no clue which one.   I have installed the CDROM on VASMCC several times but doesn't work. I removed the CDROM from the "load at boot" program on vasmCC but again no difference that I can see. Any suggestions on how to get my system to recognize a music audio file on CDROM are appreciated. 
« Last Edit: October 25, 2009, 09:55:27 pm by sledgehammer » Logged

VL7.0 xfce4 Samsung RF511
Pita
Vectorian
****
Posts: 1311


« Reply #1 on: October 25, 2009, 06:51:45 pm »

A) xmms>options>preferences>Audio I/O Plugins>Enable CD Audio Player>Configure>Digital audio extraction

B) Insert CD then on terminal give command: cdda-player
     If CD plays then nothing wrong with system.
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #2 on: October 25, 2009, 08:43:33 pm »

If you are trying to play an AUDIO CD, you don't mount it. It doesn't have a real file system. You just insert it and XMMS may start automatically, or you start XMMS and and tell it to play location /mnt/cdrom.

If you are trying to play a CD with MP3 files or other true files in a format like OGG, you do mount the CD and you tell XMMS to open the directory with the files.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
sledgehammer
Vectorian
****
Posts: 1425



« Reply #3 on: October 25, 2009, 09:54:35 pm »

Thank you both so much.  XMMS works perfectly.  I just didn't know it. 

My son "invented" a song and I am playing it now.  Very good.

John
Logged

VL7.0 xfce4 Samsung RF511
Pita
Vectorian
****
Posts: 1311


« Reply #4 on: October 26, 2009, 06:44:56 pm »

BTW "nightflyer" has written a nice little program to mount various media with
even a Desktop icon.

Look for:
/usr/bin/explorer_cd 
/usr/bin/explorer_pd
/usr/bin/explorer_fd

At the and of the explorer_cd program one can change the media programs of ones liking.
I have xmms for Audio and xine for Video.

Insert a CD klick on the icon what to play and it starts playing. Very neat.
I put the prgrams into the HD 2133 to the delight of the owner.
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #5 on: October 26, 2009, 08:53:51 pm »

Pita,

For what its worth, I tried explorer_cd and got the error "Could not find any device /dev/cdwriter /dev/dvd /dev/cdrom."  But when I type cdda-player in xterm, the CD starts playing immediately.

John
Logged

VL7.0 xfce4 Samsung RF511
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #6 on: October 27, 2009, 04:21:54 am »

The explorer_cd script was extensively modified for Light. It uses xfe, xmms, xine and vburn to handle optical discs, but as Pita says, you can easily edit it.
Logged
sledgehammer
Vectorian
****
Posts: 1425



« Reply #7 on: October 28, 2009, 12:25:04 am »

nightflier is no doubt right, but modifying it is a bit beyond my abilities.  Even though cdda-player works well, I did add /mnt/cdrom to the devices line in explorer_cd, just as an experiment, but it didn't seem to help.

It is likely something I did to my system.

john
Logged

VL7.0 xfce4 Samsung RF511
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!