VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: [1] 2 3 ... 6

Author Topic: Installed Compiz Fusion But It Won't Work [SOLVED]  (Read 9522 times)

hippyredneck

  • Vectorite
  • ***
  • Posts: 112
Installed Compiz Fusion But It Won't Work [SOLVED]
« on: November 02, 2009, 01:38:11 pm »

 :) Thanks to the tutorial...
http://www.opensourcebistro.com/Tutorial/VL60/07.System/Compiz-Fusion/compiz.htm
I successfully installed compiz fusion, except when I try to start it I get a white screen. 
Then I have to unplug the computer to turn it off and restart it???


 [SOLVED] ;D
« Last Edit: November 10, 2009, 10:51:39 pm by hippyredneck »
Logged
“The only reason for time is so that everything doesn't happen at once.” ~ Albert Einstein

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Installed Compiz Fusion But It Won't Work
« Reply #1 on: November 02, 2009, 03:10:00 pm »

Looks like you dont have 3d acceleration working. What is your video card and which driver are you using? You can tell that from the output of

Code: [Select]
lspci
as root, and from

Code: [Select]
grep Driver /etc/X11/xorg.conf
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Installed Compiz Fusion But It Won't Work
« Reply #2 on: November 02, 2009, 03:11:10 pm »

If you get a white screen then your 3d graphics acceleration is not working correctly.  
What do you use for a graphics card?
To find out you can run then post out put of this command  in the terminal as root.
lspci | grep VGA

Then to find out what driver you are using post the out put of this command as root in the terminal.
cat /etc/X11/xorg.conf | grep Driver

If you can post the results you get from those two commands we should be able to help more.



Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

hippyredneck

  • Vectorite
  • ***
  • Posts: 112
Re: Installed Compiz Fusion But It Won't Work
« Reply #3 on: November 02, 2009, 06:33:17 pm »


Yes, okay, here it is...

root:# lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]

root:# cat /etc/X11/xorg.conf | grep Driver
Driver      "kbd"
Driver      "mouse"
### Available Driver options are:-
Driver      "radeon"

Thank you  :)
Logged
“The only reason for time is so that everything doesn't happen at once.” ~ Albert Einstein

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4108
Re: Installed Compiz Fusion But It Won't Work
« Reply #4 on: November 02, 2009, 06:43:18 pm »

Yep, your ATI card is using a generic driver which does not provide 3D acceleration for your card. You will need to install the kernel sources and compile the fglrx driver. The "vlati" package in the repo is your best bet.
Logged

hippyredneck

  • Vectorite
  • ***
  • Posts: 112
Re: Installed Compiz Fusion But It Won't Work
« Reply #5 on: November 02, 2009, 06:52:04 pm »

Yep, your ATI card is using a generic driver which does not provide 3D acceleration for your card. You will need to install the kernel sources and compile the fglrx driver. The "vlati" package in the repo is your best bet.

Yes, I guess I didn't pick the best one when I installed the card then. Please tell me how to install the kernel sources and compile the fglrx driver? Maybe that's what I did when I first installed the card? If that's the case, I might be able to refer to the Google Earth thread I posted here before. If not, is there a tutorial to tell me how to do that? Or maybe you wouldn't mind telling me here now if it's not too complicated a process.  :)
Logged
“The only reason for time is so that everything doesn't happen at once.” ~ Albert Einstein

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Installed Compiz Fusion But It Won't Work
« Reply #6 on: November 02, 2009, 07:01:58 pm »

Yep, your ATI card is using a generic driver which does not provide 3D acceleration for your card. You will need to install the kernel sources and compile the fglrx driver. The "vlati" package in the repo is your best bet.

Yes, I guess I didn't pick the best one when I installed the card then. Please tell me how to install the kernel sources and compile the fglrx driver? Maybe that's what I did when I first installed the card? If that's the case, I might be able to refer to the Google Earth thread I posted here before. If not, is there a tutorial to tell me how to do that? Or maybe you wouldn't mind telling me here now if it's not too complicated a process.  :)

First check if you dont have it installed already. You can use gslapt for that or look into the /var/log/packages directory. If you have a file starting with kernel-src there, then you have it already.
Noy if you dont have it installed, first find your kernel version: open a terminal and run

Code: [Select]
uname -r
With that number in your hand, go to http://vectorlinux.osuosl.org/veclinux-6.0/kernels/ and copy the link of the kernel-src package matching your kernel version. Now as root:

Code: [Select]
installpkg <paste_link_here>
That should take care of the kernel source. Now install the vlati package and run vxconf as root. Follow the prompts and install the proprietary driver needed for your card.

HTH
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Installed Compiz Fusion But It Won't Work
« Reply #7 on: November 02, 2009, 07:22:59 pm »

I am sorry to say, but your card is not supported by the fglrx driver, so your only options are the opensource ati or radeon drivers
Logged

hippyredneck

  • Vectorite
  • ***
  • Posts: 112
Re: Installed Compiz Fusion But It Won't Work
« Reply #8 on: November 02, 2009, 07:51:28 pm »

I'm gonna need a nap for this. :)
Logged
“The only reason for time is so that everything doesn't happen at once.” ~ Albert Einstein

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Installed Compiz Fusion But It Won't Work
« Reply #9 on: November 02, 2009, 08:25:45 pm »

Hey, Hippyredneck don't give up hope.

There may be a solution for you yet.  You can still install a driver from the ati site.

First of all go to the ati driver site.
http://support.amd.com/us/gpudownload/Pages/index.aspx
Then select linux in the first box, radeon in the second and 9600 in the third.  See picture.
Then click the download link on the resulting page.  It's toward the bottom.

Then follow this tutorial.  It was done for a nvidia driver install from the site but it works very much the same for an ati driver install.
http://www.opensourcebistro.com/Tutorial/VL60/01.Installation/nvidia/nvidia.htm

The only difference is you will be running the driver installer you downloaded from the Ati site rather than the driver installer from the nvidia site.

I'll see if I can make a tut using an actual ati driver as an example, but this should do for now.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

hippyredneck

  • Vectorite
  • ***
  • Posts: 112
Re: Installed Compiz Fusion But It Won't Work
« Reply #10 on: November 04, 2009, 01:45:29 pm »

No, I certainly haven't given up hope, thank you.

I did follow the tutorial and installed the driver from the amd site, but got a message at the end saying there were errors in the installation. Now the screen is all messed up and I can only login tui mode. So I'm at a different computer now. The message said something about autoconfig and, I wrote it down... /usr/share/ati/fglrx-install.log

I am burning a copy of vectorlinux light here on cd so hopefully I will be able to use my computer at home to talk with you more.

 :)
Logged
“The only reason for time is so that everything doesn't happen at once.” ~ Albert Einstein

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Installed Compiz Fusion But It Won't Work
« Reply #11 on: November 04, 2009, 02:35:37 pm »

Curses foiled again!!!
I was really hoping that would be the answer.

You don't have to reinstall to get your computer up and running again...
Just run vxconf again from tui mode. It will reset your xorg.conf to the radeon driver you had working before.  Then maybe try again.  I'll make an ati driver tut soon.
Resetting xorg.conf with vxconf
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

hippyredneck

  • Vectorite
  • ***
  • Posts: 112
Re: Installed Compiz Fusion But It Won't Work
« Reply #12 on: November 04, 2009, 05:08:15 pm »

Sorry, I meant vectorlinux light LIVE, so I wouldn't have to reninstall. At this point I want to avoid reinstalling considering all the work that's been put into this one. My friend was helping me put pbx in a flash on the virtual box. So far we had it installed on the virtual box, but not yet fully working. Lots of work, but quite fun. So I will try to fix it from what you've told me, thank you.
Logged
“The only reason for time is so that everything doesn't happen at once.” ~ Albert Einstein

hippyredneck

  • Vectorite
  • ***
  • Posts: 112
Re: Installed Compiz Fusion But It Won't Work
« Reply #13 on: November 06, 2009, 02:22:25 am »

Okay, I got the old driver working, but the compiz fusion still won't work. Just a white screen. I tried to put the new driver in again, it kinda stalls at 77% and then says there were errors in the installation. It says the errors can be seen at /usr/share/ati/fglrx-install.log, but when I put that in the tui mode it says permission denied. Any idea what I can do from here please? Thank you ALL for your help so far.
Logged
“The only reason for time is so that everything doesn't happen at once.” ~ Albert Einstein

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4108
Re: Installed Compiz Fusion But It Won't Work
« Reply #14 on: November 06, 2009, 05:18:17 am »

You probably need to use the root account to read the file then.
Logged
Pages: [1] 2 3 ... 6