VectorLinux
August 01, 2014, 02:15:50 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: New Kernel fail <solved>  (Read 1763 times)
InTheWoods
Vectorite
***
Posts: 302


« on: November 08, 2009, 07:17:39 pm »

I attemped to upgrade my kernel from the 2.6.27.12-i686-3vl60 stock install to the 2.6.28.4-i686-3vl60 version.
I downloaded and installed source and modules as well using 'installpkg' then updated with 'vliloconf'.

On booting the new kernel I got a standard text booting screen everything working fine untill just before you would come to a login prompt. At this point the screen flashes several times and 'x' fails to start giving several messages (I can't reproduce faithfully).

When I originaly installed Vec6.0 I chose to install the proprietary nvidia drivers. According to the error message this fails to load. The last message is that 'gdm is shut down'.

Question #1 Is there any way to build and insert a new nvidia module into /lib/modules/2.6.28.4/build/drivers/video/nvidia/? The directory exists. And I see in /lib/modules/2.6.28.4/source/drivers/video/nvidia/ files wich are identical. These files mostly end with .c but I also see a makefile in there.

Question #2 If I had chosen a non-proprietary driver on the initial install would the new kernel function normaly? It has worked on the open source driver before.

I see that Pita has a similar problem here.
But from his published error message it would appear that he is actually trying to install the driver. I can't even type in a terminal to attempt this. Nor would I know how if I could.

Any help would be appreciated.
« Last Edit: November 09, 2009, 05:00:24 pm by InTheWoods » Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #1 on: November 08, 2009, 07:50:24 pm »

the nvidia driver needs to be rebuilt for each kernel that is installed.
just run vxconf as root and it will guide you through it.

the opensource driver does not need to be recompiled for each new kernel but does not perform as well as the closed source driver.
you should be able to switch to another terminal by pressinf CTRL+ALT+F2 then login as root and run vxconf or you can use the TUI boot option.
Logged
InTheWoods
Vectorite
***
Posts: 302


« Reply #2 on: November 09, 2009, 04:59:14 pm »

Quote
you should be able to switch to another terminal by pressinf CTRL+ALT+F2 then login as root and run vxconf
There is the answer I was looking for. I had totaly forgoten that you could open up a new terminal and get access to vxconf.

Quote
or you can use the TUI boot option
If you do this don't you just rebuild the driver for the original kernel?

I did use vxconf while using the original kernel and switched from the 'nvidia' to the 'nv' driver. It actually runs better this way.

All is well with the new kernel. Thanks.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!