VectorLinux
October 01, 2014, 03:57:26 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 6.0Light:Can't lock or logout using ctrl+alt+de in IceWM  (Read 1562 times)
vovane
Member
*
Posts: 50


« on: November 19, 2009, 09:48:46 am »

As documentation for IceWM says,i can lock or shutdown\reboot the system by pressing ctrl+alt+del and selecting the appropriate action or pressing the right hotkey.But buttons "Lock workstation","Shutdown" and "Reboot" are inactive and i can't activate them,so the menu becomes useless.What should i do to activate these buttons?I would really like to lock the system by pressing ctrl+alt+del and enter!:)Give me a tip please:)
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4024



« Reply #1 on: November 19, 2009, 06:16:45 pm »

A quick workaround would be to edit the file ~/.icewm/keys file.
Add a line something like:
Code:
key "Alt+Ctrl+End"     xscreensaver-command -lock
Pick a key combination that makes sense to you.
Restart IceWM after making the changes.
Logged
vovane
Member
*
Posts: 50


« Reply #2 on: November 20, 2009, 11:47:09 am »

Thanks,but this is not good.I want that menu to work,they described it so tasty...I will google around again.Thanks again.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4024



« Reply #3 on: November 20, 2009, 12:04:16 pm »

You can avoid the customizations to IceWM by de-selecting it during install of Light.

Then install a pristine version of IceWM afterwards, using gslapt or directly from the source: http://www.icewm.org/

Logged
vovane
Member
*
Posts: 50


« Reply #4 on: November 20, 2009, 12:06:34 pm »

But can i just reinstall it from source now?Without reinstalling the whole Light?
Logged
newt
Vectorian
****
Posts: 1132



« Reply #5 on: November 20, 2009, 12:42:59 pm »

vovane,

I was able to activate the 'Lock' option by simply editing the preferences (/home/user/.icewm/preferences).
Uncomment the Lock command: # LockCommand=""
Adjust command to your preference: LockCommand="xlock -mode blank"
Log out of icewm and back it. It should now work.

Hope this helps

Edit:
information comes from here: http://www.icewm.org/FAQ/IceWM-FAQ-5.html#ss5.4
Logged
vovane
Member
*
Posts: 50


« Reply #6 on: November 20, 2009, 12:48:18 pm »

It only blanks out the screen.It becomes black and nothing else.Also,it doesn't actually lock anything - screen unlocks when i press enter twice.I also didn't find anything in google yet.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4024



« Reply #7 on: November 20, 2009, 01:01:02 pm »

This works for me:
Code:
LockCommand="xscreensaver-command -lock"
Logged
vovane
Member
*
Posts: 50


« Reply #8 on: November 20, 2009, 01:04:21 pm »

Great!That works.Now i see there are some more options to fill in:shutdown and reboot.All these commands exist when i am logged in as root,but what for a simple user?And thanks again,nightflier:-)
Logged
newt
Vectorian
****
Posts: 1132



« Reply #9 on: November 20, 2009, 02:36:14 pm »

I should have mentioned that you need to initially set 'xlock' - i.e. run it once from the terminal and it will prompt you to set the locking password. Regardless, xscreensaver with the lock option is more in-line with what you were after anyway.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!