VectorLinux
August 30, 2014, 10:18:35 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: APM [FAILED]  (Read 2378 times)
w2ibc
Packager
Vectorite
****
Posts: 114

GAHHHHHH!!!!!


WWW
« on: November 29, 2009, 02:36:22 am »

just noticed this as i was rebooting between kernels

as it is going though the text between gui kernel selection to GDM

during "setting up hardware" i get a

setting up apm [FAILED]
Logged

Linux Registered User #481509.
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #1 on: November 29, 2009, 03:32:08 am »

APM is legacy technology, not supported by very many PCs anymore. Most will be using ACPI ( Smiley so long as you've enabled it, anyway).

The APM 'failed' message is not very important. To stop it, you need to make the /etc/rc.d/rc.apm script non-executable.

Easiest way is to use mc - open a terminal, su to root, start Midnight Commander and navigate to /etc/rc.d  Find the rc.apm script (easiest way is to enter ALT-S in mc, then enter 'rc.apm', which will move the cursor to the script).

With the cursor over rc.apm, press CTRL-x, then c. You will get a box with permissions shown for the file under the cursor. Select any of the 'execute' options that show an x and remove the 'x' from the box. Then click on the 'set' option. The file will no longer be execuatble.

HTH.

paul.
Logged
w2ibc
Packager
Vectorite
****
Posts: 114

GAHHHHHH!!!!!


WWW
« Reply #2 on: November 30, 2009, 02:41:54 am »

thanks that fixed it
Logged

Linux Registered User #481509.
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: November 30, 2009, 10:30:48 am »

Great tip!, toothandnail.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Cepo
Member
*
Posts: 11


« Reply #4 on: January 23, 2010, 04:40:54 am »

Hi. I turn off rc.apm as executable, but after reboot didn't work Performance Profiles and Vcpufreq too. Than, I musted turn on rc.apm to executable back because
I am using Ondemand governor and sometimes cpuspeedy. This stuff is not working with APM off  Roll Eyes

Any Ideas??
Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #5 on: January 23, 2010, 05:21:50 am »

Hi. I turn off rc.apm as executable, but after reboot didn't work Performance Profiles and Vcpufreq too. Than, I musted turn on rc.apm to executable back because
I am using Ondemand governor and sometimes cpuspeedy. This stuff is not working with APM off  Roll Eyes

Any Ideas??

Odd. What is the machine? If it is old, it may need APM support for CPU throttling to work.

Other options are to check what module is loaded for CPU control. I can't remember the AMD one off-hand, but for my Intel Cor2Duo its acpi_cpufreq. I have had some instances where I had to make sure that the correct module was loading.

If there is a problem with the correct module loading, you can add it to /etc/rc.d/rc.modules (or uncomment it if it is already in the file).

Paul.
Logged
Cepo
Member
*
Posts: 11


« Reply #6 on: January 23, 2010, 10:10:41 am »

Thanks for answer.  It is 2 years book, HP Compaq 6820s, core2duo 2x2.0Ghz.  I will check the settings of rc.modules and I will see what next.  Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!