VectorLinux
August 28, 2014, 07:06:32 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 20091203 pidgin-2.6.4 [VL6.0]  (Read 1946 times)
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« on: December 03, 2009, 05:26:54 am »

hatap_ph has built a new Pidgin package for VectorLinux 6.0.
   
      
   
Code:
pidgin: pidgin (multi-protocol Instant Messaging client)
pidgin:
pidgin: Pidgin is an instant messaging program for Windows, Linux, BSD,
pidgin: and other Unixes. You can talk to your friends using AIM, ICQ,
pidgin: Jabber/XMPP, MSN Messenger, Yahoo!, Bonjour, Gadu-Gadu, IRC,
pidgin: Novell GroupWise Messenger, QQ, Lotus Sametime, SILC, SIMPLE,
pidgin: MySpaceIM, and Zephyr.
pidgin:
pidgin: License: GPL
pidgin: Authors: Sean Egan
pidgin: Website: http://www.pidgin.im/
   
   After testing this package please stop back here and let us know how it works for you.
   
Logged
budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #1 on: December 07, 2009, 04:46:42 pm »

it all works except for the audio calls with gtalk.

getting the following error:
Code:
(06:51:02 PM) Error creating session: Could not create the valve element
(06:51:02 PM) Error adding stream.
(06:51:02 PM) The call has been terminated.

Is it just on my box, or is it the package that misses something?
Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
hata_ph
Moderator
Vectorian
*****
Posts: 3256


-- Just being myself --


« Reply #2 on: December 07, 2009, 05:01:55 pm »

Try remove your gstreamer folder from your home directory....

http://ubuntuforums.org/showthread.php?p=7834225
Logged
budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #3 on: December 07, 2009, 08:40:15 pm »

First of all thanks a lot for keeping the pidgin package updated.

Quote
Try remove your gstreamer folder from your home directory....
I tried that one before, but it didn't help.
Tried with this version again, but I still get the same error.
I have gst-plugins-good and gst-plugins-bad installed,absence of which was causing this problem for the people at arch linux forum.

Does this function work for you?

EDIT:
I think I found what the problem was - I didn't have gst-plugins-farsight installed.
Now it just says "Error creating session."

Actually no, I tried again, pidgin crashed, and now it's back to the whole valve element business again.

« Last Edit: December 07, 2009, 08:48:00 pm by budulay » Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
hata_ph
Moderator
Vectorian
*****
Posts: 3256


-- Just being myself --


« Reply #4 on: December 07, 2009, 09:55:16 pm »

I don't have a webcam so I cannot test it for you....

what version of gstreamer you have?
does it crash only you use the video?
Logged
budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #5 on: December 08, 2009, 09:44:31 am »

I don't have a camera either, so I was just testing the audio call part.

It crashed once after I installed gst-plugins-farsight. it went like this:
I installed the plugin, I tried to call someone, it gave me "Error creating conference".
Then I tried to call again and it chashed.
Then it went back to the original valve element error.

I will try resetting gstreamer options again once I get home, and see what happens.

I use the latest one from the repo - gstreamer-0.10-25 I believe.
Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #6 on: December 08, 2009, 07:40:00 pm »

Basically here is the picture:

if I have .gstreamer-0.10 directory, once I try audio call I get the good old valve element story

if I delete .gstreamer-0.10 and then run pidgin and try audio call, it crashes.
I ran it from command line and here's the output:
Code:
(Pidgin:15031): GStreamer-CRITICAL **: gst_caps_ref: assertion `GST_CAPS_REFCOUNT_VALUE (caps) > 0' failed

(Pidgin:15031): GStreamer-CRITICAL **: gst_caps_unref: assertion `GST_CAPS_REFCOUNT_VALUE (caps) > 0' failed

(Pidgin:15031): GStreamer-CRITICAL **: gst_caps_ref: assertion `GST_CAPS_REFCOUNT_VALUE (caps) > 0' failed

(Pidgin:15031): GStreamer-CRITICAL **: gst_caps_unref: assertion `GST_CAPS_REFCOUNT_VALUE (caps) > 0' failed

(Pidgin:15031): GStreamer-CRITICAL **: gst_caps_ref: assertion `GST_CAPS_REFCOUNT_VALUE (caps) > 0' failed

(Pidgin:15031): GStreamer-CRITICAL **: gst_caps_unref: assertion `GST_CAPS_REFCOUNT_VALUE (caps) > 0' failed

(Pidgin:15031): GStreamer-CRITICAL **: gst_caps_ref: assertion `GST_CAPS_REFCOUNT_VALUE (caps) > 0' failed

(Pidgin:15031): GStreamer-CRITICAL **: gst_caps_unref: assertion `GST_CAPS_REFCOUNT_VALUE (caps) > 0' failed
OIL: ERROR liboiltest.c 361: oil_test_check_impl(): illegal instruction in mmxCombineAddU

(Pidgin:15031): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed
Pidgin 2.6.4 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the developers
by reporting a bug at:
http://developer.pidgin.im/simpleticket/

Please make sure to specify what you were doing at the time
and post the backtrace from the core file.  If you do not know
how to get the backtrace, please read the instructions at
http://developer.pidgin.im/wiki/GetABacktrace
Aborted

I'll google that and 'll see what I could find.

EDIT:
Found lots of gstreamer errors like the one I had. The problem seems to be a conflict between the gst-plugins-farsight and gst-plugins-good. Also it looks like the newer gst-plugins-good makes gst-plugins-farsight obsolete.

Can someone else please test the pidgin-gtalk audio call function to check whether it is my local problem, or there is something missing in the pacakge.
« Last Edit: December 08, 2009, 08:06:54 pm by budulay » Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
hata_ph
Moderator
Vectorian
*****
Posts: 3256


-- Just being myself --


« Reply #7 on: December 10, 2009, 05:14:26 pm »

It seem to enable video/voice call in pidgin require gst-plugins-good and gst-plugins-bad...i have upload the plugins and repackage pidgin....I have uploaded it....pls help to move to the testing repo...

Quote
aaa_base >= 12.1.0-noarch-2 | glibc-solibs >= 2.7-i486-10
aspell >= 0.60.6-i586-1vl60
atk >= 1.22.0-i486-1
cairo >= 1.6.4-i586-1vl60
coreutils >= 6.9-i486-1
cxxlibs >= 6.0.9-i486-1 | gcc-g++ >= 4.2.3-i486-1
cyrus-sasl >= 2.1.22-i486-1
dbus >= 1.1.20-i486-1
dbus-glib >= 0.74-i486-2
expat >= 2.0.1-i486-1
farsight2 >= 0.0.15-i586-1vl60
fontconfig >= 2.4.2-i486-2
freetype >= 2.3.9-i586-1vl60
gcc >= 4.2.3-i486-1
glib2 >= 2.16.3-i586-1gsb
gnutls >= 2.6.1-i486-1_slack12.1
gst-plugins-bad >= 0.10.14-i586-1vl60
gst-plugins-base >= 0.10.25-i586-2vl60
gst-plugins-good >= 0.10.16-i586-1vl60
gstreamer >= 0.10.25-i586-1vl60
gtk+2 >= 2.12.9-i486-1
gtkspell >= 2.0.11-i586-2gsb
libICE >= 1.0.4-i486-1
libSM >= 1.0.3-i486-1
libX11 >= 1.1.4-i486-1
libXScrnSaver >= 1.1.3-i486-1
libXau >= 1.0.3-i486-1
libXcomposite >= 0.4.0-i486-1
libXcursor >= 1.1.9-i486-1
libXdamage >= 1.1.1-i486-1
libXdmcp >= 1.0.2-i486-1
libXext >= 1.0.4-i486-1
libXfixes >= 4.0.3-i486-1
libXi >= 1.1.3-i486-1
libXinerama >= 1.0.3-i486-1
libXrandr >= 1.2.2-i486-1
libXrender >= 0.9.4-i486-1
libgcrypt >= 1.4.0-i486-2
libgpg-error >= 1.6-i486-3
libidn >= 1.5-i486-1
libpng >= 1.2.35-i586-1vl60
libxcb >= 1.0-i486-2
libxml2 >= 2.6.32-i486-1_slack12.1
ncurses >= 5.6-i486-3
pango >= 1.20.0-i486-1
perl >= 5.10.0-i586-1vl60
pixman >= 0.10.0-i486-4
python >= 2.5.2-i486-1
sqlite3 >= 3.5.6-i586-2gsb
startup-notification >= 0.9-i486-1
tcl >= 8.4.18-i486-1
tk >= 8.4.18-i486-1
zlib >= 1.2.3-i486-2
« Last Edit: December 10, 2009, 05:21:40 pm by hata_ph » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!