VectorLinux
October 01, 2014, 02:07:23 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 20091030 mc-4.7.0_pre4 [VL6.0]  (Read 2102 times)
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« on: October 30, 2009, 01:42:54 pm »

toothandnail has built a new Mc package for VectorLinux 6.0.
   
      
   
Code:
mc: mc (GNU Midnight Commander)
mc:
mc: MC is a user shell with a text-mode full-screen interface.
mc: It can be run on the OS console, in xterm and other
mc: terminal emulators. It allows you to manage files while
mc: still having access to the command line. It is simple to
mc: use, and provides virtual filesystem support for compressed
mc: files including LZMA compression.
mc: License: GPL
mc: Authors: Andrej Borsenkow <borsenkow.msk@sni.de> & others
mc: Website: http://www.ibiblio.org/mc/

Smiley I didn't expect it to take long for 4.7.0-pre4 to come out, but I didn't think it would be quite this fast....   

   After testing this package please stop back here and let us know how it works for you.
   
« Last Edit: October 30, 2009, 01:45:22 pm by toothandnail » Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #1 on: November 16, 2009, 02:15:03 pm »

 Grin Just to add a little bit....

As well as supporting the new Slackware package format (.txz), this new version of MC now supports 'skins'. There are several examples provided - they can be found in /usr/shar/mc/skins and can be loaded by starting MC with 'mc -s <name-of-skin>

They allow the user to customise colour and other settings very easily, especiall things like the colours used for different file types (some of the default ones are just about invisible on my systems).

Other neat new features include keyboard shortcuts for changing panel sort orders, a <meta>-. command to toggle the display of hidden files on and off.

One annoyance is that something is broken when 'autosave settings' is turned off. I always used to untick 'autosave settings', then set up a couple of directories that I wante to have selected when I first started MC, then use the menu option to save settings. At which point, every time I started MC, the right hand pane would be in the same directory. Unfortunately, this no longer works. Even with autosave turned off, the right hand pane will default to whatever directory was selected when MC was shut down. Hopefully this may get fixed in the near future.

paul.
Logged
MikeCindi
Moderator
Vectorian
*****
Posts: 1073


« Reply #2 on: November 16, 2009, 03:55:13 pm »

Installed this on KDE Classic and of course works well for me but haven't tried the autosave features yet.
Logged

The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143
Pita
Vectorian
****
Posts: 1310


« Reply #3 on: November 28, 2009, 10:50:24 pm »

Unable to make it display properly. The lines are thick garbled characters rendering mc useless.
Good I had made a backup of the former version.

In slackware-13 this version of mc displays properly, again not in my VL box.
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #4 on: November 28, 2009, 11:10:28 pm »

Unable to make it display properly. The lines are thick garbled characters rendering mc useless.
Good I had made a backup of the former version.

In slackware-13 this version of mc displays properly, again not in my VL box.

Strange. What terminal are you running it in? I've got it running in Xfce's terminal, xterm and the KDE Konsole, all without any problems. It will not display properly in Aterm (which I used to use a lot), because Aterm is no UTF8 capable. In that environment, it displays rows of letters instead of lines, which is pretty hard on the eyes.

paul.
Logged
Pita
Vectorian
****
Posts: 1310


« Reply #5 on: November 29, 2009, 05:21:39 pm »

Yes the problem is with aterm. I use a script to open mc which uses aterm.
I changed to xterm and the new mc opens properly.
That script uses a larger terminal and can open as su with then red background.

Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #6 on: November 30, 2009, 12:54:19 am »

Yes the problem is with aterm. I use a script to open mc which uses aterm.
I changed to xterm and the new mc opens properly.

Its a pity Aterm is not being updated any more. I used to use it because it was light weight and could be easily controlled in a script. I'm now back to using the Xfce terminal, which is not as much too my liking.

Quote
That script uses a larger terminal and can open as su with then red background.

Not sure about xterm (I've not used it much), but with the Xfce terminal, you can still control the terminal size. I use this as a launcher from wbar for MC:

Code:
i: /usr/share/icons/hicolor/48x48/apps/gftp.png
c: terminal --geometry 104x36 -T MC -e mc
t: MC

That gets me a wider than normal window for MC, and also sets the terminal name (though it doesn't show the path information that mc normally shows, unfortunately. I also have a launcher for MC with root access which uses su -c to open it.

Smiley I use MC a lot, so when I boot any of the machines, it is usually one of the first things that I start, and it usually runs all the time. Can't live without MC....

paul.
Logged
Pita
Vectorian
****
Posts: 1310


« Reply #7 on: November 30, 2009, 08:42:20 pm »

Until this new version of mc-4.7.0 the program has always opened properly
with aterm. Why the change now beats me.

I have a launcher on my xfce-panel one for user accessing ~/.bin/.mc and one for root
now reading:
Code:
xterm -bg brown -fg white -cr blue -g 75x55 -fn -misc-*-*-*-*-*-15-* -e su -c mc

Before it was aterm.

My .mc script:

Code:
#!/bin/sh
if [ -d "$HOME/.mc" ]; then
    FIRST="no"
else
    FIRST=""
fi
if [ -z "$DISPLAY" ]; then
   mc
else
   if [ "$UID" == 0 ]; then
      xterm  -bg brown -fg white -cr blue -fn -misc-*-*-*-*-*-15-* -T "MC as super-user" -tn xterm -g 85x60 -e mc &
   else
      xterm  -bg blue -fg white -cr yellow -fn -misc-*-*-*-*-*-15-* -T "Midnight Commander" -tn xterm -g 85x60 -e mc &
   fi
fi
snip..../....

The first xterm was aterm until now and the -T flag never worked.

So in xterm I give command: "sudo .mc" for mc with root access.

Yes, me too could not live w/o mc. I must have tried a dozen other FMs
there might be at least 6 in my box none I rarely use, MC is still the best.

Edit:
 I just checked in slackware-13. This new version of mc opens perfectly with aterm
as well as with rxvt. So the problem is with VL-6 again.
« Last Edit: December 01, 2009, 12:41:41 am by Pita » Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #8 on: December 01, 2009, 07:53:51 am »

The reason for the display problem is that Aterm is old and is not Utf8 compliant. The new version of MC is (finally) UTf8 compliant.

If the Slackware version of MC works with Aterm, I can only assume that the Slackware build has disabled MCs UTF8 handling. I do not intend to do that with the VL build. You could try the Slackware package under VL and see what sort of results that gets.

paul.
Logged
Pita
Vectorian
****
Posts: 1310


« Reply #9 on: December 01, 2009, 08:28:49 pm »

The reason for the display problem is that Aterm is old and is not Utf8 compliant. The new version of MC is (finally) UTf8 compliant.

If the Slackware version of MC works with Aterm, I can only assume that the Slackware build has disabled MCs UTF8 handling. I do not intend to do that with the VL build. You could try the Slackware package under VL and see what sort of results that gets.

paul.

I am using the slackware version of MC in my VL box and the result is the same as with the VL version,
aterm cannot display MC properly. I copied my aterm version into the slackware box
and aterm displays MC properly there. Huh
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #10 on: December 01, 2009, 09:44:47 pm »

Smiley I think I've found it.....

If you open a terminal in Slackware and enter:

Code:
echo $LANG

what does it return?

As a second test, execute the same command from a terminal in VL 6.0 and let me know what it returns....

As a further test, open an Aterm terminal in VL, enter the following command:

Code:
export LANG=C


Then start MC and see what it looks like.

I think the problem is down to the fact that Slackware has made no attempt whatever to get proper locale handling. You will probably find that the LANG variable in Slackware is either C or en_US. Aterm can handle those locales, where it can't handle something like en_GB.utf8 (which is what I use).

As a last ditch effort to get MC to be usable in Aterm, you could modify your script to include this:

Code:
export LANG=C

before you start MC. That will problably fix it, though its a horrible kludge.

Another alternative would be to use urxvt. Unfortunately, I don't like the key mappings it uses (you can't use ALT-S to search in MC, for instance) and my attempts to fix the mapping haven't worked very well. I've also managed to break something in the setup that it uses, since it is now coming up with fonts so tiny that even with a magnifying glass, I can't read them (and I like tiny fonts!).

Anyhow, let me know how you get on with that.

paul.
Logged
Pita
Vectorian
****
Posts: 1310


« Reply #11 on: December 02, 2009, 05:04:12 pm »

Smiley I think I've found it.....

If you open a terminal in Slackware and enter:

Code:
echo $LANG

what does it return?

en_US

Quote
As a second test, execute the same command from a terminal in VL 6.0 and let me know what it returns....

en_US.USF-8

Quote
As a further test, open an Aterm terminal in VL, enter the following command:

Code:
export LANG=C


Then start MC and see what it looks like.

Nice as it used to be. The lines are lines.

Quote
I think the problem is down to the fact that Slackware has made no attempt whatever to get proper locale handling. You will probably find that the LANG variable in Slackware is either C or en_US. Aterm can handle those locales, where it can't handle something like en_GB.utf8 (which is what I use).

Another alternative would be to use urxvt. Unfortunately, I don't like the key mappings it uses (you can't use ALT-S to search in MC, for instance) and my attempts to fix the mapping haven't worked very well. I've also managed to break something in the setup that it uses, since it is now coming up with fonts so tiny that even with a magnifying glass, I can't read them (and I like tiny fonts!).

Anyhow, let me know how you get on with that.

paul.

In my box urxvt opens the search with Alt-Shift-?, however, not anymore in xterm. I have to use Esc-Shift-?
which is harder on my stiff fingers. rxvt apparently cannnot read en_US.YSF-8 as well just as aterm.
BTW aterm is not included in slackware.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!