VectorLinux
April 24, 2014, 02:56:02 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: How to get rid of home and filesystem icons on the desktop with XFCE/COMPIZ?  (Read 1283 times)
haywire
Vectorian
****
Posts: 507


« on: December 03, 2009, 05:54:23 am »

Well this is probably the last thing for my system setup, being a long time amiga user, I wanted to setup my vector system much like my amiga box.

I managed to setup a panel much like amidock, its full of program launchers. Nightflier helped me setup a ram disk and I have a desktop icon that looks like amiga os to access the ram disk now...

The whole system is setup exactly how I wanted, looking very amiga os like except that the home and file system icons are still there. I setup icons to access my hard drives from the desktop, but I wanted to remove the home and file system icons on the desktop...

If I could do that it would look very similar to the amiga setup I've come so accustomed to. I have my windows box setup like this pretty much as well.
Looks like this :

http://www.amigahistory.co.uk/amigaforever/aforever1.png

This is how I'd prefer my vector desktop to look, except the program launcher bar is at the top and I'm keeping the vector bar with start menu at the bottom of the screen.

I'm using vector linux 6.0 standard with xfce/compiz. My main setup is on user steven not root.

I tried to access those files via gui on the root account, they must be hidden because they don't show in the folder.
Can someone tell me how to change those file permissions so I can delete them from the desktop?

I have an icon for file system and home on my bottom start bar, just in case I still need to access them, I can also still access them via thunar in the console if necessary. I know this may not be important to some, but I want my custom setup to look and work how I'd like, and thats one point of why I like linux so much, because its generally configurable for everything you see.

I know this can be done, but I tried some stuff with chmod but I'm not finding a way to get this thing done. Again, its a little thing but its very important to me to make the system look and work how I prefer it to.

Any help, I'm all ears, Thanks to everyone so far, this new setup is my best ever.... Will post screen shots as soon as I get this done, it all looks fantastic... Almost all setup now except for this and a few other little interface improvements I want to make....

Thanks!

Steven

Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: December 03, 2009, 11:22:31 am »

Should be easy...
1. Switch you window manager back to Xfwm4....
Right click the compiz fusion icon go to 'select window manager' then 'xfwm4'
Or just don't start up compiz after you boot in.

2. Turn off all desktop icons.
Go to menu --->Settings-->Desktop
In the resulting window go to 'Behaviour' and select 'none' from the drop down list under 'Desktop Icons'

You can then start up compiz and be icon free.

Note if you do this with compiz running you could lose your wallpaper.
To get it back requires an extra step. In the terminal type 'xfdesktop --reload'.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
haywire
Vectorian
****
Posts: 507


« Reply #2 on: December 03, 2009, 12:02:37 pm »

I don't want no icons, I just don't want a home and file system icon...

I would like an icon to access each hard drive (already set up) and an icon to access the ram disk (already set up) and thats it for now except for things I may want to add later, mostly folders, like a folder for games, a folder for mp3's, a folder for video files, and so on....

Any idea how to keep the ability to have icons on screen but still be able to ditch just the home and file system icons?

I've tried a few more things and nothing worked right so far. Very frustrating argh...

Steven
Logged
haywire
Vectorian
****
Posts: 507


« Reply #3 on: December 05, 2009, 10:44:28 am »

Anyone else have any ideas? I would think this should be a pretty easy thing to accomplish but I've had no luck so far...
Very frustrating...

Steven
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #4 on: December 05, 2009, 03:54:14 pm »

Just to make sure... You've tried browsing to /home/(yourself)/Desktop in the file manager and tried deleting the files by right-clicking them and choosing delete?
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
haywire
Vectorian
****
Posts: 507


« Reply #5 on: December 05, 2009, 11:33:41 pm »

yes I tried that but no files or entries from the home or file system icons show up in file manager.
I also tried show hidden files and refreshing the folder, still does not show those entries.

This is a strange problem, had a similar thing in suse or red hat but I think I was able to do this in terminal as root.

How can I access the /home/steven/desktop directory on the root account?

Steven
Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #6 on: December 06, 2009, 02:28:21 am »

yes I tried that but no files or entries from the home or file system icons show up in file manager.
I also tried show hidden files and refreshing the folder, still does not show those entries.

This is a strange problem, had a similar thing in suse or red hat but I think I was able to do this in terminal as root.

How can I access the /home/steven/desktop directory on the root account?

Steven

The home, file system and trash icons are built-in to Xfce. You can turn them on or off in Xfce 4.6.1, but I don't think you can do so in the earlier version (which is the default in VL6.0 Standard).

You could enable the testing repo in slapt-get and upgrade to the later version of Xfce. It seems reasonably solid, though there are a few problems (like missing icons).

I don't really understand your question regarding /home/steven/desktop on the root account? You should be able ot access /home/steven/Desktop without problems from the root account, though you need to be careful about doing anything to files in that directory while logged in as root - if you change any of the permissions, you will end up with all sorts of strange problems.

paul.
Logged
haywire
Vectorian
****
Posts: 507


« Reply #7 on: December 06, 2009, 08:13:33 am »

Okay then how exactly do I enable the testing repo?

Then it would be slapt-get xfce from a root terminal?

If I can install the newer xfce, sounds like that will fix my problem...

Steven
Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #8 on: December 06, 2009, 09:44:28 am »

Okay then how exactly do I enable the testing repo?

The simplest method is via the menu - System > Gslapt > Edit > Preferences > Sources. Tick on the box for the testing repo. Then let Gslapt refresh the slapt-get data when it prompts you.

Quote
Then it would be slapt-get xfce from a root terminal?

There are a lot of dependencies, but slapt-get xfce4 should get it and the deps. The other option would be direct from Gslapt, though I'm always a bit wary of loading things like that while the desktop is active.

Safest would be to open a terminal, su to root, then enter 'init 3' to kill X and get to the console. Log in as root, then use slapt-get to install the latest Xfce.

Quote
If I can install the newer xfce, sounds like that will fix my problem...

Looks like it. You can selectively disable the Home, File System and Wastebasket icons, leaving the Removable Devices icon active (it will normally only appear when you mount a CD or USB drive of some sort).

Once the new Xfce is installed, right-click on the desktop, select Desktop Settings, then Icons.

paul.
« Last Edit: December 06, 2009, 09:50:49 am by toothandnail » Logged
haywire
Vectorian
****
Posts: 507


« Reply #9 on: December 07, 2009, 06:33:34 am »

Well I enabled testing repo, upgraded to xfce 4.6.1 and yes that sure did it.
Its a cool upgrade to be able to check those on or off the desktop, I'm glad I'm not the only one apparently who wanted to be able to do that.

Now my desktop has everything I want, but even more importantly perhaps, is that it has nothing I don't want.
I know it may be a little thing, but I hate things like that, Linux=freedom so you should be able to make those choices, and I'm glad you can.

Thanks for the help guy. I have one new panel to add for common surfing destinations, then my desktop will finally be all set and beautiful. I'll post some screen shots when I'm through, it looks fantastic so far, and I gotta say I've gotten very used to compiz and love it. I think once you get used to working in 3d, its tough to go back.

Loving the vectorbox...

Steven
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!