VectorLinux
July 31, 2014, 11:16:28 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Changing US keyboard mapping to UK  (Read 1232 times)
Colonel Panic
Vectorian
****
Posts: 526


« on: December 07, 2009, 07:30:02 am »

Hi, I saw someone mention this question in a different thread and I thought I'd chime in since I've had the same problem. How do you change a US keyboard layout to a UK one and then get it to stick? I  used to have this problem in Vector 5.1 but seem to remember I was able to solve it, now I've got the same one in 6.0 Standard (I haven't checked 5.9 SOHO for it yet).

Thanks in advance,

Colonel Panic .
Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #1 on: December 07, 2009, 12:07:20 pm »

Is this for X or for console use?

In X, the quickest way is to open a terminal, su to root, then edit /etc/X11/xorg.conf

Look for the keyboard section, and change it to the below:

Code:
Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "gb"    ## KEYBOARD_MAP!
Option  "XkbModel"  "pc104"    ## KEYBOARD_MODEL!
Option  "Xkbvariant"  ""    ## KEYBOARD_VARIANT!
EndSection

If it is set to US, you will find the 'Option "XkbLayout" will be us, not gb.

Whoops. Forgot. To change the layout for console, you need to edit (as root, of course), /etc/rc.d/rc.keymap. In this instance, the correct value for loadkeys is 'uk'

paul.
« Last Edit: December 07, 2009, 12:14:22 pm by toothandnail » Logged
Colonel Panic
Vectorian
****
Posts: 526


« Reply #2 on: December 07, 2009, 04:03:24 pm »

Thanks, I'll give it a try. Smiley
Logged
Colonel Panic
Vectorian
****
Posts: 526


« Reply #3 on: December 08, 2009, 05:15:59 am »

¬!"£$%^&*()_+{}[]:@~;'#|<>?\,./

I could leave it there, but I want to say thanks, that was brilliant! I keep a backup of all my config files and the new, amended xorg.conf file is now going to be replacing the old one.

Thanks once again.
« Last Edit: December 09, 2009, 08:18:35 am by Colonel Panic » Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #4 on: December 08, 2009, 05:23:27 am »

¬!"£$%^&*()_+{}[]:@~;'#|<>?\,./

 Grin  Wink

Quote
I copuld leave it there, but I want to say thanks, that was brilliant! I keep a backup of all my config files and the new, amended xorg.conf file is now going to be replacing the old one.

Thanks once again.

Glad it worked....

paul.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!