Please support VectorLinux!

Author Topic: Installing Conky on Vector 6.0 / 6.0 Light  (Read 754 times)

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Installing Conky on Vector 6.0 / 6.0 Light
« on: January 12, 2010, 05:53:05 am »
Has anyone managed to get Conky to install and run properly on Vector 6.0? When I tried this, I got the message "needs lua >= 5.1 to compile". I installed lua, and the installer couldn't find it for some reason.

Anyone else had this problem?

Thanks in advance,

CP .

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Installing Conky on Vector 6.0 / 6.0 Light
« Reply #1 on: January 12, 2010, 07:54:42 am »
Has anyone managed to get Conky to install and run properly on Vector 6.0? When I tried this, I got the message "needs lua >= 5.1 to compile". I installed lua, and the installer couldn't find it for some reason.

Anyone else had this problem?

Thanks in advance,

CP .

Strange. Is this a self-compiled version, or my build from the repo? If the latter, I had the same problem when building it, and ended up having to disable lua in the configure to get it to build.

If you haven't, try the repo version - it was built on 6.0 Standard, but I don't think there should be any deps that can't be used in Light.

:( I've made multiple attempts to build 1.7.2, but if I enable wlan support, it fails to build - for some reason, the Slackware-derived version of the wireless-tools does not suit it. I have also intended to see if  rebuild of the VL lua package would fix the problem, but I'm not expert enough in building libraries to be sure I can fix the problem. Lua support works with both Zenwalk and Salix, so it is something in the way lua is built in Vector that is causing that problem, though the wireless-tools problem seems to be common to all (or all that I've tried) Slackware-based distros.

paul.

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Re: Installing Conky on Vector 6.0 / 6.0 Light
« Reply #2 on: January 12, 2010, 08:24:43 am »
Thanks for replying Paul.

Strange. Is this a self-compiled version, or my build from the repo?

I've tried both, with the same result in each case.

If the latter, I had the same problem when building it, and ended up having to disable lua in the configure to get it to build.

If you haven't, try the repo version - it was built on 6.0 Standard, but I don't think there should be any deps that can't be used in Light.

Thanks for the advice. The trouble is, you've got no control with a repo version - it's just "installpkg *.tlz." So I think it's got to be the source version.

I've made multiple attempts to build 1.7.2, but if I enable wlan support, it fails to build - for some reason, the Slackware-derived version of the wireless-tools does not suit it. I have also intended to see if  rebuild of the VL lua package would fix the problem, but I'm not expert enough in building libraries to be sure I can fix the problem. Lua support works with both Zenwalk and Salix, so it is something in the way lua is built in Vector that is causing that problem, though the wireless-tools problem seems to be common to all (or all that I've tried) Slackware-based distros.

paul.


Fair enough. I'll try disabling lua in the configuration stage of the conky source package, and see if that helps.

Best,

CP .

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Installing Conky on Vector 6.0 / 6.0 Light
« Reply #3 on: January 12, 2010, 10:25:55 am »
Try using Gslapt to install the build from the repo - it should work, and should also pick up any deps that aren't already installed in Light.

:) Certainly works here - its one of the packages I build because I always use it myself.....

paul.

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Re: Installing Conky on Vector 6.0 / 6.0 Light
« Reply #4 on: January 12, 2010, 10:42:44 am »
Thanks, but I configured it with the --disable-lua option before I saw your last post and it works (though I don't know if any features are missing). I'll try Gslapt soon for something though.