VectorLinux
October 24, 2014, 03:53:21 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: updating pango to update gtk+2 VL5.9  (Read 952 times)
bad_gui
Member
*
Posts: 61


« on: December 28, 2009, 08:28:42 pm »

I'm in a dependency trap with VL5.9

I want to upgrade gtkpod, but it requires >= gtk+2.12 which requires pango >=1.17.3

The odd thing is that if I try to uninstall pango with gslapt it will take many other apps
with it. I don;t want to break my system to update one package.  I also saw a post on the
web that two parallel pango versions is not a good idea.

I've seen a workaround where pango and gtk+2 can be temporarily installed to compile
gtkpod, but the original versions of these are still kept in the system for everything else.
I can't remember the details and don't know how to google for this.

I looked at the ./configure -h listing for gtk+2, but I don't see how to redirect it to the
newer temp install rather than the system version of pango.

Any suggestions?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #1 on: December 29, 2009, 06:10:06 am »

You still need to install to the correct locations so that your gtkpod configure picks up the correct binaries.
With that said, you can removepkg the old pango, build the new pango, builg your new gtk (good luck), build gtkpod and then removepkg the new pango, and installpkg the old pango.... whewh!

No... seriously, trust me,.... upgrading gtk on the 5.9 base is not easy.
It's going to want new glib, new gcc, all kinds of things....
Logged

The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1551


I like the bass to go BOOM!


WWW
« Reply #2 on: January 02, 2010, 04:31:29 am »

Quote
No... seriously, trust me,.... upgrading gtk on the 5.9 base is not easy.
It's going to want new glib, new gcc, all kinds of things....

You do not want to do this. It's probably going to leave you with a broken system.
Logged

Most music on my soundcloud page was arranged in programs running on VL.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!