VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Running e2fsck on a partition in use  (Read 1155 times)

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Running e2fsck on a partition in use
« on: January 11, 2010, 04:32:41 pm »

Hi again. I'm in Vector 6.0 Light at the moment and have had a couple of file system errors to sort out. When I try to unmount the root partition to apply e2fsck though, I get the message "umount :  /: device is busy", which means I can't take things any further.

I've always solved this in the past by keeping two different Vector distros on the drive at once so that I can fsck each one's file system from the other, but this takes up a lot of space. Is there a better way?

Thanks in advance,

Colonel Panic .
Logged

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: Running e2fsck on a partition in use
« Reply #1 on: January 11, 2010, 04:49:59 pm »

You could boot up the computer with a live cd which by default doesn't mount your root partition. You could then run fsck from there.
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Re: Running e2fsck on a partition in use
« Reply #2 on: January 12, 2010, 02:00:21 am »

Thanks for replying.

Tried that, but both slax and damn small linux do mount partitions on your hard drive by default. The one which doesn't (puppy) has a slower implementation of fsck than Vector does, so it takes an age to sort it out.

I think your advice is probably along the right lines though.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4133
Re: Running e2fsck on a partition in use
« Reply #3 on: January 12, 2010, 03:20:43 am »

On the Light Live boot menu you can press tab, then append "nohd" to the boot options, or you can unmount manually after start.

Or try this: http://www.cyberciti.biz/faq/linux-force-fsck-on-the-next-reboot-or-boot-sequence/
Logged

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Re: Running e2fsck on a partition in use
« Reply #4 on: January 12, 2010, 05:42:04 am »

Thanks, I'll try at least one of those; I've got the Vector 5.9 Live CD around somewhere.

Cheers,

CP .
Logged

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Re: Running e2fsck on a partition in use
« Reply #5 on: January 12, 2010, 10:45:02 am »

A quick update -Vector Live works (booting up into the command line and then tabbing and adding the "nohd" option). I may try the other option soon.
Logged