VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2] 3

Author Topic: HP Mini 2133 - 'choppy' video and sound.....  (Read 9306 times)

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4132
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #15 on: March 11, 2010, 05:36:36 am »

Open a terminal and run htop, then watch it as you play the video. I would suspect that CPU is maxing out before memory. If that is the case, adding RAM would not help much.
Logged

roarde

  • Vectorian
  • ****
  • Posts: 612
  • move the needle
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #16 on: March 11, 2010, 06:08:31 pm »

These settings in the Driver section of xorg.conf sped up my rendering. I'm using the openchrome that came with VL 6.0 Light.

Code: [Select]
Driver      "openchrome"
Option      "VBEModes"                  "1"
Option      "PanelSize"                 "1440x900"

VBEModes allows setting mode by vbe call, I believe. Without it, some form or other of direct rendering is not possible. PanelSize both sets the size and tells X you're definitely using the attached panel. Set it for your display size, of course.

Also helpful in the device section:

Code: [Select]
Option      "SWCursor"                  "1"
# Keeps cursor from disappearing on many websites, including google maps.

Option      "XAANoOffscreenPixmaps"     "1"
# Solves scrambled video problem many drivers are having.

Hope it's not a waste of your time. Luck.
Logged
Robert
VL 7.1 Light

sledgehammer

  • Vectorian
  • ****
  • Posts: 1472
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #17 on: March 11, 2010, 09:47:44 pm »

Never_stop_learning,

I suggest that you drop the mini onto a hard, preferably concrete, surface, soak it overnight in salty water, and then run over it three times in quick succession with a Ford 350 pickup.  Put the remains in a dryer for not more than 2 hours. Do all this carefully, of course.  You should probably keep a fifth of Jameson ready in case it doesn't work.
Logged
VL7.0 xfce4 Samsung RF511

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1329
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #18 on: March 11, 2010, 10:08:47 pm »

Always preferred C4 myself.  ;D
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

sledgehammer

  • Vectorian
  • ****
  • Posts: 1472
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #19 on: March 12, 2010, 12:12:25 am »

retired1AF,

Your suggestion is certainly more direct.  But knowing never_stop_learnings fondness for his HP Mini 2133, I suspect that, with C4, we would be prying it from his cold, dead hands.

 
Logged
VL7.0 xfce4 Samsung RF511

Pita

  • Vectorian
  • ****
  • Posts: 1338
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #20 on: March 12, 2010, 03:59:01 am »

Never_stop_learning,

I suggest that you drop the mini onto a hard, preferably concrete, surface, soak it overnight in salty water, and then run over it three times in quick succession with a Ford 350 pickup.  Put the remains in a dryer for not more than 2 hours. Do all this carefully, of course.  You should probably keep a fifth of Jameson ready in case it doesn't work.

I showed this to my good woman the owner of a HP 2133 and her question is,
where can she find a  Ford 350 pickup? :D
Logged

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #21 on: March 12, 2010, 06:19:57 am »

These settings in the Driver section of xorg.conf sped up my rendering. I'm using the openchrome that came with VL 6.0 Light.

Code: [Select]
Driver      "openchrome"
Option      "VBEModes"                  "1"
Option      "PanelSize"                 "1440x900"

VBEModes allows setting mode by vbe call, I believe. Without it, some form or other of direct rendering is not possible. PanelSize both sets the size and tells X you're definitely using the attached panel. Set it for your display size, of course.

Also helpful in the device section:

Code: [Select]
Option      "SWCursor"                  "1"
# Keeps cursor from disappearing on many websites, including google maps.

Option      "XAANoOffscreenPixmaps"     "1"
# Solves scrambled video problem many drivers are having.

Hope it's not a waste of your time. Luck.


Thank you, sixforty.....I tried your suggestions but there was no improvement.
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1329
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #22 on: March 12, 2010, 06:23:48 am »

As nightflier suggested, you should open htop and watch the CPU load while playing a video. If your CPU shoots to 100%, there's not much else you're going to be able to do about this issue.
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #23 on: March 12, 2010, 06:30:23 am »

Open a terminal and run htop, then watch it as you play the video. I would suspect that CPU is maxing out before memory. If that is the case, adding RAM would not help much.

You were absolutely correct.....htop shows the cpu pegging at 100% and staying there when I try to play a video from YouTube or one of the news sites.....

My other HP Mini (Intel Atom processor) handles Internet video with ease. This appears to be a limitation of the Via C7 processor as implemented in the 2133.....

Thank you for all for your suggestions and help.....If anyone has any other thoughts and/or suggestions (though no C4, Ford F350 or saltwater will be used on this cool little netbook ;)  ) I am happy to try them.
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4132
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #24 on: March 12, 2010, 07:07:06 am »

One thought: make sure you have the latest Flash player. They keep tweaking it and performance under Linux is improving.
Logged

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #25 on: March 12, 2010, 07:20:25 am »

One thought: make sure you have the latest Flash player. They keep tweaking it and performance under Linux is improving.

Thank you....I'll do so and report back.
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #26 on: March 12, 2010, 07:34:38 am »

This site is helpful for displaying the currently utilized flash player version in your browser:
http://www.mediacollege.com/adobe/flash/player/version/show.html

If these attempts fail to solve the cpu usage problem then it may be worth the effort to downgrade flash to a 9.x.xx version to see if the issues resolve.

Edit:
After reading an article on TheReg regarding flash performance and cpu usage, it states that when it comes to efficient video playback the single most important factor on cpu load is the ability for flash to access hardware acceleration.  It goes on to state that hardware acceleration has been added to Flash 10.1 (still in beta3 stage).  With all of that in mind, I would recommend installing the latest Flash 10.1 Beta3 considering it supposedly has hardware acceleration implemented AND that the acceleration should provide the most efficient video playback.  Sounds like this is right in line with what you need.  Here's the direct link to Flash 10.1 Beta3:
http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_1_p3_linux_022310.tar.gz
« Last Edit: March 12, 2010, 09:00:06 am by newt »
Logged

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #27 on: March 12, 2010, 11:44:55 am »

Thank you, newt.

Downloaded, extracted and moved the libflashplayer.so to /usr/lib/mozilla/plugins. Verified that I am running version 10.1.51.95.

Video is much better (not great, but acceptable).....but no sound. Sound works fine on Shoutcast via XMMS so I know my sound is working.......

So close.

Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #28 on: March 12, 2010, 12:18:41 pm »

It's a long shot: Do you have the snd-pcm-oss module loaded? You can check using 'lsmod'. If not, try loading it to see if it helps (modprobe snd-pcm-oss).
Logged

never_stop_learning

  • Vectorite
  • ***
  • Posts: 263
    • CigarWeekly
Re: HP Mini 2133 - 'choppy' video and sound.....
« Reply #29 on: March 12, 2010, 01:58:11 pm »

It's a long shot: Do you have the snd-pcm-oss module loaded? You can check using 'lsmod'. If not, try loading it to see if it helps (modprobe snd-pcm-oss).

lsmod shows snd_pcm  75268  3 snd_pcm_oss,snd_hda_intel
Logged
Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std
Pages: 1 [2] 3