VectorLinux
October 30, 2014, 08:23:56 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HPLIP: ppd file missing in Vector?  (Read 2928 times)
ppetitjean
Member
*
Posts: 5


« on: October 26, 2009, 01:08:36 am »

Hello from France,
The file:hp-deskjet_f2100_series-hpijs.ppd.gz present in the original source (works fine with my printer) seems to miss in the Vector package.
Any hints?
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: October 26, 2009, 06:15:19 am »

I think you may be using the newest hplip.  It does not seem to be complete to me as it covers far less printers than the previous version. 
Use gslapt to downgrade back to hplip version 2.8.12

You should then be able to find the ppd you want here...
/usr/share/cups/model/HP/hp-deskjet_f2100_series-hpijs.ppd
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
ppetitjean
Member
*
Posts: 5


« Reply #2 on: October 26, 2009, 07:39:20 am »

-hplip version 2.8.12 did not worked for me at all: socket communication error

-hplip version 3.9.2 from the repos worked fine for the scanner and  for most of the hp utilities ("Gestionnaire de périphériques")

The printer works now with a dirty fix: the hp-deskjet_f2100_series-hpijs.ppd taken from the hplip-3.9.8 tarball source in  usr/share/cups/model/HP/ (and a foomatic-rip-hplip in  /usr/lib/cups/filter/

Everything works but....
Logged
ppetitjean
Member
*
Posts: 5


« Reply #3 on: January 06, 2010, 08:09:53 am »

I think you may be using the newest hplip.  It does not seem to be complete to me as it covers far less printers than the previous version. 
Use gslapt to downgrade back to hplip version 2.8.12
You should then be able to find the ppd you want here...
/usr/share/cups/model/HP/hp-deskjet_f2100_series-hpijs.ppd

I had some times to try that again and it works...
I feel sorry

Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #4 on: January 06, 2010, 03:21:34 pm »

No worries.  Just glad you got it going and stuck with Vector.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!