Please support VectorLinux!

Author Topic: VL5.9.1 SOHO Ndiswrapper dont works  (Read 1737 times)

Cepo

  • Member
  • *
  • Posts: 11
VL5.9.1 SOHO Ndiswrapper dont works
« on: January 13, 2010, 01:27:31 pm »
Hi. Sorry for a making new thread. I just readed many information on forum but I didn t find information how to fix my problem.

I have VL 5.9.1 SOHO with kernel 2.6.25.7 with Intel wireless 3945 abg wireless card. I readed this main information
http://forum.vectorlinux.com/index.php?topic=1282.0

Method 1> Dotn works, because vasm in safe mode dont detect my card. I freeze on this step and I cant go next.

Method2> Everything works fine in all steps to configure ndiswrapper. I have latest version of ndiswrapper and latest
version on Intel wirelles 3945 ABG driver. I installed ndiswrapper - but last step

ifconfig wlan0 up            gave me       SIOCSIFFLAGS: No such file or directory error.

Ethernet is working normal with cable. Any ideas? I will be glad for any info.

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: VL5.9.1 SOHO Ndiswrapper dont works
« Reply #1 on: January 13, 2010, 01:46:23 pm »
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

Cepo

  • Member
  • *
  • Posts: 11
Re: VL5.9.1 SOHO Ndiswrapper dont works
« Reply #2 on: January 13, 2010, 02:12:07 pm »
Thanks for link. I try it. but I got this error on this step

Code:

root:# modprobe -n -v --first-time ndiswrapper
insmod /lib/modules/2.6.27.29/misc/ndiswrapper.ko

I got

cepolinux:/~/ndis
root:# modprobe -n -v --first-time ndiswrapper
FATAL: Module ndiswrapper already in kernel.
cepolinux:/~/ndis
root:# insmod /lib/modules/2.6.27.29/misc/ndiswrapper.ko
insmod: can't read '/lib/modules/2.6.27.29/misc/ndiswrapper.ko': No such file or directory

 :'(

And root:# dmesg  - there are no info about ndiswrapper in this code  :-[
« Last Edit: January 13, 2010, 02:14:56 pm by Cepo »

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: VL5.9.1 SOHO Ndiswrapper dont works
« Reply #3 on: January 13, 2010, 03:52:04 pm »
Thanks for link. I try it. but I got this error on this step

Did you continue and try the next step? The steps that you got errors on were to insert the ndiswrapper module which (according to the errors) appears to already be inserted so I *think* everything is fine so far.
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

Cepo

  • Member
  • *
  • Posts: 11
Re: VL5.9.1 SOHO Ndiswrapper dont works
« Reply #4 on: January 14, 2010, 09:01:28 am »
Hi

I dont have luck to fix that. I reinstalled system and tried at once. I download ndiswrapper 1.55 - latest version. Intel driver was downloaded from
Intel web site. I go step by step in manual what you posted to me and I got error in dmesg.

root:# dmesg     

iwl3945: iwlwifi-3945-1.ucode firmware file req failed: Reason -2
iwl3945: Could not read microcode: -2
ACPI: PCI interrupt for device 0000:10:00.0 disabled
eth0: Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
eth0: 10/100 speed: disabling TSO
ndiswrapper version 1.55 loaded (smp=yes, preempt=yes)
usbcore: registered new interface driver ndiswrapper

cepolinux:/~/Ndis
root:# iwlist wlan0 scan
wlan0     Interface doesn't support scanning : Network is down

I will try to use other version of Intel driver if it help. And, I can istall VL6 version but I am not sure if the new kernel will be works with ati catalyst 8-5 for my
old Ati radeon X1350  :(

Cepo

  • Member
  • *
  • Posts: 11
Re: VL5.9.1 SOHO Ndiswrapper dont works
« Reply #5 on: January 14, 2010, 09:58:31 am »
NOW SOLVED  ;D :D ;)

The problem was missing firmware iwlwifi3945-1.uncode in /etc/firmware. I had iwlwifi3945-2.uncode yesterday after reinstalling system.

I found link to 3945-1 uncode and copy this to firmware. And now, every is working perfect.  ;)

I very thank you for your link and help  :)