VectorLinux
August 22, 2014, 11:15:17 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Little help... if anyone can would be desirable.  (Read 636 times)
alex
Member
*
Posts: 2


« on: January 16, 2010, 10:08:49 am »

Good morning everyone,
 today I migrated from Win7 to Vector Linux6.0 (leaving these two on one Hdd), but on the other side I have completly no knowledge literally about Linux systems apart from instaling them and partitioning Hdd (two days ago installed Knoppix but was much worse than LV 6.0 - the last see my ethernet card at least Smiley so I removed Knoppix and have now LV).
 Just was able to an hour ago turn on my sound card and at least can watch a movie or listen music.
 But cannot figure out how to run an internet connection and start print server (my printer is Epson stylus sx100, LV do not see this printer so probably have to search for driver for this printer in internet or am I wrong?).
 My modem is connected  through Usb and printer too. But the most important is modem - when I am under Win7, I am using a password and username from my ISP to get connection (it's ADSL modem cable connection 1 Mb speed) and in Vector Linux don't see any of such programs or alternatives. I have configured modem with DNS and so on (I mean other functions like gateway and broadcast), but still cannot connect and don't know why. Shall I compile the kernel or what? Have ethernet card Realtek.
 Till now have no idea how to run internet under LC. Can anyone help, please?
 Greeting from south of Poland,
where is now much snow outside Smiley
Logged
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #1 on: January 16, 2010, 11:42:10 am »

1. What model/brand is your modem? Pls post the output of your lspci, lsusb and lsmod (just run the 3 command in a console/terminal as root).

2. Did you enable the CUPS services for printing? You can enable/disable it using VASM. Check the service section, I believe.

BTW, welcome to VL. Smiley
Logged
alex
Member
*
Posts: 2


« Reply #2 on: January 16, 2010, 03:51:10 pm »

Thnx for answer,
 I did the three commands like You said, so here is outcome:
root:# lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 10)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400 GS (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)


root:# lsusb
Bus 001 Device 003: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 046d:c312 Logitech, Inc.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 1110:9042 Analog Devices Canada, Ltd (Allied Telesyn)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


root:# lsmod
Module                  Size  Used by
ipt_MASQUERADE          3456  1
xt_tcpudp               3712  58
xt_state                2816  2
iptable_mangle          3584  0
nf_nat_irc              2944  0
nf_conntrack_irc        6052  1 nf_nat_irc
nf_nat_ftp              3584  0
nf_conntrack_ftp        8100  1 nf_nat_ftp
iptable_nat             6024  1
nf_nat                 16792  4 ipt_MASQUERADE,nf_nat_irc,nf_nat_ftp,iptable_nat
nf_conntrack_ipv4      14220  5 iptable_nat,nf_nat
nf_conntrack           55776  9 ipt_MASQUERADE,xt_state,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,iptable_nat,nf_nat,nf_conntrack_ipv4
iptable_filter          3456  1
ip_tables              11536  3 iptable_mangle,iptable_nat,iptable_filter
x_tables               13572  5 ipt_MASQUERADE,xt_tcpudp,xt_state,iptable_nat,ip_tables
lp                     10372  0
snd_seq_dummy           3716  0
snd_seq_oss            31872  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                48368  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7436  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37408  0
snd_mixer_oss          15104  1 snd_pcm_oss
speedstep_lib           4740  0
acpi_cpufreq            7948  0
freq_table              4352  1 acpi_cpufreq
fuse                   53788  10
irtty_sir               5888  0
snd_hda_codec_realtek   190340  1
sir_dev                11780  1 irtty_sir
snd_hda_intel          25544  2
rtc_cmos               10144  0
irda                  108984  1 sir_dev
rtc_core               15132  1 rtc_cmos
snd_hda_codec          60928  2 snd_hda_codec_realtek,snd_hda_intel
crc_ccitt               2688  1 irda
rtc_lib                 3328  1 rtc_core
parport_pc             35908  1
serio_raw               6020  0
iTCO_wdt               10916  0
i2c_i801                9616  0
snd_hwdep               7812  1 snd_hda_codec
snd_pcm                67972  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
parport                31724  2 lp,parport_pc
snd_timer              19976  2 snd_seq,snd_pcm
snd                    51492  16 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
ueagle_atm             30264  0
nvidia               7218264  26
soundcore               7008  1 snd
usbatm                 16000  1 ueagle_atm
snd_page_alloc          8840  2 snd_hda_intel,snd_pcm
r8169                  27780  0
atm                    36788  1 usbatm
i2c_core               21268  2 i2c_i801,nvidia
mii                     5376  1 r8169
evdev                  10144  4

By the way, I found a driver for my modem, it is Sagem Fast 800 E4 on producer site, it is Fast8x0_3-0-6.tgz but when I am tring to install it, getting message like below:  Sad

Fast8x0_3-0-6.tgz
WARNING: Non-standard package name

.-----.-----------------------------------------------------------------------.
| 1/1 | Installing Fast8x0_3-0-6.tgz                                          |
'-----'-----------------------------------------------------------------------'
WARNING: Package has no description.

If it's going about printer, used 127.0.0.1/613 or smth like this but driver to my printer is not listed among so I tried another drivers which I found similiar and the conclusion is that the printer is living (I mean start doing smth inside with test page, can hear sounds) but do not print anything. But I do not bother about it, coz most important issue now is how to run internet.
Thnx for reply,
Aleksander.
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #3 on: January 17, 2010, 11:56:14 am »

Check the www.linuxprinting.org database for information about what printer driver to use.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!