VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Intel 810 graphics not recognised- where to report bug?  (Read 1316 times)

itlarson

  • Member
  • *
  • Posts: 6
Intel 810 graphics not recognised- where to report bug?
« on: January 17, 2010, 03:55:02 pm »

I am trying out vector linux on an old Dell dimension 2100.  Vectorlinux seems like a good choice for this old hardware, since it is lightweight, and uses xfce.  The problem is vector doesn't properly identify the on-board intel 810e graphics.  As a result the graphical installer compresses everything into a bar along the top of the screen.  I installed using the text based installer, but when I booted, I got alternating bars and blocks of color.  Fortunatly I had a similar problem with a Suse install on this machine, and had an idea what to do.  Suse would only run at 480x620 untill I edited xorg, and I was able to get vector working this way too.  Here are the changes I made:

Driver "i810"
BoardName "Intel 810"
Option "noaccel"

Now vector seems to be working well, and my question is where to report the driver problem.  I know this hardware can be identified properly, since i have had it be identified properly in previous (Ubuntu?) installs.  Hopefully the vector devs will be interested in making this true for vector too.
Logged

nitehawk

  • Vectorite
  • ***
  • Posts: 155
  • Just me.
Re: Intel 810 graphics not recognised- where to report bug?
« Reply #1 on: January 17, 2010, 06:31:07 pm »

Oh yes,....I have a couple of Dell computers with that i810 -- and it's a real pain, for sure!  Not many distros will work with the Intel 810.  I had to just give up, and put in another graphic card in each one.  Got an older Nvidia in one,...and in my old PIII I just slapped in an old 2D accelerator I had.  Anything will work better than that i810.    Before I changed the video cards ... I had tried (and failed with) OpenSuse, SimplyMepis, Wolvix,  etc. etc. etc.    Now the Dell with the Nvidia card works beautifully with Vector. 
Logged

itlarson

  • Member
  • *
  • Posts: 6
Re: Intel 810 graphics not recognised- where to report bug?
« Reply #2 on: January 18, 2010, 07:40:07 pm »

I think this is a matter of hardware detection, not of Linux's ability to support the hardware, since my graphics is working fine now.  Although it is hopeless at 3d, the 810 is fine for desktop stuff, and I've run it at 1280x1024 in the past with no problems.  Undoubtedly the nvidia is better, and better supported in Linux,  But I am unwilling to put money into a ten year old computer.  I still would like to know where to report the problem, though, since it might be a simple fix.   
Logged