VectorLinux
November 23, 2014, 06:17:58 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: sharing files samba fouled {solved}  (Read 2103 times)
franklin1k
Member
*
Posts: 55


« on: January 24, 2010, 05:37:30 pm »

Okay,
I've done this before.  Why it does not work this time, VL Gurus only know.

There are three computers. 
VL 6.0 - new
VL 6.0 KDE classic - newer
VL 5.1  -  running since 5.1 came out

The VL 5.1 used Konqueror to transfer files to an XP box that is no longer.  Not a problem for years.  I now want these three boxes to share files.

vlsmbmnt-files.tlz from nightflier used on all
VL 5.1 and VL6.0 have smb demon started in services

this apears for both:
frank:$ smbtree
Password:
MYGROUP
        \\VECTOR                        Samba Server
                \\VECTOR\vl60
                \\VECTOR\IPC$                   IPC Service (Samba Server)
        \\THUMP                         Samba Server
                \\THUMP\IPC$            IPC Service (Samba Server)
                \\THUMP\TRANSTRUCK
                \\THUMP\THUMPTRUCK
                \\THUMP\NEW FOLDER
-------------------------------------------

On VL 6.0 KDE classic does not have the smb deamon in services no matter how often I run VASMCC.
smbtree never shows anything

How do I start sorting this out?  This is going on a week with the same results.
Brother, could you spare the time?
« Last Edit: January 26, 2010, 12:47:45 am by franklin1k » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4029



« Reply #1 on: January 24, 2010, 06:50:03 pm »

The vlsmbmnt fix should not be necessary in KDE-Classic. Also, you don't need the smb daemon running to access files on other computers.

A good place to start is to get the IP address of the computer with the shared files.
Then, in the Konqueror address bar enter:
smb://ip_address_of_other_computer

If successful, we can work forwards from there.

Logged
franklin1k
Member
*
Posts: 55


« Reply #2 on: January 24, 2010, 09:22:14 pm »

Alrighty then,
running konqueror has mixed results
The VL 5.1 box could be seen from the KDE classic box.  A file was transfered.

Niether 5.1 box and the classic could see the VL 6.0 standard.
    the classic denied access
    the 5.1 asked for password
         no password = zip
       user password = zip
       root password = you quessed it

Niether 5.1 box or the VL 6.0 standard could see the KDE Classic

I thought to use konqueror for file transfer the smb deamon had to be running.  smb://other_comp_ip_address was kinda a clue.  What twisted fact wasted hours of time?

Thanks for helping again. 
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4029



« Reply #3 on: January 25, 2010, 03:25:15 am »

Now, to offer shares from the KDE-Classic box:

As root, edit the file /etc/samba/smb.conf
Find this section:

# This one is useful for people to share files
;[tmp]
;   comment = Temporary file space
;   path = /tmp
;   read only = no
;   public = yes

remove all the semicolons, save the file, then issue command:
Code:
/etc/rc.d/init.d/samba start

Try to connect from the other boxes again.
Logged
franklin1k
Member
*
Posts: 55


« Reply #4 on: January 25, 2010, 08:07:52 am »

The changes were made

Upon command;

vector:/~
frank:$ /etc/rc.d/init.d/samba start
-bash: /etc/rc.d/init.d/samba: No such file or directory
vector:/~
frank:$ cd /etc/rc.d/init.d/
vector://etc/rc.d/init.d
frank:$ ls
bluetooth*  firewall*  gslaptd*     portmap*  wicd*
cron*       fuse*      inetd*       sample/   wifi-radar*
cups*       gpm*       lm_sensors*  sshd*
vector://etc/rc.d/init.d
frank:$
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4029



« Reply #5 on: January 25, 2010, 02:53:16 pm »

Do you have a file /etc/rc.d/rc.samba?
If so, try this:
Code:
cp /etc/rc.d/rc.samba /etc/rc.d/init.d/samba
chmod +x /etc/rc.d/init.d/samba
/etc/rc.d/init.d/samba start

If you don't have it, try enabling the testing repository in gslapt and upgrade to latest version of samba.
Logged
franklin1k
Member
*
Posts: 55


« Reply #6 on: January 25, 2010, 05:20:18 pm »

Yes, the file was there.
I ran the commands
samba did start
same results

the 5.1 and classic can share files.  Only share file on 5.1 can be seen.

The VL6.0 still asks for premission.  No combo of user/password grants access

Neither 5.1 or VL6.0 can see share file on classic
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4029



« Reply #7 on: January 25, 2010, 05:42:36 pm »

Try user "guest" and blank password.

If that does not work, on your KDE-Classic box:
smbpasswd -a (username)
Use an existing account and password.
Then try connecting using those credentials.
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #8 on: January 25, 2010, 06:13:05 pm »

Franklin1k,

If you want Linux-to_Linux networking (no Windows in the mix), consider using nfs for your network. It's easy to set up and once you have your network working, your shares are as easy to manage as if they were on your own computer. You don't have to mess with logins and passwords or special paths in a file manager.

I have a how-to here:
 http://forum.vectorlinux.com/index.php?topic=669.msg3845#msg3845

It looks a bit daunting at first glance, but it's not. Copy and paste my examples into the relevant files on each system and adapt them for your situation. Once you edit the files in /etc, you can just copy them to other computers or to new installations of VectorLinux.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
franklin1k
Member
*
Posts: 55


« Reply #9 on: January 26, 2010, 12:47:14 am »

It works.
The solution was to rewrite the config file on each machine

[global]
   workgroup = MYGROUP
   security = SHARE

[tmp]
   comment = Temporary file space
   path = /tmp
   read only = No
   guest ok = Yes

I then went into the file permissions and file sharing on each box.

GrannyGeek,
I'll give it a try.  I always used a XP box inbetween my linux machines, so samba worked well.  This is my first time have the VL boxes sharing on their own.  Now that this greater mystery fell another need take its place.

thanks all


Logged
bigpaws
Vectorian
****
Posts: 1857


« Reply #10 on: January 26, 2010, 04:28:03 pm »

Try in konqueror fish://ip of the linux machine

Bigpaws
« Last Edit: January 27, 2010, 08:27:44 am by bigpaws » Logged
franklin1k
Member
*
Posts: 55


« Reply #11 on: January 26, 2010, 08:52:19 pm »

Seems like konqueror works as the swiss army knife over a network.  While looking up fish a dozen other commands were found.  Nice to have options.

thanks, I'll try it
« Last Edit: January 27, 2010, 12:29:53 am by franklin1k » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!