VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: ssh  (Read 1124 times)

flip city

  • Packager
  • Vectorite
  • ****
  • Posts: 340
  • Way Out In HyperSpace
ssh
« on: January 27, 2010, 11:11:42 am »

Hello classy Vectorians,

 I'm experimenting with ssh, and have a couple of questions concerning configuring ssh with firewalls and my ethernet router. First off, what settings need to be adjusted in Firestarter to allow for the ssh connection; AND what if anything needs to be adjusted in the settings of my ethernet router, to allow for the same ?? Also, when everything is set and good to go, how do I verify that ssh is performing as designed ?

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: ssh
« Reply #1 on: January 27, 2010, 11:44:32 am »

Some settings depend on whether you are using ssh to connect to a computer outside of your network or not. If you are just connecting within your network, you probably won't have to change the router settings. If you are connecting outside of your network, then (if the other computer you are trying to connect to is behind a router) you will have to enable port forwarding on the remote router. ssh uses port 22. I don't really know much about Firestarter but I would think that you don't have to do anything with it. If you successfully connect to another computer, you will see a line stating the last login time of that computer and a line saying which user you are working as and maybe some other stuff and then the blinking prompt.
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: ssh
« Reply #2 on: January 27, 2010, 11:59:41 am »

In the past, using VL 5.8 (I think), I remember having to open port 22 on the VL firewall (I guess that would be the Firestarted you're referring to).  But, as Daniel suggests, attempt your ssh connections without any firewall or router modifications first.  If you are unsuccessful at connecting to a local network system then open port 22 on the system that you're trying to connect to.  Hope this helps.
Logged