VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: lyx 1.6.5  (Read 2060 times)

sledgehammer

  • Vectorian
  • ****
  • Posts: 1472
lyx 1.6.5
« on: February 06, 2010, 01:18:53 pm »

hata_ph, I tried loading it from source and it didn't work.  Any chance you might put it on the repositories?

John
Logged
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: lyx 1.6.5
« Reply #1 on: February 06, 2010, 05:21:52 pm »

sure...will let u know ASAP.....

what kind of problem did u encounter?
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1472
Re: lyx 1.6.5
« Reply #2 on: February 06, 2010, 07:57:32 pm »

It configured fine, but erred-out on make....lots of errors at the end of the make file, such as:

Quote
SignalSlotPrivate_moc.cpp:159: error: no 'bool lyx::SlotImpl::qt_property(int, int, QVariant*)' member function declared in class 'lyx::SlotImpl'
SignalSlotPrivate_moc.cpp: In member function 'bool lyx::SlotImpl::qt_property(int, int, QVariant*)':
SignalSlotPrivate_moc.cpp:161: error: 'qt_property' is not a member of 'QObject'
SignalSlotPrivate_moc.cpp: At global scope:
SignalSlotPrivate_moc.cpp:164: error: no 'bool lyx::SlotImpl::qt_static_property(QObject*, int, int, QVariant*)' member function declared in class 'lyx::SlotImpl'
make[5]: *** [SignalSlotPrivate.lo] Error 1
make[5]: Leaving directory `/home/johwhi/src/lyx/lyx-1.6.5/lyx-1.6.5/src/support'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/johwhi/src/lyx/lyx-1.6.5/lyx-1.6.5/src/support'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/johwhi/src/lyx/lyx-1.6.5/lyx-1.6.5/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/johwhi/src/lyx/lyx-1.6.5/lyx-1.6.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/johwhi/src/lyx/lyx-1.6.5/lyx-1.6.5'
make: *** [all] Error 2
Logged
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: lyx 1.6.5
« Reply #3 on: February 06, 2010, 11:36:34 pm »

Hey, I did package lyx-1.6.5 for VL5.9 and VL6 but I just notice I only announce it for VL5.9. Where is VL6? Hahahahhaa....I believe I have uploaded it to the VL repo. I will double check it again and let u all know. :P

http://forum.vectorlinux.com/index.php?topic=11004.0

From your error, what version of QT4 u are using now?
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1472
Re: lyx 1.6.5
« Reply #4 on: February 07, 2010, 12:24:05 pm »

qt4 (4.5.0_r948357-i586-1vl60)

john
Logged
VL7.0 xfce4 Samsung RF511

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: lyx 1.6.5
« Reply #5 on: February 07, 2010, 03:08:01 pm »

Hey, I did package lyx-1.6.5 for VL5.9 and VL6 but I just notice I only announce it for VL5.9. Where is VL6? Hahahahhaa....I believe I have uploaded it to the VL repo. I will double check it again and let u all know. :P

http://forum.vectorlinux.com/index.php?topic=11004.0

From your error, what version of QT4 u are using now?

I must have missed that one. Its in testing now. See here:

http://forum.vectorlinux.com/index.php?topic=11336.0

Paul.

Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: lyx 1.6.5
« Reply #6 on: February 07, 2010, 04:49:20 pm »

qt4 (4.5.0_r948357-i586-1vl60)

john

Try downgrade it to qt-4.4.1-i586-1vl60

Quote
aaa_base >= 12.1.0-noarch-2 | glibc-solibs >= 2.7-i486-10
aiksaurus >= 1.2.1-i586-1vl60
aspell >= 0.60.6-i586-1vl60
cxxlibs >= 6.0.9-i486-1 | gcc-g++ >= 4.2.3-i486-1
expat >= 2.0.1-i486-1
fontconfig >= 2.4.2-i486-2
freetype >= 2.3.9-i586-1vl60
gcc >= 4.2.3-i486-1
glib2 >= 2.16.3-i586-1gsb
libICE >= 1.0.4-i486-1
libSM >= 1.0.3-i486-1
libX11 >= 1.1.4-i486-1
libXau >= 1.0.3-i486-1
libXdmcp >= 1.0.2-i486-1
libXext >= 1.0.4-i486-1
libXi >= 1.1.3-i486-1
libXrandr >= 1.2.2-i486-1
libXrender >= 0.9.4-i486-1
libpng >= 1.2.35-i586-1vl60
libxcb >= 1.0-i486-2
qt4 >= 4.4.1-i586-1vl60
zlib >= 1.2.3-i486-2
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: lyx 1.6.5
« Reply #7 on: February 07, 2010, 04:56:45 pm »

Hey, I did package lyx-1.6.5 for VL5.9 and VL6 but I just notice I only announce it for VL5.9. Where is VL6? Hahahahhaa....I believe I have uploaded it to the VL repo. I will double check it again and let u all know. :P

http://forum.vectorlinux.com/index.php?topic=11004.0

From your error, what version of QT4 u are using now?

I must have missed that one. Its in testing now. See here:

http://forum.vectorlinux.com/index.php?topic=11336.0

Paul.



BTW, did I annouce I have upload the package for VL6? It seem like I cannot find it. If I forgot to annouce it then is my fault. Sorry about that. :P
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1472
Re: lyx 1.6.5
« Reply #8 on: February 07, 2010, 08:56:43 pm »

Thanks.  1.6.5 works fine.  Perhaps it was there (VL6 testing repository) all along and I just did not see it as it is listed above 1.6.4.

BTW, I did not have to downgrade qt4.

John
Logged
VL7.0 xfce4 Samsung RF511

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: lyx 1.6.5
« Reply #9 on: February 08, 2010, 12:23:50 am »


BTW, did I annouce I have upload the package for VL6? It seem like I cannot find it. If I forgot to annouce it then is my fault. Sorry about that. :P

I don't remember seeing one,  but that doesn't mean much - if you announced it at a point where I was busy, I may simply have missed the announcement. Anyhow, no harm done, its up now.

Paul.
Logged

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: lyx 1.6.5
« Reply #10 on: February 08, 2010, 12:25:41 am »

Thanks.  1.6.5 works fine.  Perhaps it was there (VL6 testing repository) all along and I just did not see it as it is listed above 1.6.4.

:) No, that is a peculiarity (not the only one) of Gslapt. Until I read this thread, I wasn't aware there was a 1.6.5 build up, so it only got moved in last night....

Glad it works.

Paul.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: lyx 1.6.5
« Reply #11 on: February 08, 2010, 12:44:13 am »

I try to build lyx with qt4-4.5.0_r948357-i586-1vl60 and it give me error.....not sure what is the root cause....

Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1472
Re: lyx 1.6.5
« Reply #12 on: February 08, 2010, 09:14:54 am »

No clue here, hata_ph.

Gslapt clearly shows that I am using qt4 (4.5.0_r948357-i586-1vl60) rather than qt4 (4.4.1), lyx clearly shows that I am using ver. 1.6.5 and lyx 1.6.5 works great!

John
Logged
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: lyx 1.6.5
« Reply #13 on: February 08, 2010, 06:51:52 pm »

Yes. It seem you can run lyx with qt4-4.5 but I cannot build with it. I have to use qt4-4.4.1 version.
Logged