Please support VectorLinux!

Author Topic: Lilo and Win 7 bootloader...  (Read 7747 times)

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Lilo and Win 7 bootloader...
« on: January 31, 2010, 05:53:04 am »
I installed VL on a computer for a friend. This computer already had Win 7 on it (so I set up a dual-boot). After installation, VL boots up fine but Win 7 pops up an error message saying something about the bootloader and to fix it by using the windows installation disk or something. I think I remember reading something about compatibility issues between the Win 7 bootloader and linux bootloaders. This computer doesn't get used much so the situation is not critical but should I have done something different during the installation of VL to make the dual-boot work?
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Lilo and Win 7 bootloader...
« Reply #1 on: January 31, 2010, 06:29:00 am »
Similarly, but different: I installed SOHO 6 B2 on a system with Windows 7 but used the Grub2 bootloader instead. It worked fine and Windows 7 does not complain about anything.  The only inconsistency is that Grub2 identifies the Windows installation as 'Vista' and not '7', which can be changed after-the-fact if wanted.

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Lilo and Win 7 bootloader...
« Reply #2 on: January 31, 2010, 07:24:23 am »
Microsoft changed the MBR when Vista was first released. While Grub sometimes works without problems, I've seen a number of instances where it does cause problems when combined with Vista.

As a result, I normally suggest people who want to multi-boot a Vista machine use EasyBCD. It allows the Windows boot loader to be modified and avoids any chance of upsetting the silly thing.

http://neosmart.net/dl.php?id=1

Not sure if they certify it for use with Windows 7, but I've used it with a lot of Vista installs without any problems at all.

Paul.

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1280
Re: Lilo and Win 7 bootloader...
« Reply #3 on: March 03, 2010, 08:11:28 am »
Microsoft changed the MBR when Vista was first released. While Grub sometimes works without problems, I've seen a number of instances where it does cause problems when combined with Vista.

As a result, I normally suggest people who want to multi-boot a Vista machine use EasyBCD. It allows the Windows boot loader to be modified and avoids any chance of upsetting the silly thing.

http://neosmart.net/dl.php?id=1

Not sure if they certify it for use with Windows 7, but I've used it with a lot of Vista installs without any problems at all.

Paul.


I'll report back after this weekend as far as EasyBCD and Win 7. Once the external drive shows up later this week, I'll be installing VL on it and plan on using EasyBCD to get things set up. (Thanks for the link, by the way!)
ASUS K73 Intel i3 Dual Core 2.3GHz

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: Lilo and Win 7 bootloader...
« Reply #4 on: March 03, 2010, 11:54:13 pm »
I installed VL6.0 Light on a system with windows7 and Lilo was able to detect the windows instalation with no effort on my part.
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: Lilo and Win 7 bootloader...
« Reply #5 on: March 04, 2010, 05:27:48 am »
I installed VL6.0 Light on a system with windows7 and Lilo was able to detect the windows instalation with no effort on my part.

Yeah, that's what happened with me too, but was Win7 able to boot afterwards?
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1280
Re: Lilo and Win 7 bootloader...
« Reply #6 on: April 05, 2010, 09:18:54 am »
When I first installed VL on the USB drive, I gave EasyBCD a try. I was able to boot into Windows 7, however it didn't like the USB drive for some reason. I finally installed LILO to the USB drive, changed the boot order on the notebook to USB drive first and internal hard drive second. When the USB drive is plugged in, the boot process is Linux. When it's unplugged, it goes straight to Windows.
ASUS K73 Intel i3 Dual Core 2.3GHz