VectorLinux
April 19, 2014, 02:05:24 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 20100202 - vcpufreq-2.2.0 [ VL 6.0 ]  (Read 1883 times)
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« on: February 02, 2010, 10:27:09 am »

Joe1962 has released a new stable version of vcpufreq

Quote
        |-----handy-ruler------------------------------------------------------|
vcpufreq: vcpufreq (cpufreq configuration utility)
vcpufreq:
vcpufreq: vcpufreq is a cpufreq configuration utility developed in Gambas by
vcpufreq: Joe1962 for Vector Linux. It makes it easy to change cpufreq governor
vcpufreq: and related frequency settings. It does not load the appropiate
vcpufreq: cpufreq module for your system. Includes the CLI util vcpufreq-load
vcpufreq: useful for setting the saved config on system start.
vcpufreq:
vcpufreq: Joe1962 <joe1962@users.sourceforge.net>
vcpufreq: GNU LIBRARY GENERAL PUBLIC LICENSE, Version 2, June 1991
vcpufreq:

#----------------------------------------

BUILDDATE: Wed Jan 27 12:15:00 EST 2010
PACKAGER:  Joe1962
HOST:      Linux 2.6.31.6 i686
DISTRO:    Vector Linux 6.0 SOHO Beta 2 built on DEC-02-2009
CFLAGS:   
CONFIGURE:

System Requirements
Quote
bash >= 3.0
qt >= 3.3.5
gambas-runtime >= 2.16 | gambas >= 2.16
kernel >= 2.6.20
Please test this package and report any problems on this thread
Logged

budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #1 on: February 03, 2010, 08:03:07 pm »

The latest gambas and gambas-runtime I can find in the repo is 2.15, therefore slapt-get refuses to install this version of vcpufreq.
Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #2 on: February 03, 2010, 08:13:27 pm »

As a work around, install the latest available gambas packages, and use the --no-dep option on gslapt to install the vcpufreq package.
It should work, as the bytecode has not changed in gambas 2 for a while. This should get you going while we get some updated gambas packages
Logged

budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #3 on: February 03, 2010, 08:33:19 pm »

Thank you M0E-lnx, installed without any problems with gambas 2.15 and --no-dep option.

Works great, huge thanks to Joe1962 and everyone who participated in the development for an excelent piece of software.
Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #4 on: February 04, 2010, 08:22:31 am »

Installed to my T61 (Core2Duo 2.0 GHz).

When I run it, it picks up both cores, but is showing only one CPU frequency readout. See this link:

http://www.users.waitrose.com/~paulm/vcpufreq.png

I was expecting it to show the frequency of both cores, or am I misunderstanding?

Paul.
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #5 on: February 05, 2010, 06:48:23 am »

Indeed, it should show both cores. For debugging, please post the output of the following commands run in a terminal:

cat /sys/devices/system/cpu/cpu0/cpufreq/affected_cpus
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
cat /sys/devices/system/cpu/cpu0/cpufreq/related_cpus
cat /sys/devices/system/cpu/cpu1/cpufreq/affected_cpus
cat /sys/devices/system/cpu/cpu1/cpufreq/scaling_cur_freq
cat /sys/devices/system/cpu/cpu1/cpufreq/related_cpus

Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #6 on: February 05, 2010, 07:30:42 am »

Ok, results as below:

Code:
tooth:$ cat /sys/devices/system/cpu/cpu0/cpufreq/affected_cpus
0 1

tooth:$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
800000

tooth:$ cat /sys/devices/system/cpu/cpu0/cpufreq/related_cpus
0 1

tooth:$ cat /sys/devices/system/cpu/cpu1/cpufreq/affected_cpus
0 1

tooth:$ cat /sys/devices/system/cpu/cpu1/cpufreq/scaling_cur_freq
800000

tooth:$ cat /sys/devices/system/cpu/cpu1/cpufreq/related_cpus
0 1

Hope that helps.....

Paul.
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #7 on: February 05, 2010, 07:44:54 am »

Code:
tooth:$ cat /sys/devices/system/cpu/cpu0/cpufreq/affected_cpus
0 1

Yes, that means that the frequency of both cores is linked, they cannot be separately set. When vcpufreq finds this situation, it will only handle and display the frequency for cpu0.


EDIT: For example, in my Core 2 Duo, I get the following:

Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/affected_cpus
0

cat /sys/devices/system/cpu/cpu1/cpufreq/affected_cpus
1
« Last Edit: February 05, 2010, 07:47:50 am by Joe1962 » Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #8 on: February 05, 2010, 11:52:10 am »

As a work around, install the latest available gambas packages, and use the --no-dep option on gslapt to install the vcpufreq package.
It should work, as the bytecode has not changed in gambas 2 for a while. This should get you going while we get some updated gambas packages

M0E-lnx: could you explodepkg it, edit the slack-deps and repackage as -2vl60? I am actually using gambas 2.19, but manually wrote in the wrong earlier version without actually checking if my memory served me... Embarrassed
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #9 on: February 05, 2010, 01:20:48 pm »

As a work around, install the latest available gambas packages, and use the --no-dep option on gslapt to install the vcpufreq package.
It should work, as the bytecode has not changed in gambas 2 for a while. This should get you going while we get some updated gambas packages

M0E-lnx: could you explodepkg it, edit the slack-deps and repackage as -2vl60? I am actually using gambas 2.19, but manually wrote in the wrong earlier version without actually checking if my memory served me... Embarrassed

Done
Logged

Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #10 on: February 05, 2010, 01:49:51 pm »

Thanks!
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
roarde
Vectorite
***
Posts: 488


move the needle


« Reply #11 on: June 26, 2010, 11:51:15 pm »

AFAICT, still not picking up gambas. Shouldn't it be gambas2-runtime >=2.15 | gambas2 >= 2.15 ?

If not, what do I know?

If so, kudos to daemonhunter743 for testing, noticing, and mentioning the problem.
Logged

Robert
VL Light 7.0, icewm/spacefm
Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #12 on: June 28, 2010, 05:06:23 am »

This is fixed in the vcpufreq-2.2.1 package which has so far gone under the radar, it should be up in the repo soon courtesy of nightflier.


EDIT: for more info check out the vcpufreq development thread from this post on: http://forum.vectorlinux.com/index.php?topic=980.msg74555#msg74555
« Last Edit: June 28, 2010, 05:23:46 am by Joe1962 » Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!