VectorLinux
July 26, 2014, 12:51:24 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: The script of the country of Thailand in SE Asia  (Read 1424 times)
ThaiTchr
Member
*
Posts: 6


« on: January 30, 2010, 07:15:29 pm »

I have recently installed Vector Lite on an old pc (AMD K6 processor)with the 120 Mb memory. I love how fast it is compared to when I used other Linux distributions.  I have the Pathetic Writer, AbiWord, and OpenOffice word processing programs installed on it presently.  I would like to be able to add a keyboard and font system so I can type up documents in the Thai script.  I haven't been able to find any documentation or posting anywhere to explain how I can do this with the Vector Lite operating system using any of these word processing programs.  I have been able to easily do this on other computers using the Ubuntu operating system and OpenOffice.  Is it impossible to add this language with Vector Lite?
Thank you for any input.
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #1 on: January 31, 2010, 05:45:44 am »

There might be an addon for OpenOffice for the Thai language. In OpenOffice, go to Tools > Extension manager. Near the bottom left of the Extension manager, there is a link that says "Get more extensions here...". From there you can search for what you need.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
ThaiTchr
Member
*
Posts: 6


« Reply #2 on: January 31, 2010, 09:07:35 pm »

Thanks for your suggestion Daniel.  I checked out your suggestion.  In the "plug ins" listed I don't see any mention of how to set up the keyboard and to install the fonts to allow me to use the Thai script however I see that there is mention of a Thai dictionary so I am still hopeful of finding instructions somewhere.  Actually, when I go into Open Office to the "Options" and then to "Language" it appears to me that some sort of provision is there because I see mention of fonts or a keyboard for "Th" which is the code for Thailand however it is "grayed out" on the copy of Open Office on this computer where I am trying to install it so if I can just find a bit more instruction I might be able to accomplish the task.  I do have a set of "truetype" fonts for the Thai language that I took from the laptop computer which has the Ubuntu operating system on it.  The directory there is found in /usr/share/fonts/ttf/Thai but I don't have that directory in this computer and when I tried to just paste the Thai fonts into the /usr/share/fonts/ttf/ directory I was denied permission to do it.  I looked for a similar directory in a directory made for Open Office but so far I haven't found any directory for fonts in anything for Open Office.  Any other suggestions?  Thanks again for your help.
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #3 on: February 01, 2010, 05:54:01 am »

Try copying the fonts as root. In a terminal, (as root) the command would be:

cp /usr/share/fonts/ttf/Thai/name-of-font /usr/share/fonts/ttf/
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #4 on: February 01, 2010, 09:28:51 pm »

After you copy the Thai fonts into /usr/share/fonts/ttf/ you should run
fc-cache
as root in a terminal. I think you also need to restart X.

The fonts will be usable by all users. If you are the only user, you can copy them into ~/.fonts as user. I then run fc-cache but I'm not sure it's necessary in this case. I haven't found it necessary to restart X when I copy fonts to ~/.fonts. The fonts will be available only to you.

If you need to save disk space, you can create symlinks in ~/.fonts instead of copying the fonts there.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
ThaiTchr
Member
*
Posts: 6


« Reply #5 on: February 01, 2010, 10:15:17 pm »

Thank you both for your instructions.  As a newbe I need to ask you about using the copy command that Daniel gave me.  Don't I need to copy the truetype Thai fonts into the directory /usr/share/fonts/ttf/Thai before I give the command cp /usr/share/fonts/ttf/Thai/name of font /usr/share/ttf/  ?     As you might guess, I haven't used the cp command before.  The last time I remember doing a copy command from a prompt was when I was using a DOS prompt and two floppy disk drives about 15 years ago?? or so before the first copy of Windows came out.  Right now I have the Thai fonts "parked" in a directory under "MyDocuments" folder.

Thanks again for your help.
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #6 on: February 02, 2010, 01:40:18 pm »

Ah, sorry I think I might have misunderstood where the font files were located. Using the cp command in linux is pretty much the same as using copy in windows. Usage is: cp /path/where/stuff/is/now/file.txt /path/where/stuff/is/being/copied/to/

You can probably figure out how to use it to your need now. Another option is to open a filemanager as root. As root in a terminal, enter the command for your filemanager (examples: konqueror , thunar , pcmanfm -t ). You should then be able to copy the files that way.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
ThaiTchr
Member
*
Posts: 6


« Reply #7 on: February 02, 2010, 08:47:27 pm »

Thanks for your clarification Daniel.  I didn't read your posting carefully so I first (after logging into a terminal as "root") tried copying the fonts to a directory that did not exist (/usr/share/ttf/).  That couldn't be done  so I used the mkdir command to create it. Then I copied the fonts into this new directory using the cp command.  I copied all the truetype Thai fonts I have into it, rebooted, and then went into OpenOffice to see what changes had been made.   I could not find the new fonts listed in the "writer" program so I did a bit of checking and realized that you had said to copy the fonts into the /usr/share/fonts/ttf/ directory.  I tried doing this using the cp command but each time I did I got the message " cp cannot create regular file  '/usr/share/fonts/ttf/'  : Is a directory "   That did not make any sense to me so I tried copying one of the fonts into another part of the system. I was able to do that without any problems so I think something is preventing me from copying the fonts into that directory that has all the system fonts in it.  What do you suggest now?
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #8 on: February 03, 2010, 07:52:04 am »

The command to copy the fonts from /usr/share/ttf (if that's where they are now) would be (as root):

cp /usr/share/ttf/name-of-font.ttf /usr/share/fonts/ttf/

Try that and see if it works.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
ThaiTchr
Member
*
Posts: 6


« Reply #9 on: February 03, 2010, 08:43:56 pm »

Thank you for your help Daniel.  I looked at what you had written and thought to myself that I had tried what you had written.  Then I noticed that you had one part of the path to the fonts that was different than what I had typed.  You had used TTF but I had typed ttf.   When I made the correction there was no problem copying the fonts to the directory.  I didn't realize the names were "case sensitive" although now that I have seen the difference in results I remember reading in a Linux tutorial that the directory names are case sensitive.

Now that I have successfully copied the fonts to the correct spot they are available in OpenOffice Writer. I am able to "insert" any character using the "Insert" "Special Character" menu.

Now my question is how do I change my keyboard layout so I can easily switch it to the Thai keyboard layout and back to English to input file names, etc which require English.  In Ubuntu I think I found a "widget" for the desktop that allowed me to switch keyboard layouts.  I will look for such a feature in my Vector Lite system because I don't see any provision in the program for the superuser that allows the keyboard to be set up for easily switching keyboards.  If you know of any system please let me know.

Thanks again for your help.  It is really a blessing to me  Smiley
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #10 on: February 04, 2010, 04:40:16 am »

I think you can change the keyboard layout in VASM. In the menu under System, there will be an entry for Vector Control Center. That's it. I'm not at my VL computer right now so I can't really give you any more specific instructions right now.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
ThaiTchr
Member
*
Posts: 6


« Reply #11 on: February 04, 2010, 06:00:51 am »

Thanks for your note Daniel.  I will check out the suggestion you made.  I also have a reference to editing the xorg.conf in /etc/x11/ directory to change the keyboard.  One of these will work.

Thanks again for your help in getting this set up.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!