Please support VectorLinux!

Author Topic: desktop and gui kinda broken  (Read 620 times)

degarb

  • Member
  • *
  • Posts: 38
desktop and gui kinda broken
« on: February 04, 2010, 11:27:11 am »
After installing vector linux, there is a bad flaw.  You right click on desktop and no create launcher.

And when you right click on any menu (start>cat>menu item)  you cannot edit or see properties.

This irritated me.  So I right clicked desktop and hit prefs and enabled show menu.    Unfortunately, this option totally broke the desktop as now I cannot copy and paste copy of on desktop to edit with leaf pad.


How do I run the desktop config utility?????????????????????

Rollback possible?

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: desktop and gui kinda broken
« Reply #1 on: February 04, 2010, 11:59:00 am »
It is not a flaw. It is the way it is. VL Light is not, nor does it pretend to be, mswindows.

To go back to the way it was, Click Menu > Home. Pcmanfm will open. Click Edit > Preferences > Desktop tab, un-check box for "Show menus...", click OK.

The menu is defined by text files in the ".icewm" folder in your home dir. Note the leading dot, which means that it is normally hidden from the file manager. In pcmanfm, click View and check box for showing hidden items.


GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: desktop and gui kinda broken
« Reply #2 on: February 04, 2010, 09:27:24 pm »
If you want to put a launcher icon on your IceWM desktop, you put a *.desktop file in ~/Desktop. There are two ways you can do this.

** If the application is listed in the "Start" menu, there will be a *.desktop file in /usr/share/applications. You can simply copy that file into your ~/Desktop directory.

** Another way to add an icon to the desktop is to create one yourself. Look at the files already in ~/Desktop and use them as a model for adding another *.desktop file to ~/Desktop.

After you make these changes, you need to restart IceWM (Start menu, Logout, then type startx at the prompt). You should now have the desired icons on the desktop.
--GrannyGeek
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller