VectorLinux
August 23, 2014, 03:10:04 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [solved] Trouble with new NVIDIA GT240 video card.  (Read 3318 times)
DJLinux
Member
*
Posts: 7


« on: February 06, 2010, 03:32:30 pm »

hello i use the latest version of VectorLinux with a NVIDIA Ti 4200 video card without any problems.
now i got a new box with a NVIDIA GT240 card and the loading of the nvidia driver will fail.

is it to new for the driver included in VectorLinux ?

if so has anyone compiled the curent driver from NVIDIA site with VectorLinux?

thank you for any info
and sorry about my bad english

i tested CUDA and OpenCL (not OpenGL) on windows and would use CUDA with Linux too.

Joshy
« Last Edit: February 06, 2010, 04:12:44 pm by DJLinux » Logged
DJLinux
Member
*
Posts: 7


« Reply #1 on: February 06, 2010, 04:16:18 pm »

i compiled the latest driver 190.53 without any problems  Smiley

(from glxinfo)
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 240/PCI/SSE2
OpenGL version string: 3.2.0 NVIDIA 190.53
OpenGL shading language version string: 1.50 NVIDIA via Cg compiler

i like NVIDIA's Linux support and the good job of the VectorLinux team

now starting with CUDA under Linux

thank you

Joshy
« Last Edit: September 12, 2010, 02:00:30 am by DJLinux » Logged
DJLinux
Member
*
Posts: 7


« Reply #2 on: September 12, 2010, 02:10:20 am »

Hello i'm again :-)
now i pluged a ordinary PS2 mouse on my box and i use this section
Code:
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "PS/2"
    Option "Device" "/dev/psaux"
#    Option "Device" "/dev/input/mice" <-- same result no mouse wheel
    Option "ZAxisMapping"  "4 5"
EndSection
but i don't get the mouse wheel working

Any idea what are wrong ?

Thank you

Joshy
the whole xorg.config
Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 256.53  (buildmeister@builder101)  Fri Aug 27 21:33:39 PDT 2010

Section "ServerLayout"
    Identifier     "Simple Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
    Option         "Xinerama" "0"
EndSection

Section "Files"
#    ModulePath "/usr/lib/xorg/modules"
    RgbPath         "/usr/share/X11/rgb"
    FontPath        "/usr/share/fonts/local/"
    FontPath        "/usr/share/fonts/misc/"
    FontPath        "/usr/share/fonts/OTF/"
    FontPath        "/usr/share/fonts/TTF/"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/CID/"
    FontPath        "/usr/share/fonts/Speedo/"
    FontPath        "/usr/share/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/75dpi/"
    FontPath        "/usr/share/fonts/100dpi/"
    FontPath        "/usr/share/fonts/cyrillic/"
EndSection

Section "Module"
    Load           "dbe"  # Double buffer extension
    SubSection     "extmod"
        Option         "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load           "type1"
    Load           "freetype"
    #Load        "speedo"
    Load           "glx"
EndSection

Section "InputDevice"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.
#    Option     "Protocol"      "Xqueue"
# Set the keyboard auto repeat parameters.  Not all platforms implement
# this.
#    Option     "AutoRepeat"    "500 5"
# Specifiy which keyboard LEDs can be user-controlled (eg, with xset(1)).
#    Option     "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#    Option     "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a European
# keyboard, you will probably want to use one of:
#
#    Option     "XkbModel"      "pc102"
    Option     "XkbModel"      "pc105"
#
# If you have a Microsoft Natural keyboard, you can use:
#
#    Option     "XkbModel"      "microsoft"
#
# If you have a US "windows" keyboard you will want:
#
#    Option     "XkbModel"      "pc104"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#
#    Option     "XkbLayout"     "de"
#
# or:
#
    Option     "XkbLayout"     "de"
    Option     "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#
#    Option     "XkbOptions"    "ctrl:swapcaps"
# These are the default XKB settings for X.Org
#
#    Option     "XkbRules"      "xorg"
#    Option     "XkbModel"      "pc105"
#    Option     "XkbLayout"     "us"
#    Option     "XkbVariant"    ""
#    Option     "XkbOptions"    ""
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "PS/2"
# The mouse device.  The device is normally set to /dev/mouse,
#   Option "Device" "/dev/mouse"
    Option "Device" "/dev/psaux"
#    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping"  "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics W2242"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 240"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1680x1050 +0+0; 800x600 +0+0; 640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Logged
bigpaws
Vectorian
****
Posts: 1847


« Reply #3 on: September 12, 2010, 03:10:49 am »

Quote
    Option         "Protocol" "PS/2"
    Option "Device" "/dev/psaux"
#    Option "Device" "/dev/input/mice" <-- same result no mouse wheel
    Option "ZAxisMapping"  "4 5"

See that #? That is a comment which means that it is not read.
Remove the # and you should be up and running. If that does
not fix this problem try using IMPS/2 vs PS/2

HTH

Bigpaws
Logged
DJLinux
Member
*
Posts: 7


« Reply #4 on: September 12, 2010, 03:30:27 am »

Hello Bigpaws, you are right.

Option "Protocol" "IMPS/2"

was the right key

thank you

Joshy

by the way
i know about the "#" in scripts, it was only to say i tried both mouse drivers with the same result.
« Last Edit: September 12, 2010, 03:32:22 am by DJLinux » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!