VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Kernel panic while watching flash video  (Read 8269 times)

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Kernel panic while watching flash video
« on: February 13, 2010, 10:10:48 pm »

It's happening on my MSI laptop, with kernels 2.6.32.4, 2.6.32.7 and 2.6.32.8. I also get the same thing with Ubuntu, so my kernel build shouldn't be the main cause. Also I ran memtest overnight and it returned no errors. The heat shouldn't be the problem either(After restarting computer after a panic I checked the temperature in HardInfo and it never exceeded 55 C - that is if the sensors tab in hardinfo shows cpu temperature, which I really hope it does ;))
The only time this panic happens is when I watch any flash video - imem, vodpod, veoh and a bunch of other websites. Didn't have this happen on YouTube though, maybe because I haven't watched it that much.
A panic happens more often if I have my cpu in performance mode rather than ondemand.
My flash player version is 10 r 12, but the same panic also happened with 10 r 42. It happens both in opera and firefox, and also in Ubuntu 9.10.
Usually 15 minutes of watching flash video in performance mode is enough for a panic. In ondemand it usually takes about an hour.
I have no problem watching regular videos with xine or mplayer(xine froze once, but it wasn't a panic - scroll and caps lock were not blinking).

I turned a video on and switched to the first workspace, and surely after about 15 minutes I had a panic. I wrote the message from cli on a piece of paper, so there might be minor errors(although I tried not to make any). After that I added noapic option to lilo append line, which didn't help at all. The first output is without noapic, where the second one is with it.

Hope I didn't miss anything. I tried googling but had no luck.
I am not really sure what to do about this - do I ask abut it here, or should I submit a report at kernel.org?

Thank you for your time.

Code: [Select]
[<c102cff6>] ? release_console_sem+0x1a6/0x1c0
[<c10266fb>] default_wake_function+0xb/0x10
[<c1040056>] autoremove_wake_function+0x16/0x40
[<c1021008>] __wake_up_common+0x48/0x70
[<c1021a37>] __wake_up+0x37/0x50
[<c102d052>] printk_tick+0x42/0x50
[<c10361bd>] update_process_times+0x3d/0x60
[<c104cfb6>] tick_sched_timer+0x56/0x1e0
[<c1042cea>] ? _remove_hrtimer+0x2a/0xa0
[<c1053ae7>] ? is_module_text_address+0x37/0x40
[<c104cf60>] ? tick_sched_timer+0x0/0x1e0
[<c1042eee>] __run_hrtimer+0x3e/0x90
[<c10431bc>] hrtimer_interrupt+0x10c/0x1b0
[<c1005946>] ? dump_trace+0x86/0xd0
[<c1014a37>] smp_apic_timer_interrupt+0x57/0x90
[<c15f08df>] ? _spin_unlock_irqrestore+0x1f/0x30
[<c10036b6>] apic_timer_interrupt+0x2a/0x30
[<c102c984>] ? panic+0xd4/0x100
[<c100df25>] mce_panic+0x1b5/0x1c0
[<c100e657>] do_mashine_check+0x5c7/0x840
[<c100e090>] ? do_mashine_check+0x0/0x840
[<c15f0cd6>] error_code+0x66/0x6c
[<c100e090>] ? do_mashine_check+0x0/0x840

---[end trace a31ef56b30f51bf3]---

Code: [Select]
[<c10264e9>] try_to_wake_up+0x69/0x270
[<c1020554>] ? target_load+0x24/0x50
[<c10266fb>] default_wake_function+0xb/0x10
[<c1040056>] autoremove_wake_function+0x16/0x40
[<c1021008>] __wake_up_common+0x48/0x70
[<c1021a37>] __wake_up+0x37/0x50
[<c102d052>] printk_tick+0x42/0x50
[<c10361bd>] update_process_times+0x3d/0x60
[<c104cfb6>] tick_sched_timer+0x56/0x1e0
[<c1042cea>] ? _remove_hrtimer+0x2a/0xa0
[<c1042e90>] ? hrtimer_wakeup+0x0/0x20
[<c104cf60>] ? tick_sched_timer+0x0/0x1e0
[<c1042eee>] __run_hrtimer+0x3e/0x90
[<c10431bc>] hrtimer_interrupt+0x10c/0x1b0
[<c1005946>] ? dump_trace+0x86/0xd0
[<c1014a37>] smp_apic_timer_interrupt+0x57/0x90
[<c10036b6>] apic_timer_interrupt+0x2a/0x30
[<c102c984>] ? panic+0xd4/0x100
[<c100df25>] mce_panic+0x1b5/0x1c0
[<c100e657>] do_mashine_check+0x5c7/0x840
[<c100e090>] ? do_mashine_check+0x0/0x840
[<c15f0cd6>] error_code+0x66/0x6c
[<c100e090>] ? do_mashine_check+0x0/0x840

---[end trace 79c5e100afbb2f8c]---


UPDATE:
Just had another panic, this time just using flash player, not watching flash video.
« Last Edit: February 19, 2010, 01:11:31 am by budulay »
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

w2ibc

  • Packager
  • Vectorite
  • ****
  • Posts: 114
  • GAHHHHHH!!!!!
    • W2IBC.com
Re: Kernel panic while watching flash video
« Reply #1 on: April 09, 2010, 12:24:11 pm »

im curious to what dmesg prints out.

on this box here i cant run ubuntu 9.10 as firefox/opera and flash will cause a "panic" and force me into a hard reboot.
ubuntu 9.10 dmesg would give me a flood of
[37814.489561] hda-intel: spurious response 0x0:0x0, last cmd=0x1320011

dmesg on VL KDE Classic gives me a flood of
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x14

however on VL i do not get the "panic" just sometimes on reboots sound dose not load right forcing me into rebooting until it dose load correctly (sometimes up to 20 reboots)
Logged
Linux Registered User #481509.

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: Kernel panic while watching flash video
« Reply #2 on: April 09, 2010, 08:16:03 pm »

Interesting.
 I'd like to know if you can monitor the CPU and RAM, just before you get the panic, and please let us know if either of those gets pegged.
Logged

w2ibc

  • Packager
  • Vectorite
  • ****
  • Posts: 114
  • GAHHHHHH!!!!!
    • W2IBC.com
Re: Kernel panic while watching flash video
« Reply #3 on: April 10, 2010, 11:50:54 pm »

Interesting.
 I'd like to know if you can monitor the CPU and RAM, just before you get the panic, and please let us know if either of those gets pegged.

wish i had thought of that back when i did have ubuntu on here.

is VL using pulse audio at all? im not sure. I know i had problems with ubuntu when they moved to pulse and each version of ub. the sound problems just got worse till 9.10 it was a mess for me.
Logged
Linux Registered User #481509.

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: Kernel panic while watching flash video
« Reply #4 on: April 20, 2010, 09:59:56 pm »

Sorry I am a bit slow in the response to this. Been busy as can be. The pulse audio question is out of my territory. That will have to be answered by someone else. I know on my system it seems to be using pulse, according to Kmix, I have to push the PCM up in order to get sound.
Logged

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: Kernel panic while watching flash video
« Reply #5 on: May 09, 2010, 11:06:20 am »

Sorry for not replying sooner - I guess I assumed that this thread would stay unanswered forever ;)

I am not sure what to look for in dmesg:
it gives me 3 ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x14
a few wireless errors and 20 more pages of output..
didn't see any floods or anything, though.
the only somewhat repeated message is:
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Surround Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Center Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave LFE Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Side Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Speaker Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Mono Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Line-Out Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave PCM Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Surround Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Center Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave LFE Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Side Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Mono Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave Line-Out Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1658: Cannot find slave PCM Playback Switch, skipped

So is there anything in particular that I should look for?
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: Kernel panic while watching flash video
« Reply #6 on: May 11, 2010, 08:44:23 pm »

Seems like a flash thing. Try rolling back to a previous version of Flash and see if that works.
Logged

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: Kernel panic while watching flash video
« Reply #7 on: May 17, 2010, 12:40:03 pm »

I tried in on 10r12 and 10r42, and had the same result.

Also I got a panic once while trying to mirror a video in kino.

I will upgrade my kernel again and see if that will help.
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!