VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: 20100225 pac-0.9.6.1 [VL6.0]  (Read 1411 times)

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
20100225 pac-0.9.6.1 [VL6.0]
« on: February 25, 2010, 12:17:35 pm »

Daniel has built a new Pac package for VectorLinux 6.0.
   
      
   
Code: [Select]
pac: PAC Manager (SSH/Telnet)
pac:
pac: PAC is a Perl/GTK Gnome replacement for SecureCRT/Putty/etc... It
pac: provides a GUI to configure SSH/Telnet connections: users, passwords,
pac: EXPECT regular expressions, macros, etc.
pac:
pac:
pac: License: GPLv3
pac: Authors: perseo22
pac: Website: http://sourceforge.net/projects/pacmanager
   
   After testing this package please stop back here and let us know how it works for you.
   
Logged

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 20100225 pac-0.9.6.1 [VL6.0]
« Reply #1 on: February 25, 2010, 01:58:45 pm »

I'm having several problems with this. First, it doesn't seem to show up in Gslapt (even though it is obviously registered, since the announce software found it).

Having checked the deps manually and downloaded it, I'm getting a lot of errors. First on YAML, which I've fixed, but now on Gtk2.pm, which I've not been able to fix so far.

I think you need to add the necessary Perl modules to the dep list, or nobody will be able to use it without a lot of pain.

Paul.
Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
    • Joe1962's Website
Re: 20100225 pac-0.9.6.1 [VL6.0]
« Reply #2 on: February 25, 2010, 02:36:58 pm »

Me too (VL6 SOHO B3):
Code: [Select]
joe1962:$ pac
Can't locate YAML.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0/i586-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl . /usr/share/pac /usr/share/pac) at /usr/share/pac/PACMain.pm line 32.
BEGIN failed--compilation aborted at /usr/share/pac/PACMain.pm line 32.
Compilation failed in require at /usr/bin/pac line 36.
BEGIN failed--compilation aborted at /usr/bin/pac line 36.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: 20100225 pac-0.9.6.1 [VL6.0]
« Reply #3 on: February 25, 2010, 02:48:07 pm »

I have no idea what the dependencies are other than vte, perl, and libgnome. How do I add Perl modules to the dep list?
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 20100225 pac-0.9.6.1 [VL6.0]
« Reply #4 on: February 26, 2010, 12:03:51 pm »

I have no idea what the dependencies are other than vte, perl, and libgnome. How do I add Perl modules to the dep list?

Sorry, I'm not exactly an expert on Perl. Maybe someone else will be better able to answer that.

On the other hand, you must have had to add a number of modules to the standard 6.0 Perl install to get it to run. Have you got a list of the modules that you added?

Paul.
Logged

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: 20100225 pac-0.9.6.1 [VL6.0]
« Reply #5 on: February 26, 2010, 01:38:34 pm »

I didn't add anything. It came as an RPM so I just opened it up and repackaged it as a VL package. I did this from my 5.9.1 SOHO machine which doesn't have a new enough gtk2 package so I knew I wouldn't be able to get it to run. The documentation (what little I could find) showed just those three dependencies.
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM